Skip Menu |
 

This queue is for tickets about the PPM-Make CPAN distribution.

Report information
The Basics
Id: 119132
Status: resolved
Priority: 0/
Queue: PPM-Make

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.9903
Fixed in: (no value)



Subject: Non-ASCII in author names causing problems
Download (untitled) / with headers
text/plain 654b
A ppd file which contains (some kind of?) non-ASCII characters cannot be installed with ppm. And it seems that using make_ppm it's possible to create such kind of ppd files. To reproduce, build one of Ingy's modules: C:\Users\IEUser>make_ppm IO::All ... C:\Users\IEUser>ppm install IO-All.ppd Installing package 'IO-All.ppd'... Error installing package 'IO-All.ppd': Could not locate a PPD file for package IO-All.ppd Problem seems to be the "ö" in the author name. It seems to be converted to some strange encoding (cp437?) and put into the AUTHOR field, thus making the XML invalid. If I remove this strange character, then ppm installation works.
Download (untitled) / with headers
text/plain 839b
On 2016-12-05 17:03:08, SREZIC wrote: Show quoted text
> A ppd file which contains (some kind of?) non-ASCII characters cannot > be installed with ppm. And it seems that using make_ppm it's possible > to create such kind of ppd files. > > To reproduce, build one of Ingy's modules: > > C:\Users\IEUser>make_ppm IO::All > ... > C:\Users\IEUser>ppm install IO-All.ppd > Installing package 'IO-All.ppd'... > Error installing package 'IO-All.ppd': Could not locate a PPD file for > package IO-All.ppd > > Problem seems to be the "ö" in the author name. It seems to be > converted to some strange encoding (cp437?) and put into the AUTHOR > field, thus making the XML invalid. If I remove this strange > character, then ppm installation works.
If it matters: this was done with the latest StrawberryPerl 5.24.0.1 on a Win7 VM. German locale was in effect.
On Tue Dec 06 07:08:36 2016, SREZIC wrote: Show quoted text
> On 2016-12-05 17:03:08, SREZIC wrote:
> > A ppd file which contains (some kind of?) non-ASCII characters cannot > > be installed with ppm. And it seems that using make_ppm it's possible > > to create such kind of ppd files. > > > > To reproduce, build one of Ingy's modules: > > > > C:\Users\IEUser>make_ppm IO::All > > ... > > C:\Users\IEUser>ppm install IO-All.ppd > > Installing package 'IO-All.ppd'... > > Error installing package 'IO-All.ppd': Could not locate a PPD file > > for > > package IO-All.ppd > > > > Problem seems to be the "ö" in the author name. It seems to be > > converted to some strange encoding (cp437?) and put into the AUTHOR > > field, thus making the XML invalid. If I remove this strange > > character, then ppm installation works.
> > If it matters: this was done with the latest StrawberryPerl 5.24.0.1 > on a Win7 VM. German locale was in effect.
Thanks for the report. Shipped 0.9904 with a fix to encode non-ascii characters as numerical entities. Hope this helps.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.