Skip Menu |
 

This queue is for tickets about the Perl-Critic-Pulp CPAN distribution.

Report information
The Basics
Id: 118959
Status: open
Priority: 0/
Queue: Perl-Critic-Pulp

People
Owner: Nobody in particular
Requestors: paul [...] city-fan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 91
Fixed in: (no value)



Subject: Modules::ProhibitPOSIXimport broken with Perl < 5.10
Download (untitled) / with headers
text/plain 656b
Version 91 introduced a change in Modules::ProhibitPOSIXimport that used the defined-or operator, which was introduced in Perl 5.10.0. As a result, the module (and test suite) fail quite spectacularly on Perl 5.8.x or earlier. The following change works for me: --- lib/Perl/Critic/Policy/Modules/ProhibitPOSIXimport.pm +++ lib/Perl/Critic/Policy/Modules/ProhibitPOSIXimport.pm @@ -121,7 +121,8 @@ sub _parse_args { my @ret; while (@first) { - my $aref = shift @first // next; + my $aref = shift @first; + next unless defined($aref); if (@$aref == 1) { my $elem = $aref->[0]; if ($elem->isa('PPI::Structure::List')) {
Subject: Re: [rt.cpan.org #118959] Modules::ProhibitPOSIXimport broken with Perl < 5.10
Date: Sun, 27 Nov 2016 13:08:39 +1100
To: "paul\ [...] city-fan.org via RT" <bug-Perl-Critic-Pulp [...] rt.cpan.org>
From: Kevin Ryde <user42_kevin [...] yahoo.com.au>
Download (untitled) / with headers
text/plain 196b
"paul@city-fan.org via RT" <bug-Perl-Critic-Pulp@rt.cpan.org> writes: Show quoted text
> > Version 91 introduced a change in Modules::ProhibitPOSIXimport that > used the defined-or operator,
Thanks, fixed in 92.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.