Skip Menu |
 

This queue is for tickets about the Net-SIP CPAN distribution.


Subject: Test failures
Download (untitled) / with headers
text/plain 664b
Subject: libnet-sip-perl_0.700-1_amd64.build
Download libnet-sip-perl_0.700-1_amd64.build
application/octet-stream 87.6k

Message body not shown because it is not plain text.

Subject: libnet-sip-perl_0.700-1_amd64.build.highload

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 189b
Am Do 17. Nov 2016, 15:47:22, GREGOA schrieb: Show quoted text
> 0.690 and 0.691 fail the test suite sometimes:
Thanks for reporting. It should be fixed in 0.701 where a bug in async TCP connect was fixed.
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Fri, 18 Nov 2016 02:05:23 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 3.6k
On Thu, 17 Nov 2016 16:34:38 -0500, Steffen Ullrich via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=118824 > > > Am Do 17. Nov 2016, 15:47:22, GREGOA schrieb:
> > 0.690 and 0.691 fail the test suite sometimes:
> Thanks for reporting. It should be fixed in 0.701 where a bug in async TCP connect was fixed.
Wow, that was fast - thanks! Unfortunately I still get test failures (without artificial load), once in two test runs (the first succeeded …): t/07_call_on_hold.t ..................... 1..64 # ------- test with family ip4 transport udp # uas >> OK # << ok 1 - [uas] OK # uas >> Listening # << ok 2 - [uas] Listening # uac >> OK # << ok 3 - [uac] OK # uac >> Started # << ok 4 - [uac] Started # uas >> Call accepted # << ok 5 - [uas] Call accepted # uac >> Start RTP # << ok 6 - [uac] Start RTP # uac >> RTP#50# # << ok 7 - [uac] RTP\#50\# # uas >> got rtp packet#50 # Starting ReInvite # << ok 8 - [uas] got rtp packet\#50 ok 9 - [uas] Starting ReInvite # uac >> Got ReInvite # << ok 10 - [uac] Got ReInvite # uas >> Start RTP # << ok 11 - [uas] Start RTP # uas >> RTP#50# # << ok 12 - [uas] RTP\#50\# # uac >> got rtp packet#50 # Send BYE # << ok 13 - [uac] got rtp packet\#50 ok 14 - [uac] Send BYE # uas >> Received BYE after 0 bytes read # << ok 15 - [uas] Received BYE after 0 bytes read # uac >> BYE done # << ok 16 - [uac] BYE done # ------- test with family ip6 transport udp # uas >> OK # << ok 17 - [uas] OK # uas >> Listening # << ok 18 - [uas] Listening # uac >> OK # << ok 19 - [uac] OK # uac >> Started # << ok 20 - [uac] Started # uas >> Call accepted # << ok 21 - [uas] Call accepted # uac >> Start RTP # << ok 22 - [uac] Start RTP # uac >> RTP#50# # << ok 23 - [uac] RTP\#50\# # uas >> got rtp packet#50 # Starting ReInvite # << ok 24 - [uas] got rtp packet\#50 ok 25 - [uas] Starting ReInvite # uac >> Got ReInvite # << ok 26 - [uac] Got ReInvite # uas >> Start RTP # << ok 27 - [uas] Start RTP # uas >> RTP#50# # << ok 28 - [uas] RTP\#50\# # uac >> got rtp packet#50 # Send BYE # << ok 29 - [uac] got rtp packet\#50 ok 30 - [uac] Send BYE # uas >> Received BYE after 0 bytes read # << ok 31 - [uas] Received BYE after 0 bytes read # uac >> BYE done # << ok 32 - [uac] BYE done # ------- test with family ip4 transport tcp # uas >> OK # << ok 33 - [uas] OK # uas >> Listening # << ok 34 - [uas] Listening # uac >> OK # << ok 35 - [uac] OK # uac >> Started # << ok 36 - [uac] Started not ok 37 - [uas] Call accepted # Failed test '[uas] Call accepted' # at ./t/testlib.pl line 173. not ok 38 - fatal error at ./t/testlib.pl line 174. # # Failed test 'fatal error at ./t/testlib.pl line 174. # ' # at ./t/testlib.pl line 30. # Looks like you planned 64 tests but ran 38. # Looks like you failed 2 tests of 38 run. # Looks like your test exited with 1 just after 38. Dubious, test returned 1 (wstat 256, 0x100) Failed 28/64 subtests Please tell me if there's anything I can try to help you narrow down the problem. /* As a side note: lintian (our static package analyzer) finds some spelling mistakes in the POD: I: libnet-sip-perl: spelling-error-in-manpage usr/share/man/man3/Net::SIP::Dispatcher::Eventloop.3pm.gz completly completely I: libnet-sip-perl: spelling-error-in-manpage usr/share/man/man3/Net::SIP::Leg.3pm.gz specifiy specify I: libnet-sip-perl: spelling-error-in-manpage usr/share/man/man3/Net::SIP::SocketPool.3pm.gz orgin origin */ Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: Flying Pickets: Deep Feeling
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 429b
Am Do 17. Nov 2016, 20:05:46, gregoa@debian.org schrieb: Show quoted text
> > Unfortunately I still get test failures (without artificial load), > once in two test runs (the first succeeded …):
I've detected and fixed some other race conditions in TCP handling. Should be hopefully be fixed now. Show quoted text
> As a side note: lintian (our static package analyzer) finds some > spelling mistakes in the POD:
I've fixed these too. Thanks a lot, Steffen
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Fri, 18 Nov 2016 16:51:42 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 1000b
On Fri, 18 Nov 2016 04:02:20 -0500, Steffen Ullrich via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=118824 > >
> > Unfortunately I still get test failures (without artificial load), > > once in two test runs (the first succeeded …):
> I've detected and fixed some other race conditions in TCP handling. Should be hopefully be fixed now.
Thanks! 0.702 indeed looks fine on my laptop, with and without additional load. I've uploaded it to Debian/unstable right now and I'll keep an eye of the results on the various build and test services. Show quoted text
> > As a side note: lintian (our static package analyzer) finds some > > spelling mistakes in the POD:
> I've fixed these too.
Thanks. Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: The Eagles: New kid in town
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #118824] Test failures
Date: Sat, 19 Nov 2016 22:03:50 +0100
To: gregor herrmann via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 1.1k
On Fri, 18 Nov 2016 10:52:02 -0500, gregor herrmann via RT wrote: Show quoted text
Show quoted text
> I've uploaded it to Debian/unstable right now and I'll keep an eye of > the results on the various build and test services.
The results are a bit mixed: success on the buildd and the ci.debian.net server: https://buildd.debian.org/status/logs.php?pkg=libnet-sip-perl&ver=0.702-1 https://ci.debian.net/packages/libn/libnet-sip-perl/unstable/amd64/ But failures on the 3 reproducible-build machines: https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/libnet-sip-perl.html --> https://tests.reproducible-builds.org/debian/rbuild/unstable/amd64/libnet-sip-perl_0.702-1.rbuild.log https://tests.reproducible-builds.org/debian/rbuild/unstable/i386/libnet-sip-perl_0.702-1.rbuild.log https://tests.reproducible-builds.org/debian/rbuild/unstable/armhf/libnet-sip-perl_0.702-1.rbuild.log Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: John Zorn & Masada: Mochin
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 858b
Am Sa 19. Nov 2016, 16:04:19, gregoa@debian.org schrieb: Show quoted text
> On Fri, 18 Nov 2016 10:52:02 -0500, gregor herrmann via RT wrote: > >
> > I've uploaded it to Debian/unstable right now and I'll keep an eye of > > the results on the various build and test services.
> > The results are a bit mixed: > success on the buildd and the ci.debian.net server: > https://buildd.debian.org/status/logs.php?pkg=libnet-sip- > perl&ver=0.702-1 > https://ci.debian.net/packages/libn/libnet-sip-perl/unstable/amd64/
This looks for me like a very strange network setup on these systems where localhost IP 127.0.0.1 does not exist or cannot properly used to bind a socket (to a random port). I think I've seen similar strange setups in some container environments. Could you please check the setup of these systems?
CC: reproducible-builds [...] lists.alioth.debian.org
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Sun, 20 Nov 2016 17:40:51 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 1.8k
On Sun, 20 Nov 2016 10:51:44 -0500, Steffen Ullrich via RT wrote: Show quoted text
Show quoted text
Show quoted text
> This looks for me like a very strange network setup on these > systems where localhost IP 127.0.0.1 does not exist or cannot > properly used to bind a socket (to a random port).
Indeed, I was surprised about those messages as well. Show quoted text
> I think I've > seen similar strange setups in some container environments. Could > you please check the setup of these systems?
I can't check myself but I've added the Debian reproducible build folks in Cc who can probably tell us more about the setup or might even have an idea about the failures. I don't think it's a general "can't bind to 127.0.0.1" case because then we'd see tons of failure for all packages with some kind of network tests. But somethings weird indeed … Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: Aimee Mann: Susan
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

From: ntyni [...] iki.fi
Download (untitled) / with headers
text/plain 806b
On Sun Nov 20 10:51:43 2016, SULLR wrote: Show quoted text
> This looks for me like a very strange network setup on these systems > where localhost IP 127.0.0.1 does not exist or cannot properly used to > bind a socket (to a random port). I think I've seen similar strange > setups in some container environments. Could you please check the > setup of these systems?
I believe the issue is that those systems have no 'real' network interfaces, only 'lo' (so 127.0.0.1 does exist). This can be easily reproduced on Linux systems with 'unshare -n' and 'ip li set lo up'. I think it's about IO::Socket::IP passing getaddrinfoflags => AI_ADDRCONFIG by default. IO::Socket::SSL had similar problems in the past, worked around in 2.024 by setting GetAddrInfoFlags to 0. Hope this helps a bit, -- Niko Tyni ntyni@debian.org
Download (untitled) / with headers
text/plain 518b
Show quoted text
> > I believe the issue is that those systems have no 'real' network > interfaces, only 'lo' (so 127.0.0.1 does exist). > > This can be easily reproduced on Linux systems with 'unshare -n' and > 'ip li set lo up'. > > I think it's about IO::Socket::IP passing getaddrinfoflags => > AI_ADDRCONFIG by default. > > IO::Socket::SSL had similar problems in the past, worked around in > 2.024 by setting GetAddrInfoFlags to 0.
I've tried to put the same workarounds now in Net::SIP 0.806. Let's see how this works out.
CC: ntyni [...] debian.org
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Tue, 6 Dec 2016 20:46:10 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 1.2k
On Tue, 06 Dec 2016 08:36:19 -0500, Steffen Ullrich via RT wrote: Show quoted text
Show quoted text
> > I think it's about IO::Socket::IP passing getaddrinfoflags => > > AI_ADDRCONFIG by default. > > > > IO::Socket::SSL had similar problems in the past, worked around in > > 2.024 by setting GetAddrInfoFlags to 0.
> > I've tried to put the same workarounds now in Net::SIP 0.806. Let's see how this works out.
Thanks. I wanted to upload 0.806 to Debian/unstable but I get a test failure: Odd number of elements in hash assignment at /build/libnet-sip-perl-0.806/blib/lib/Net/SIP/Util.pm line 32. # Failed test '[proxy] (?^:O>.*REQ\(INVITE\) SDP: audio=\S+)' # at ./t/testlib.pl line 234. # Failed test 'Died at t/05_call_with_stateless_proxy.t line 105. # ' # at ./t/testlib.pl line 31. # Looks like you planned 378 tests but ran 52. # Looks like you failed 2 tests of 52 run. # Looks like your test exited with 1 just after 52. Full log attached. Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: John Lennon: Power To The People

Message body is not shown because sender requested not to inline it.

Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 106b
Show quoted text
> > I wanted to upload 0.806 to Debian/unstable but I get a test failure:
This should be fixed in 0.807
CC: ntyni [...] debian.org
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Thu, 8 Dec 2016 00:11:38 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 896b
On Wed, 07 Dec 2016 01:33:47 -0500, Steffen Ullrich via RT wrote: Show quoted text
Show quoted text
> > I wanted to upload 0.806 to Debian/unstable but I get a test failure:
> This should be fixed in 0.807
Thank you. Looks good locally, so uploaded to Debian. The reproducible build servers have built it only for armhf so far, and it looks like we have failures again: https://tests.reproducible-builds.org/debian/rb-pkg/unstable/armhf/libnet-sip-perl.html https://tests.reproducible-builds.org/debian/rbuild/unstable/armhf/libnet-sip-perl_0.807-1.rbuild.log Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: Tony Joe White: Goin' Down Rockin'
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 592b
Show quoted text
> > The reproducible build servers have built it only for armhf so far, > and it looks like we have failures again: > https://tests.reproducible-builds.org/debian/rb- > pkg/unstable/armhf/libnet-sip-perl.html > https://tests.reproducible- > builds.org/debian/rbuild/unstable/armhf/libnet-sip-perl_0.807- > 1.rbuild.log
Although the path says that this is a test with 0.807 it looks like that it actually is doing a test with 0.802. From the report: Show quoted text
> Use of uninitialized value $laddr in concatenation (.) or string at /build/1st/libnet-sip-perl-0.802/blib/lib/Net/SIP/Util.pm line 364.
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Thu, 8 Dec 2016 17:48:54 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 2.4k
On Thu, 08 Dec 2016 03:13:37 -0500, Steffen Ullrich via RT wrote: Show quoted text
Show quoted text
> > The reproducible build servers have built it only for armhf so far, > > and it looks like we have failures again: > > https://tests.reproducible-builds.org/debian/rb-pkg/unstable/armhf/libnet-sip-perl.html > > https://tests.reproducible-builds.org/debian/rbuild/unstable/armhf/libnet-sip-perl_0.807-1.rbuild.log
> > Although the path says that this is a test with 0.807 it looks like that it actually is doing a test with 0.802. > From the report: >
> > Use of uninitialized value $laddr in concatenation (.) or string at /build/1st/libnet-sip-perl-0.802/blib/lib/Net/SIP/Util.pm line 364.
Oops, good catch, sorry for missing this yesterday. What we now have is: amd64: https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/libnet-sip-perl.html with 2 successful builds: https://tests.reproducible-builds.org/debian/rbuild/unstable/amd64/libnet-sip-perl_0.807-1.rbuild.log https://tests.reproducible-builds.org/debian/logs/unstable/amd64/libnet-sip-perl_0.807-1.build2.log.gz i386: https://tests.reproducible-builds.org/debian/rb-pkg/unstable/i386/libnet-sip-perl.html with 1 success: https://tests.reproducible-builds.org/debian/rbuild/unstable/i386/libnet-sip-perl_0.807-1.rbuild.log and 1 failure (which looks differently): https://tests.reproducible-builds.org/debian/logs/unstable/i386/libnet-sip-perl_0.807-1.build2.log.gz Test Summary Report ------------------- t/19_call_with_dtmf.t (Wstat: 512 Tests: 54 Failed: 2) Failed tests: 17-18 Non-zero exit status: 2 Files=17, Tests=1027, 212 wallclock secs ( 0.59 usr 0.14 sys + 35.19 cusr 3.37 csys = 39.29 CPU) Result: FAIL armhf: https://tests.reproducible-builds.org/debian/rb-pkg/unstable/armhf/libnet-sip-perl.html still the same weird build: https://tests.reproducible-builds.org/debian/rbuild/unstable/armhf/libnet-sip-perl_0.807-1.rbuild.log (it downloads 0.807-1 and then unpacks and builds 0.802-1) So it seems that the original bug is indeed fixed, great! Maybe you have some idea what the new test failure on i386 is about? Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: Peter Jones: Will You Pretend You're Blind
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 260b
Show quoted text
> t/19_call_with_dtmf.t (Wstat: 512 Tests: 54 Failed: 2)
0.808 is out there which specifically address problem with this test on terrible slow systems. cpantester reports look good so far, i.e. it now succeeds on the systems it failed before.
Subject: Re: [rt.cpan.org #118824] Test failures
Date: Wed, 14 Dec 2016 19:14:01 +0100
To: Steffen Ullrich via RT <bug-Net-SIP [...] rt.cpan.org>
From: gregor herrmann <gregoa [...] debian.org>
Download (untitled) / with headers
text/plain 730b
On Wed, 14 Dec 2016 01:45:47 -0500, Steffen Ullrich via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=118824 > > >
> > t/19_call_with_dtmf.t (Wstat: 512 Tests: 54 Failed: 2)
> > 0.808 is out there which specifically address problem with this > test on terrible slow systems. cpantester reports look good so far, > i.e. it now succeeds on the systems it failed before.
Thank you! Uploaded to Debian. Cheers, gregor -- .''`. https://info.comodo.priv.at/ - Debian Developer https://www.debian.org : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D 85FA BB3A 6801 8649 AA06 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe `- NP: The Who: My Generation
Download signature.asc
application/pgp-signature 963b

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.