Skip Menu |
 

This queue is for tickets about the Image-Thumbnail CPAN distribution.

Report information
The Basics
Id: 118576
Status: open
Priority: 0/
Queue: Image-Thumbnail

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.66
Fixed in: (no value)



Subject: Test suite fails if Image::Epeg is installed.
Download (untitled) / with headers
text/plain 1.1k
On some of my linux smoker systems (various perl versions) the test suite fails. I have the impression this happens only if Image::Epeg is installed: ... # No 'object' supplied to make thumbnail from at t/imblob.t line 40. # Failed test 'undef isa 'Image::Magick'' # at t/imblob.t line 43. # undef isn't defined # Failed test 'defined x' # at t/imblob.t line 45. # Failed test 'correct x' # at t/imblob.t line 46. # Failed test 'correct y' # at t/imblob.t line 47. # Looks like you failed 4 tests of 7. t/imblob.t ...... Dubious, test returned 4 (wstat 1024, 0x400) Failed 4/7 subtests # Failed test 'An object of class 'Image::Epeg' isa 'Image::Magick'' # at t/imf.t line 39. # The object of class 'Image::Epeg' isn't a 'Image::Magick' # Looks like you failed 1 test of 7. t/imf.t ......... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/7 subtests # Failed test 'An object of class 'Image::Epeg' isa 'Image::Magick'' # at t/imfa.t line 38. # The object of class 'Image::Epeg' isn't a 'Image::Magick' # Looks like you failed 1 test of 6. t/imfa.t ........ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/6 subtests ...
Subject: Re: [rt.cpan.org #118576] Test suite fails if Image::Epeg is installed.
Date: Tue, 01 Nov 2016 16:00:02 +0100
To: bug-Image-Thumbnail [...] rt.cpan.org
From: Lee Goddard <leeg1644 [...] leegoddard.net>

Thanks, will look



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.