Skip Menu |
 

This queue is for tickets about the Test2-Plugin-NoWarnings CPAN distribution.

Report information
The Basics
Id: 118443
Status: resolved
Priority: 0/
Queue: Test2-Plugin-NoWarnings

People
Owner: Nobody in particular
Requestors: CHORNY [...] cpan.org
kmx [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.05



Subject: Test2-Plugin-NoWarnings-0.03 fails on MS Windows / perl-5.22.3-RC4
Hi, I have experienced the following test failure:
# Versions for all modules listed in MYMETA.json (including optional ones):
#
# === Configure Requires ===
#
#     Module              Want Have
#     ------------------- ---- ----
#     ExtUtils::MakeMaker  any 7.24
#
# === Build Requires ===
#
#     Module              Want Have
#     ------------------- ---- ----
#     ExtUtils::MakeMaker  any 7.24
#
# === Test Requires ===
#
#     Module                      Want     Have
#     ----------------------- -------- --------
#     ExtUtils::MakeMaker          any     7.24
#     File::Spec                   any     3.62
#     IPC::Run3                    any    0.048
#     Test2::Bundle::Extended      any 0.000060
#     Test2::Require::Module       any 0.000060
#     Test::More              1.302015 1.302059
#
# === Test Recommends ===
#
#     Module         Want     Have
#     ---------- -------- --------
#     CPAN::Meta 2.120900 2.150010
#
# === Runtime Requires ===
#
#     Module                Want     Have
#     --------------------- ---- --------
#     Carp                   any     1.38
#     Test2::API             any 1.302059
#     Test2::Event           any 1.302059
#     Test2::Util::HashBase  any 1.302059
#     parent                 any    0.236
#     strict                 any     1.09
#     warnings               any     1.34
#
t/00-report-prereqs.t .. ok
t/basic.t .............. ok
Inappropriate I/O control operation at t/compile.t line 33.
t/compile.t ............
Dubious, test returned 25 (wstat 6400, 0x1900)
No subtests run

Test Summary Report
-------------------
t/compile.t          (Wstat: 6400 Tests: 0 Failed: 0)
  Non-zero exit status: 25
  Parse errors: No plan found in TAP output
Files=3, Tests=2,  3 wallclock secs ( 0.09 usr +  0.05 sys =  0.14 CPU)
Result: FAIL
Download (untitled) / with headers
text/plain 310b
Same problems in 0.04 If run manually, the only output is Inappropriate I/O control operation at t/compile.t line 33. run3 frequently has problems on Windows. If I replace code in parameter with file name (where I copied the code), it just does not return anything. -- Alexandr Ciornii, http://chorny.net


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.