Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 118218
Status: new
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: jonasbn [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Issue building on OSX using carton
Download (untitled) / with headers
text/plain 1.2k
I am experiencing issues building XML::LibXML on OSX 10.11 (El Capitan). I have installed libxml2 using homebrew. Manual configuration seems to work: $ perl Makefile.PL LIBS='-L/usr/local/Cellar/libxml2/2.9.4/lib' INC='I/usr/local/Cellar/libxml2/2.9.4/include/libxml2' I have added the lib part to the environment variable: LD_LIBRARY_PATH and include path to: CFLAGS, CPATH, CPPFLAGS and CPLUS_INCLUDE_PATH This does however not seem to work. [jonasbn:~/Downloads/XML-LibXML-2.0128] $ Show quoted text
> perl Makefile.PL
enable native perl UTF8 running xml2-config...ok (2.9.2) Checking for ability to link against xml2...no Checking for ability to link against libxml2...libxml2, zlib, and/or the Math library (-lm) have not been found. Try setting LIBS and INC values on the command line Or get libxml2 from http://xmlsoft.org/ If you install via RPMs, make sure you also install the -devel RPMs, as this is where the headers (.h files) are. Also, you may try to run perl Makefile.PL with the DEBUG=1 parameter to see the exact reason why the detection of libxml2 installation failed or why Makefile.PL was not able to compile a test program. [jonasbn:~/Downloads/XML-LibXML-2.0128] $ Could you provide any pointers on how to proceed? jonasbn


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.