This queue is for tickets about the Text-Naming-Convention CPAN distribution.

Report information
The Basics
Id:
117827
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
SREZIC [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: kwalitee test fails (old Module::Install)
On some smokers the test suite fails: ... t/01.api.t ........ ok These tests should not be running unless AUTHOR_TESTING=1 and/or RELEASE_TESTING=1! # Failed test 'no_broken_auto_install' # at t/kwalitee.t line 3. # Error: This distribution uses an old version of Module::Install. Versions of Module::Install prior to 0.89 do not detect correcty that CPAN/CPANPLUS shell is used. # Details: # This distribution uses obsolete Module::Install version 0.76 # Remedy: Upgrade the bundled version of Module::Install to at least 0.89, but preferably to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.) # Looks like you failed 1 test of 17. t/kwalitee.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/17 subtests ...
On 2016-09-13 13:21:31, SREZIC wrote:
Show quoted text
> On some smokers the test suite fails: > > ... > t/01.api.t ........ ok > These tests should not be running unless AUTHOR_TESTING=1 and/or > RELEASE_TESTING=1! > > # Failed test 'no_broken_auto_install' > # at t/kwalitee.t line 3. > # Error: This distribution uses an old version of Module::Install. > Versions of Module::Install prior to 0.89 do not detect correcty that > CPAN/CPANPLUS shell is used. > # Details: > # This distribution uses obsolete Module::Install version 0.76 > # Remedy: Upgrade the bundled version of Module::Install to at least > 0.89, but preferably to the most current release. Alternatively, you > can switch to another build system / installer that does not suffer > from this problem. (ExtUtils::MakeMaker, Module::Build both of which > have their own set of problems.) > # Looks like you failed 1 test of 17. > t/kwalitee.t ...... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/17 subtests > ...
Take note of the warning issued by the kwalitee test... While this test failure is indeed an issue that should be corrected, please don't allow pod, critic, coverage or kwalitee tests to run for normal user installs, as they make the installation fail unnecessarily when newer versions of the tester module introduces errors that you cannot anticipate. Also spelling tests are dependent on what dictionaries are installed locally, and critic tests use all plugins that are installed, neither of which can be predicted in advance. Either move these tests to xt/, or guard them with: plan skip_all => "These tests are for authors only!" unless $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};
Thanks for reporting this. I released 0.07 just now to fix this, which I believe will be available to you soon. -sunnavy


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.