Skip Menu |
 

This queue is for tickets about the Graph-Layout-Aesthetic CPAN distribution.

Report information
The Basics
Id: 11768
Status: resolved
Priority: 0/
Queue: Graph-Layout-Aesthetic

People
Owner: Nobody in particular
Requestors: thekestrel [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.08
Fixed in: (no value)



Subject: Topology->from_graph not vertex05 compatible
Download (untitled) / with headers
text/plain 822b
Hi, I've started using Graph::Layout::Aesthetic to extend my script using Graph-0.59 and when I try to load in the existing Graph with 'from_graph' in Topology.pm I get the following; set_attribute: not a compat02 graph at /usr/lib/perl5/site_perl/5.8/Graph.pm line 2307. I had a look at the from_graph code and if you replace the following lines if (defined($attribute)) { $graph->set_attribute($attribute, $_, $num->{$_} = $nr++) for $graph->vertices; } else { with these lines is now works. if (defined($attribute)) { if ( $graph->is_compat02 ) { $graph->set_attribute($attribute, $_, $num->{$_} = $nr++) for $graph->vertices; } else { $graph->set_vertex_attribute($attribute, $_, $num->{$_} = $nr++) for $graph->vertices; } } else { Regards Paul.
From: "Ton Hospel" <me-02 [...] ton.iguana.be>
Date: Wed, 9 Mar 2005 21:54:57 +0100
To: Guest via RT <bug-Graph-Layout-Aesthetic [...] rt.cpan.org>
Subject: Re: [cpan #11768] Topology->from_graph not vertex05 compatible
RT-Send-Cc:
Download (untitled) / with headers
text/plain 1.3k
On Sat, Mar 05, 2005 at 04:03:39PM -0500, Guest via RT wrote: Show quoted text
> > This message about Graph-Layout-Aesthetic was sent to you by guest <> via rt.cpan.org > > Full context and any attached attachments can be found at: > <URL: https://rt.cpan.org/Ticket/Display.html?id=11768 > > > Hi, > I've started using Graph::Layout::Aesthetic to extend my script using Graph-0.59 and when I try to load in the existing Graph with 'from_graph' in Topology.pm I get the following; > > set_attribute: not a compat02 graph at /usr/lib/perl5/site_perl/5.8/Graph.pm line 2307. > > I had a look at the from_graph code and if you replace the following lines > > if (defined($attribute)) { > $graph->set_attribute($attribute, $_, $num->{$_} = $nr++) for $graph->vertices; > } else { > > with these lines is now works. > > if (defined($attribute)) { > if ( $graph->is_compat02 ) { > $graph->set_attribute($attribute, $_, $num->{$_} = $nr++) for $graph->vertices; > } else { > $graph->set_vertex_attribute($attribute, $_, $num->{$_} = $nr++) for $graph->vertices; > > } > } else { > > Regards Paul. >
Thanks for your message. I'm aware that Graph changed it's interface and will soon bring out an updated version of Graph::Layout::Aesthetic (I sup[pose I'll have to go with the flow :-) )
Graph::Layout::Aesthetic v0.10 is finally Graph 0.50 compatible.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.