Skip Menu |
 

This queue is for tickets about the Net-HTTPS-Any CPAN distribution.

Report information
The Basics
Id: 116405
Status: patched
Priority: 0/
Queue: Net-HTTPS-Any

People
Owner: ivan-pause [...] 420.am
Requestors: daniel.weatherford [...] adtran.com
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in:
  • 0.10
  • 0.11
  • 0.11_01
Fixed in: (no value)



Subject: Report Bug: test error in perl 5.14
Date: Fri, 22 Jul 2016 19:47:38 +0000
To: "bug-Net-HTTPS-Any [...] rt.cpan.org" <bug-Net-HTTPS-Any [...] rt.cpan.org>
From: DANIEL WEATHERFORD <daniel.weatherford [...] adtran.com>
Download (untitled) / with headers
text/plain 2.9k
Linux Ubuntu 12.04 Distribution (uname -a): Linux kickseed 3.8.0-29-generic #42~precise1-Ubuntu SMP Wed Aug 14 15:31:16 UTC 2013 i686 i686 i386 GNU/Linux Description: Installing Net:HTTPS:Any results in a test failure that has not been there in the past. Network connectivity is fine. This same version has worked fine in the past. If this indicates a local network problem then what is the test doing that might help us narrow down the problem? Output from CPAN client: cpan[32]> install Net:HTTPS:Any utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. Running install for module 'Net::HTTPS::Any' Running make for I/IV/IVAN/Net-HTTPS-Any-0.11.tar.gz Has already been unwrapped into directory /home/blueserver/.cpan/build/Net-HTTPS-Any-0.11-JujBol Has already been made Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-load.t ........... 1/1 # Testing Net::HTTPS::Any 0.11, Perl 5.014002, /usr/bin/perl t/00-load.t ........... ok t/get-cryptssleay.t ... skipped: LWP tests disabled to avoid excessive dependencies t/get-netssleay.t ..... ok t/pod-coverage.t ...... skipped: Test::Pod::Coverage 1.08 required for testing POD coverage t/pod.t ............... skipped: Test::Pod 1.22 required for testing POD t/post-cryptssleay.t .. skipped: LWP tests disabled to avoid excessive dependencies t/post-netssleay.t .... 1/4 # Failed test 'Received 200 (OK) response' # at t/post-netssleay.t line 23. # '307 Temporary Redirect' # doesn't match '(?^i:^200)' # Looks like you failed 1 test of 4. t/post-netssleay.t .... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/4 subtests Test Summary Report ------------------- t/post-netssleay.t (Wstat: 256 Tests: 4 Failed: 1) Failed test: 2 Non-zero exit status: 1 Files=7, Tests=9, 1 wallclock secs ( 0.02 usr 0.01 sys + 0.08 cusr 0.07 csys = 0.18 CPU) Result: FAIL Failed 1/7 test programs. 1/9 subtests failed. make: *** [test_dynamic] Error 1 IVAN/Net-HTTPS-Any-0.11.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports IVAN/Net-HTTPS-Any-0.11.tar.gz Running make install make test had returned bad status, won't install without force utf8 "\xE4" does not map to Unicode at /usr/share/perl/5.14/Parse/CPAN/Meta.pm line 89, <$fh> chunk 1. Failed during this command: IVAN/Net-HTTPS-Any-0.11.tar.gz : make_test NO Thanks, Daniel
Download (untitled) / with headers
text/plain 221b
On Fri Jul 22 15:47:56 2016, daniel.weatherford@adtran.com wrote: Show quoted text
> what is the test doing that might help us narrow down the > problem?
You can determine what the test is doing by reading the source code for the test.
Subject: RE: [rt.cpan.org #116405] Report Bug: test error in perl 5.14
Date: Mon, 25 Jul 2016 14:33:04 +0000
To: "bug-Net-HTTPS-Any [...] rt.cpan.org" <bug-Net-HTTPS-Any [...] rt.cpan.org>
From: DANIEL WEATHERFORD <daniel.weatherford [...] adtran.com>
Download (untitled) / with headers
text/plain 632b
Looks like a POST to http://www.google.com/accounts/ServiceLoginAuth. Google server is busy or the link has changed? Show quoted text
-----Original Message----- From: Ivan Kohler via RT [mailto:bug-Net-HTTPS-Any@rt.cpan.org] Sent: Friday, July 22, 2016 3:32 PM To: DANIEL WEATHERFORD Subject: [rt.cpan.org #116405] Report Bug: test error in perl 5.14 <URL: https://rt.cpan.org/Ticket/Display.html?id=116405 > On Fri Jul 22 15:47:56 2016, daniel.weatherford@adtran.com wrote:
> what is the test doing that might help us narrow down the problem?
You can determine what the test is doing by reading the source code for the test.
Download (untitled) / with headers
text/plain 834b
On 2016-07-25 10:33:16, daniel.weatherford@adtran.com wrote: Show quoted text
> Looks like a POST to http://www.google.com/accounts/ServiceLoginAuth. > Google server is busy or the link has changed? > > -----Original Message----- > From: Ivan Kohler via RT [mailto:bug-Net-HTTPS-Any@rt.cpan.org] > Sent: Friday, July 22, 2016 3:32 PM > To: DANIEL WEATHERFORD > Subject: [rt.cpan.org #116405] Report Bug: test error in perl 5.14 > > <URL: https://rt.cpan.org/Ticket/Display.html?id=116405 > > > On Fri Jul 22 15:47:56 2016, daniel.weatherford@adtran.com wrote:
> > what is the test doing that might help us narrow down the problem?
> > You can determine what the test is doing by reading the source code > for the test. > >
It seems to fail everywhere since a week ago: http://matrix.cpantesters.org/?dist=Net-HTTPS-Any%200.11;reports=1#sl=7,1
Subject: Vacation
Date: Thu, 28 Jul 2016 23:44:28 +0200
To: bug-Net-HTTPS-Any [...] rt.cpan.org
From: racke [...] linuxia.de
Download (untitled) / with headers
text/plain 1.1k
Slaven_Rezic via RT writes: Show quoted text
> Queue: Net-HTTPS-Any > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=116405 > > > On 2016-07-25 10:33:16, daniel.weatherford@adtran.com wrote:
>> Looks like a POST to http://www.google.com/accounts/ServiceLoginAuth. >> Google server is busy or the link has changed? >> >> -----Original Message----- >> From: Ivan Kohler via RT [mailto:bug-Net-HTTPS-Any@rt.cpan.org] >> Sent: Friday, July 22, 2016 3:32 PM >> To: DANIEL WEATHERFORD >> Subject: [rt.cpan.org #116405] Report Bug: test error in perl 5.14 >> >> <URL: https://rt.cpan.org/Ticket/Display.html?id=116405 > >> >> On Fri Jul 22 15:47:56 2016, daniel.weatherford@adtran.com wrote:
>> > what is the test doing that might help us narrow down the problem?
>> >> You can determine what the test is doing by reading the source code >> for the test. >> >>
> > It seems to fail everywhere since a week ago: > http://matrix.cpantesters.org/?dist=Net-HTTPS-Any%200.11;reports=1#sl=7,1 > >
Hello, I'm on vacation till 31st July. In urgent cases please send a text message to my cellphone. Otherwise, I'm going to check my emails once in a while while on vacation. Regards Racke


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.