Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 11626
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: corion [...] corion.net
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Date: Tue, 22 Feb 2005 23:36:57 +0100
From: Max Maischein <corion [...] corion.net>
To: bug-Module-Build [...] rt.cpan.org
Subject: Module::Build does not upgrade from 0.2605 to 0.2608 via CPAN.pm on Win32, Perl 5.8.5
Download (untitled) / with headers
text/plain 14.5k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 434b
[corion@corion.net - Tue Feb 22 17:35:19 2005]: Show quoted text
> I guess that Module::Build and/or CPAN tries to unlink a file which is > held open by Perl, which does not work on Win32. Of course, > Module::Build should be able to upgrade itself seamlessly. See the below > test run.
This now works with 0.2609: ... nmake.EXE install -- OK C:\>perl -MModule::Build -e"print $Module::Build::VERSION" 0.2609 So this bug can be closed. -max
Download (untitled) / with headers
text/plain 136b
Okay, thanks for letting me know. I didn't actually do anything to fix this explicitly, though. Must be the bugfixing gnomes. -Ken


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.