Skip Menu |
 

This queue is for tickets about the Test-Harness CPAN distribution.

Report information
The Basics
Id: 11595
Status: resolved
Priority: 0/
Queue: Test-Harness

People
Owner: andy [...] hexten.net
Requestors:
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: Provide T::H and TAP version to test scripts
Download (untitled) / with headers
text/plain 477b
A commonly reported "bug" is when Test::More makes use of no_plan but the output is parsed by an older version of Test::Harness. The resulting misparse by T::H looks like all tests failed. It would be nice if Test::More could detect what version of Test::Harness it is running under and alter its behavior accordingly. The simplest way to do this would be for Test::Harness to provide two environment variables, TEST_HARNESS_VERSION and TAP_VERSION, when running the tests.
Fixed in 2.99.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.