Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 115399
Status: open
Priority: 0/
Queue: Net-SSLeay

People
Owner: Nobody in particular
Requestors: CLEACH [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 1.74
  • 1.69
  • 1.70
  • 1.71
  • 1.72
  • 1.73
Fixed in: (no value)

Attachments


Subject: Net-SSLeay-1.74 fails to compiler property on AIX
Download (untitled) / with headers
text/plain 3.2k
I'm running Perl 5.10.1 on AIX 7.1 with the latest AIX patches installed. I'm using OpenSSL 1.0.1e. I'll include the Perl -V output at the end of this email. After my recent AIX upgrade, this module broke (v1.69), so I attempted to upgrade to v1.74 and encountered compiler issues. Here are the steps I followed along with their output. Whenever I get an error, I delete the entire directory & extract it again to get a clean start. The errors were so verbose that I'm including them in the attached word document. Thank you for any assistance you can provide in advance. Curtis ================================================================== /tmp/build> perl -V Summary of my perl5 (revision 5 version 10 subversion 1) configuration: Platform: osname=aix, osvers=6.1.2.0, archname=aix-thread-multi uname='aix akash79 1 6 00011a85d600 powerpc unknown aix ' config_args='-desr -Dinstallprefix=/usr/opt/perl5 -Dprefix=/usr/opt/perl5 -Dcc=xlc_r -Duseshrplib -Dusethreads' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=undef, use64bitall=undef, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='xlc_r -q32', ccflags ='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=-1 -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT -qlanglvl=extended -I/usr/local/include -q32 -D_LARGE_FILES -qlonglong', optimize='-O', cppflags='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=-1 -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT -qlanglvl=extended -I/usr/local/include' ccversion='10.1.0.9', gccversion='', gccosandvers='' intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8 ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='ld', ldflags =' -brtl -bdynamic -L/usr/local/lib -b32' libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib /usr/lib64 libs=-lbind -lnsl -ldbm -ldl -lld -lm -lcrypt -lpthreads -lc perllibs=-lbind -lnsl -ldl -lld -lm -lcrypt -lpthreads -lc libc=, so=a, useshrplib=true, libperl=libperl.a gnulibc_version='' Dynamic Linking: dlsrc=dl_aix.xs, dlext=so, d_dlsymun=undef, ccdlflags=' -bE:/usr/opt/perl5/lib/5.10.1/aix-thread-multi/CORE/perl.exp' cccdlflags=' ', lddlflags='-bhalt:4 -G -bI:$(PERL_INC)/perl.exp -bE:$(BASEEXT).exp -bnoentry -lpthreads -lc -lm -L/usr/local/lib' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API Built under aix Compiled at May 19 2013 14:28:07 %ENV: PERL5LIB="/usr/opt/perl5/erm_lib/lib/perl5" @INC: /usr/opt/perl5/erm_lib/lib/perl5/aix-thread-multi /usr/opt/perl5/erm_lib/lib/perl5 /usr/opt/perl5/lib/5.10.1/aix-thread-multi /usr/opt/perl5/lib/5.10.1 /usr/opt/perl5/lib/site_perl/5.10.1/aix-thread-multi /usr/opt/perl5/lib/site_perl/5.10.1 /usr/opt/perl5/lib/site_perl/5.8.8 /usr/opt/perl5/lib/site_perl .
Subject: Net-SSLeay-1.74-Errors.doc
Download Net-SSLeay-1.74-Errors.doc
application/msword 39k

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 4.5k
Just an update. I did some research online & discovered that the error message points to me having SSLv2 support removed from my OpenSSL library. So I'm reaching out to the person who upgraded OpenSSL on my server to see if he remembered to update the include files that go with it. In the mean time I hacked SSLeay.xs & added "#define OPENSSL_NO_SSL2" to the top of the file & things now compile & I no longer get the linker errors. But I'm back to the same issue I've been having with my other ticket # 115298. t/local/07_sslecho.t ................... 1/78 # Failed test 'set_cert_and_key: private key `t/data/key.pem' () 19791888: 1 - error:2606C043:engine routines:ENGINE_FREE_UTIL:passed a null parameter # private key `t/data/key.pem' () 19791888: 2 - error:2606A074:engine routines:ENGINE_by_id:no such engine # private key `t/data/key.pem' () 19791888: 3 - error:2606C043:engine routines:ENGINE_FREE_UTIL:passed a null parameter # private key `t/data/key.pem' () 19791888: 4 - error:2606A074:engine routines:ENGINE_by_id:no such engine # ' # at t/local/07_sslecho.t line 63. # Looks like you failed 1 test of 78. Curtis On Fri Jun 17 15:31:31 2016, CLEACH wrote: Show quoted text
> I'm running Perl 5.10.1 on AIX 7.1 with the latest AIX patches > installed. I'm using OpenSSL 1.0.1e. I'll include the Perl -V output > at the end of this email. > > After my recent AIX upgrade, this module broke (v1.69), so I attempted > to upgrade to v1.74 and encountered compiler issues. Here are the > steps I followed along with their output. Whenever I get an error, I > delete the entire directory & extract it again to get a clean start. > > The errors were so verbose that I'm including them in the attached > word document. > > Thank you for any assistance you can provide in advance. > > Curtis > > > ================================================================== > /tmp/build> perl -V > Summary of my perl5 (revision 5 version 10 subversion 1) > configuration: > > Platform: > osname=aix, osvers=6.1.2.0, archname=aix-thread-multi > uname='aix akash79 1 6 00011a85d600 powerpc unknown aix ' > config_args='-desr -Dinstallprefix=/usr/opt/perl5 > -Dprefix=/usr/opt/perl5 -Dcc=xlc_r -Duseshrplib -Dusethreads' > hint=recommended, useposix=true, d_sigaction=define > useithreads=define, usemultiplicity=define > useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef > use64bitint=undef, use64bitall=undef, uselongdouble=undef > usemymalloc=n, bincompat5005=undef > Compiler: > cc='xlc_r -q32', ccflags ='-D_ALL_SOURCE -D_ANSI_C_SOURCE > -D_POSIX_SOURCE -qmaxmem=-1 -qnoansialias -DUSE_NATIVE_DLOPEN > -DNEED_PTHREAD_INIT -qlanglvl=extended -I/usr/local/include -q32 > -D_LARGE_FILES -qlonglong', > optimize='-O', > cppflags='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=-1 > -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT > -qlanglvl=extended -I/usr/local/include' > ccversion='10.1.0.9', gccversion='', gccosandvers='' > intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321 > d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8 > ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', > lseeksize=8 > alignbytes=8, prototype=define > Linker and Libraries: > ld='ld', ldflags =' -brtl -bdynamic -L/usr/local/lib -b32' > libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib /usr/lib64 > libs=-lbind -lnsl -ldbm -ldl -lld -lm -lcrypt -lpthreads -lc > perllibs=-lbind -lnsl -ldl -lld -lm -lcrypt -lpthreads -lc > libc=, so=a, useshrplib=true, libperl=libperl.a > gnulibc_version='' > Dynamic Linking: > dlsrc=dl_aix.xs, dlext=so, d_dlsymun=undef, ccdlflags=' > -bE:/usr/opt/perl5/lib/5.10.1/aix-thread-multi/CORE/perl.exp' > cccdlflags=' ', lddlflags='-bhalt:4 -G -bI:$(PERL_INC)/perl.exp > -bE:$(BASEEXT).exp -bnoentry -lpthreads -lc -lm -L/usr/local/lib' > > > Characteristics of this binary (from libperl): > Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV > PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP > USE_ITHREADS > USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API > Built under aix > Compiled at May 19 2013 14:28:07 > %ENV: > PERL5LIB="/usr/opt/perl5/erm_lib/lib/perl5" > @INC: > /usr/opt/perl5/erm_lib/lib/perl5/aix-thread-multi > /usr/opt/perl5/erm_lib/lib/perl5 > /usr/opt/perl5/lib/5.10.1/aix-thread-multi > /usr/opt/perl5/lib/5.10.1 > /usr/opt/perl5/lib/site_perl/5.10.1/aix-thread-multi > /usr/opt/perl5/lib/site_perl/5.10.1 > /usr/opt/perl5/lib/site_perl/5.8.8 > /usr/opt/perl5/lib/site_perl > .
Subject: Re: [rt.cpan.org #115399] Net-SSLeay-1.74 fails to compiler property on AIX
Date: Sat, 18 Jun 2016 13:55:25 +0900
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 4.9k
Hi I'm travelling at the moment and not in a position to be very helpful but I think what you are seeing is still consistent with incorrect headers for your shared library Cheers Sent from my iPhone Show quoted text
> On 18 Jun 2016, at 8:06 AM, Curtis Leach via RT <bug-Net-SSLeay@rt.cpan.org> wrote: > > Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=115399 > > > Just an update. I did some research online & discovered that the error message points to me having SSLv2 support removed from my OpenSSL library. So I'm reaching out to the person who upgraded OpenSSL on my server to see if he remembered to update the include files that go with it. > > In the mean time I hacked SSLeay.xs & added "#define OPENSSL_NO_SSL2" to the top of the file & things now compile & I no longer get the linker errors. > > But I'm back to the same issue I've been having with my other ticket # 115298. > > t/local/07_sslecho.t ................... 1/78 > # Failed test 'set_cert_and_key: private key `t/data/key.pem' () 19791888: 1 - error:2606C043:engine routines:ENGINE_FREE_UTIL:passed a null parameter > # private key `t/data/key.pem' () 19791888: 2 - error:2606A074:engine routines:ENGINE_by_id:no such engine > # private key `t/data/key.pem' () 19791888: 3 - error:2606C043:engine routines:ENGINE_FREE_UTIL:passed a null parameter > # private key `t/data/key.pem' () 19791888: 4 - error:2606A074:engine routines:ENGINE_by_id:no such engine > # ' > # at t/local/07_sslecho.t line 63. > # Looks like you failed 1 test of 78. > > Curtis > >
>> On Fri Jun 17 15:31:31 2016, CLEACH wrote: >> I'm running Perl 5.10.1 on AIX 7.1 with the latest AIX patches >> installed. I'm using OpenSSL 1.0.1e. I'll include the Perl -V output >> at the end of this email. >> >> After my recent AIX upgrade, this module broke (v1.69), so I attempted >> to upgrade to v1.74 and encountered compiler issues. Here are the >> steps I followed along with their output. Whenever I get an error, I >> delete the entire directory & extract it again to get a clean start. >> >> The errors were so verbose that I'm including them in the attached >> word document. >> >> Thank you for any assistance you can provide in advance. >> >> Curtis >> >> >> ================================================================== >> /tmp/build> perl -V >> Summary of my perl5 (revision 5 version 10 subversion 1) >> configuration: >> >> Platform: >> osname=aix, osvers=6.1.2.0, archname=aix-thread-multi >> uname='aix akash79 1 6 00011a85d600 powerpc unknown aix ' >> config_args='-desr -Dinstallprefix=/usr/opt/perl5 >> -Dprefix=/usr/opt/perl5 -Dcc=xlc_r -Duseshrplib -Dusethreads' >> hint=recommended, useposix=true, d_sigaction=define >> useithreads=define, usemultiplicity=define >> useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef >> use64bitint=undef, use64bitall=undef, uselongdouble=undef >> usemymalloc=n, bincompat5005=undef >> Compiler: >> cc='xlc_r -q32', ccflags ='-D_ALL_SOURCE -D_ANSI_C_SOURCE >> -D_POSIX_SOURCE -qmaxmem=-1 -qnoansialias -DUSE_NATIVE_DLOPEN >> -DNEED_PTHREAD_INIT -qlanglvl=extended -I/usr/local/include -q32 >> -D_LARGE_FILES -qlonglong', >> optimize='-O', >> cppflags='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=-1 >> -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT >> -qlanglvl=extended -I/usr/local/include' >> ccversion='10.1.0.9', gccversion='', gccosandvers='' >> intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321 >> d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8 >> ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', >> lseeksize=8 >> alignbytes=8, prototype=define >> Linker and Libraries: >> ld='ld', ldflags =' -brtl -bdynamic -L/usr/local/lib -b32' >> libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib /usr/lib64 >> libs=-lbind -lnsl -ldbm -ldl -lld -lm -lcrypt -lpthreads -lc >> perllibs=-lbind -lnsl -ldl -lld -lm -lcrypt -lpthreads -lc >> libc=, so=a, useshrplib=true, libperl=libperl.a >> gnulibc_version='' >> Dynamic Linking: >> dlsrc=dl_aix.xs, dlext=so, d_dlsymun=undef, ccdlflags=' >> -bE:/usr/opt/perl5/lib/5.10.1/aix-thread-multi/CORE/perl.exp' >> cccdlflags=' ', lddlflags='-bhalt:4 -G -bI:$(PERL_INC)/perl.exp >> -bE:$(BASEEXT).exp -bnoentry -lpthreads -lc -lm -L/usr/local/lib' >> >> >> Characteristics of this binary (from libperl): >> Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV >> PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP >> USE_ITHREADS >> USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API >> Built under aix >> Compiled at May 19 2013 14:28:07 >> %ENV: >> PERL5LIB="/usr/opt/perl5/erm_lib/lib/perl5" >> @INC: >> /usr/opt/perl5/erm_lib/lib/perl5/aix-thread-multi >> /usr/opt/perl5/erm_lib/lib/perl5 >> /usr/opt/perl5/lib/5.10.1/aix-thread-multi >> /usr/opt/perl5/lib/5.10.1 >> /usr/opt/perl5/lib/site_perl/5.10.1/aix-thread-multi >> /usr/opt/perl5/lib/site_perl/5.10.1 >> /usr/opt/perl5/lib/site_perl/5.8.8 >> /usr/opt/perl5/lib/site_perl >> .
> > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.