Skip Menu |
 

This queue is for tickets about the DBD-mysql CPAN distribution.

Report information
The Basics
Id: 115167
Status: resolved
Priority: 0/
Queue: DBD-mysql

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 4.033_02
  • 4.034
Fixed in: 4.035



Subject: configure_requires DBI::DBD missing
Download (untitled) / with headers
text/plain 556b
It seems that DBI::DBD should be specified as configure_requires. If it isn't, then building from the CPAN shell fails if DBI is not yet installed: Output from '/bbbike/perl-5.20.3D/bin/perl Makefile.PL': Can't locate DBI/DBD.pm in @INC (you may need to install the DBI::DBD module) (@INC contains: /run/user/1023/cpansmoker/2016060812/CPAN-Reporter-lib-JPF_ /opt/perl-5.20.3D/lib/site_perl/5.20.3/x86_64-linux-ld /opt/perl-5.20.3D/lib/site_perl/5.20.3 /opt/perl-5.20.3D/lib/5.20.3/x86_64-linux-ld /opt/perl-5.20.3D/lib/5.20.3 .) at Makefile.PL line 16.
Download (untitled) / with headers
text/plain 758b
On 2016-06-08 10:07:39, SREZIC wrote: Show quoted text
> It seems that DBI::DBD should be specified as configure_requires. If > it isn't, then building from the CPAN shell fails if DBI is not yet > installed: > > Output from '/bbbike/perl-5.20.3D/bin/perl Makefile.PL': > > Can't locate DBI/DBD.pm in @INC (you may need to install the DBI::DBD > module) (@INC contains: /run/user/1023/cpansmoker/2016060812/CPAN- > Reporter-lib-JPF_ /opt/perl-5.20.3D/lib/site_perl/5.20.3/x86_64-linux- > ld /opt/perl-5.20.3D/lib/site_perl/5.20.3 /opt/perl- > 5.20.3D/lib/5.20.3/x86_64-linux-ld /opt/perl-5.20.3D/lib/5.20.3 .) at > Makefile.PL line 16.
This is still the case with the current stable 4.034. See https://travis-ci.org/eserte/sandbox/jobs/143249466 for a sample failed build.
Subject: Re: [rt.cpan.org #115167] configure_requires DBI::DBD missing
Date: Fri, 8 Jul 2016 08:43:40 +0200
To: "bug-DBD-mysql [...] rt.cpan.org" <bug-DBD-mysql [...] rt.cpan.org>
From: Michiel Beijen <michiel.beijen [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
I looked into this and indeed broke it by accident by a change to Makefile.PL recently. I'm sorry and will release a fix shortly. -- Michiel Op vrijdag 8 juli 2016 heeft Slaven_Rezic via RT <bug-DBD-mysql@rt.cpan.org> het volgende geschreven: Show quoted text
> Queue: DBD-mysql > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=115167 > > > On 2016-06-08 10:07:39, SREZIC wrote:
> > It seems that DBI::DBD should be specified as configure_requires. If > > it isn't, then building from the CPAN shell fails if DBI is not yet > > installed: > > > > Output from '/bbbike/perl-5.20.3D/bin/perl Makefile.PL': > > > > Can't locate DBI/DBD.pm in @INC (you may need to install the DBI::DBD > > module) (@INC contains: /run/user/1023/cpansmoker/2016060812/CPAN- > > Reporter-lib-JPF_ /opt/perl-5.20.3D/lib/site_perl/5.20.3/x86_64-linux- > > ld /opt/perl-5.20.3D/lib/site_perl/5.20.3 /opt/perl- > > 5.20.3D/lib/5.20.3/x86_64-linux-ld /opt/perl-5.20.3D/lib/5.20.3 .) at > > Makefile.PL line 16.
> > This is still the case with the current stable 4.034. > See https://travis-ci.org/eserte/sandbox/jobs/143249466 for a sample > failed build. >
RT-Send-CC: michiel.beijen [...] gmail.com
Download (untitled) / with headers
text/plain 1.2k
Looks fixed now. On 2016-07-08 02:43:55, michiel.beijen@gmail.com wrote: Show quoted text
> I looked into this and indeed broke it by accident by a change to > Makefile.PL recently. I'm sorry and will release a fix shortly. > -- > Michiel > > Op vrijdag 8 juli 2016 heeft Slaven_Rezic via RT <bug-DBD-mysql@rt.cpan.org> > het volgende geschreven: >
> > Queue: DBD-mysql > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=115167 > > > > > On 2016-06-08 10:07:39, SREZIC wrote:
> > > It seems that DBI::DBD should be specified as configure_requires. If > > > it isn't, then building from the CPAN shell fails if DBI is not yet > > > installed: > > > > > > Output from '/bbbike/perl-5.20.3D/bin/perl Makefile.PL': > > > > > > Can't locate DBI/DBD.pm in @INC (you may need to install the DBI::DBD > > > module) (@INC contains: /run/user/1023/cpansmoker/2016060812/CPAN- > > > Reporter-lib-JPF_ /opt/perl-5.20.3D/lib/site_perl/5.20.3/x86_64-linux- > > > ld /opt/perl-5.20.3D/lib/site_perl/5.20.3 /opt/perl- > > > 5.20.3D/lib/5.20.3/x86_64-linux-ld /opt/perl-5.20.3D/lib/5.20.3 .) at > > > Makefile.PL line 16.
> > > > This is still the case with the current stable 4.034. > > See https://travis-ci.org/eserte/sandbox/jobs/143249466 for a sample > > failed build. > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.