Skip Menu |
 

This queue is for tickets about the Dist-Surveyor CPAN distribution.

Report information
The Basics
Id: 115128
Status: resolved
Priority: 0/
Queue: Dist-Surveyor

People
Owner: Nobody in particular
Requestors: DBOOK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Undeclared runtime dependencies
This distribution does not declare a runtime dependency on LWP::UserAgent or JSON, but these are not core modules and the dist_surveyor script does not compile without them. There are also undeclared dependencies on several modules which did not become core until perl 5.8.9 or later, these include version, Module::CoreList, and Module::Metadata. Additionally several modules that weren't core until perl 5.8 but these aren't as important outside of the niche of supporting perl 5.6. My recommendation is simply to declare all runtime dependencies, even the core modules, and let the installer sort it out. grinnz@home ~> perl cpanm.pl --notest Dist::Surveyor --> Working on Dist::Surveyor Fetching http://www.cpan.org/authors/id/S/SE/SEMUELF/Dist-Surveyor-0.013.tar.gz ... OK ==> Found dependencies: ExtUtils::MakeMaker --> Working on ExtUtils::MakeMaker Fetching http://www.cpan.org/authors/id/B/BI/BINGOS/ExtUtils-MakeMaker-7.18.tar.gz ... OK Configuring ExtUtils-MakeMaker-7.18 ... OK Building ExtUtils-MakeMaker-7.18 ... OK Successfully installed ExtUtils-MakeMaker-7.18 (upgraded from 6.17) Configuring Dist-Surveyor-0.013 ... OK Building Dist-Surveyor-0.013 ... OK Successfully installed Dist-Surveyor-0.013 2 distributions installed grinnz@home ~> plenv rehash grinnz@home ~> dist_surveyor Can't locate version.pm in @INC (@INC contains: /home/grinnz/.plenv/versions/58test/lib/perl5/5.8.1/x86_64-linux /home/grinnz/.plenv/versions/58test/lib/perl5/5.8.1 /home/grinnz/.plenv/versions/58test/lib/perl5/site_perl/5.8.1/x86_64-linux /home/grinnz/.plenv/versions/58test/lib/perl5/site_perl/5.8.1 /home/grinnz/.plenv/versions/58test/lib/perl5/site_perl .) at /home/grinnz/.plenv/versions/58test/lib/perl5/site_perl/5.8.1/Dist/Surveyor.pm line 38. BEGIN failed--compilation aborted at /home/grinnz/.plenv/versions/58test/lib/perl5/site_perl/5.8.1/Dist/Surveyor.pm line 38. Compilation failed in require at /home/grinnz/.plenv/versions/58test/bin/dist_surveyor line 169. BEGIN failed--compilation aborted at /home/grinnz/.plenv/versions/58test/bin/dist_surveyor line 169.
Download (untitled) / with headers
text/plain 583b
And just after submitting I noticed that in dist.ini, the prereqs are intended to be runtime dependencies, but are specified incorrectly. Instead of: [Prereqs] version = 0 Compress::Zlib = 0 CPAN::DistnameInfo = 0 LWP::UserAgent = 0 Module::CoreList = 0 Module::Metadata = 0 JSON = 0 -phase = test Archive::Tar = 0 it should be: [Prereqs] version = 0 Compress::Zlib = 0 CPAN::DistnameInfo = 0 LWP::UserAgent = 0 Module::CoreList = 0 Module::Metadata = 0 JSON = 0 [Prereqs / TestRequires] -phase = test Archive::Tar = 0 because the -phase option applies to the plugin as a whole.
Download (untitled) / with headers
text/plain 155b
Thanks Dan. I doubt I'll get to this anytime soon. I'd be delighted to give you ownership, or co-maintainer, status so you can fix it yourself. Interested?
Download (untitled) / with headers
text/plain 333b
On Tue Jun 07 09:24:58 2016, TIMB wrote: Show quoted text
> Thanks Dan. I doubt I'll get to this anytime soon. I'd be delighted to > give you ownership, or co-maintainer, status so you can fix it > yourself. Interested?
Sure I'd be happy to fix it with comaint. Should I make a new github fork to work from? Don't want to confuse the repo situation.
Great. You're now a co-maint. Yes, a fork seems like the best way. Thanks!
Fixed in 0.014


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.