Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 11496
Status: open
Worked: 1 min
Priority: 0/
Queue: GD

People
Owner: LDS [...] cpan.org
Requestors: alessandro.avino [...] telecomitalia.it
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Problem with make test of GD installation
Date: Mon, 14 Feb 2005 08:43:10 +0100
From: "Avino Alessandro" <alessandro.avino [...] telecomitalia.it>
To: <bug-gd [...] rt.cpan.org>
Download (untitled) / with headers
text/plain 5.2k
Hi, my name is Alessandro I installed Perl 5.003_05 on my Sun Solaris (SUNW,Ultra-5_10, sun4u), with Solaris 5.7 Operating System. I used a gcc compiler (version 2.95) to compile all my components. Then, I successfully installed some perl Modules: - DBI-1.14 - DBD-Oracle-1.06 - GDTextUtil-0.80 - GDGraph-1.33 - CGI-FastTemplate-1.09 - Parse-RecDescent-1.80 - Spreadsheet-WriteExcel-0.36 The next module I would install was GD_1.30. but, first, zlib-1.1.4 libpng-1.2.5 gd-1.8.4 I had problem with the "make test" command. Here the log # make test /usr/bin/perl -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris -I/usr/local/bin/nsPerl5.005_03/lib /usr/local/bin/nsPerl5.005_03/lib/ExtUtils/xsubpp -object_capi -typemap /usr/local/bin/nsPerl5.005_03/lib/ExtUtils/typemap -typemap typemap GD.xs >xstmp.c && mv xstmp.c GD.c cc -c -I/usr/local/include -I/usr/local/include/gd -I/usr/local/include -O -DVERSION=\"1.30\" -DXS_VERSION=\"1.30\" -KPIC -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris/CORE -DHAVE_JPEG -DHAVE_TTF GD.c cc: unrecognized option `-KPIC' GD.xs: In function `XS_GD__Image_newFromXpm': GD.xs:539: warning: assignment makes pointer from integer without a cast LD_RUN_PATH="/usr/local/lib:/lib" cc -o blib/arch/auto/GD/GD.so -R/usr/local/lib -R/lib -G -L/usr/local/lib GD.o -L/usr/lib/X11 -L/usr/local/lib -lgd -lpng -lz -lm chmod 755 blib/arch/auto/GD/GD.so PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris -I/usr/local/bin/nsPerl5.005_03/lib -e 'use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t t/GD................Can't load './blib/arch/auto/GD/GD.so' for module GD: ld.so. 1: /usr/bin/perl: fatal: relocation error: file ./blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpegCtx: referenced symbol not found at /usr/local/bin/nsPerl5.005_03/lib/sun4-solaris/DynaLoader.pm line 169. at t/GD.t line 11 BEGIN failed--compilation aborted at t/GD.t line 11. dubious Test returned status 2 (wstat 512, 0x200) DIED. FAILED tests 1-10 Failed 10/10 tests, 0.00% okay Failed Test Status Wstat Total Fail Failed List of failed ------------------------------------------------------------------------ ------- t/GD.t 2 512 10 10 100.00% 1-10 Failed 1/1 test scripts, 0.00% okay. 10/10 subtests failed, 0.00% okay. *** Error code 2 make: Fatal error: Command failed for target `test_dynamic' But the "make install" was OK. So, I tried to install newer version of my components and so my new list of software is * ActivePerl-5.6.1.638-sun4-solaris * libpng-1.2.7-config * ljpegsrc.v6b * freetype-1.3.1 * gd-2.0.32 * GD-2.16 The problem remain and now I don't know what can I do. Here the new error log # make test PERL_DL_NONLAZY=1 /usr/local/ActivePerl-5.6/bin/perl -Iblib/arch -Iblib/lib -I/usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread-multi -I/usr/local/ActivePerl-5.6/lib/5.6.1 -e 'use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t t/GD..........Can't load './blib/arch/auto/GD/GD.so' for module GD: ld.so.1: /usr/local/ActivePerl-5.6/bin/perl: fatal: relocation error: file ./blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpeg: referenced symbol not found at /usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread-multi/DynaLoader .pm line 206. Compilation failed in require at t/GD.t line 13. BEGIN failed--compilation aborted at t/GD.t line 13. t/GD..........dubious Test returned status 255 (wstat 65280, 0xff00) DIED. FAILED tests 1-10 Failed 10/10 tests, 0.00% okay t/Polyline....Can't load 'blib/arch/auto/GD/GD.so' for module GD: ld.so.1: /usr/local/ActivePerl-5.6/bin/perl: fatal: relocation error: file blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpeg: referenced symbol not found at /usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread-multi/DynaLoader .pm line 206. Compilation failed in require at blib/lib/GD/Polyline.pm line 49. BEGIN failed--compilation aborted at blib/lib/GD/Polyline.pm line 49. Compilation failed in require at t/Polyline.t line 10. BEGIN failed--compilation aborted at t/Polyline.t line 10. t/Polyline....dubious Test returned status 255 (wstat 65280, 0xff00) DIED. FAILED test 1 Failed 1/1 tests, 0.00% okay Failed Test Stat Wstat Total Fail Failed List of Failed ------------------------------------------------------------------------ ------- t/GD.t 255 65280 10 20 200.00% 1-10 t/Polyline.t 255 65280 1 2 200.00% 1 Failed 2/2 test scripts, 0.00% okay. 11/11 subtests failed, 0.00% okay. *** Error code 2 make: Fatal error: Command failed for target `test_dynamic' Can you help me?? How can I resolve this situation?? Thanks so much Alessandro -------------------------------------------------------------------- CONFIDENTIALITY NOTICE This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to webmaster@telecomitalia.it. Thank you www.telecomitalia.it --------------------------------------------------------------------
Download (untitled) / with headers
text/html 11.2k
Download (untitled) / with headers
text/plain 6.3k
Current versions of the GD Perl module require you to install libgd (the C library) version 2.0.28 or higher. I am surprised that when you compiled the GD module, it didn't warn you about this requirement. Did you see a message like this one? NOTICE: This module requires libgd 2.0.25 or higher. it will NOT work with earlier versions. If you are getting compile or link errors, then please get and install a new version of libgd from www.boutell.com. Do NOT ask Lincoln for help until you try this. Lincoln [alessandro.avino@telecomitalia.it - Mon Feb 14 02:49:56 2005]: Show quoted text
> Hi, > my name is Alessandro > I installed Perl 5.003_05 on my Sun Solaris (SUNW,Ultra-5_10, sun4u), > with Solaris 5.7 Operating System. > I used a gcc compiler (version 2.95) to compile all my components. > Then, I successfully installed some perl Modules: > > - DBI-1.14 > - DBD-Oracle-1.06 > - GDTextUtil-0.80 > - GDGraph-1.33 > - CGI-FastTemplate-1.09 > - Parse-RecDescent-1.80 > - Spreadsheet-WriteExcel-0.36 > > The next module I would install was GD_1.30. but, first, > zlib-1.1.4 > libpng-1.2.5 > gd-1.8.4 > > I had problem with the "make test" command. Here the log > > # make test > /usr/bin/perl -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris > -I/usr/local/bin/nsPerl5.005_03/lib > /usr/local/bin/nsPerl5.005_03/lib/ExtUtils/xsubpp -object_capi > -typemap > /usr/local/bin/nsPerl5.005_03/lib/ExtUtils/typemap -typemap typemap > GD.xs >xstmp.c && mv xstmp.c GD.c > cc -c -I/usr/local/include -I/usr/local/include/gd > -I/usr/local/include > -O -DVERSION=\"1.30\" -DXS_VERSION=\"1.30\" -KPIC > -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris/CORE -DHAVE_JPEG > -DHAVE_TTF GD.c > cc: unrecognized option `-KPIC' > GD.xs: In function `XS_GD__Image_newFromXpm': > GD.xs:539: warning: assignment makes pointer from integer without a > cast > LD_RUN_PATH="/usr/local/lib:/lib" cc -o blib/arch/auto/GD/GD.so > -R/usr/local/lib -R/lib -G -L/usr/local/lib GD.o -L/usr/lib/X11 > -L/usr/local/lib -lgd -lpng -lz -lm > chmod 755 blib/arch/auto/GD/GD.so > PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib > -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris > -I/usr/local/bin/nsPerl5.005_03/lib -e 'use Test::Harness
qw(&runtests Show quoted text
> $verbose); $verbose=0; runtests @ARGV;' t/*.t > t/GD................Can't load './blib/arch/auto/GD/GD.so' for module > GD: ld.so. > 1: /usr/bin/perl: fatal: relocation error: file > ./blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpegCtx:
referenced Show quoted text
> symbol not found at > /usr/local/bin/nsPerl5.005_03/lib/sun4-solaris/DynaLoader.pm line
169. Show quoted text
> at t/GD.t line 11 > BEGIN failed--compilation aborted at t/GD.t line 11. > dubious > Test returned status 2 (wstat 512, 0x200) > DIED. FAILED tests 1-10 > Failed 10/10 tests, 0.00% okay > Failed Test Status Wstat Total Fail Failed List of failed >
------------------------------------------------------------------------ Show quoted text
> ------- > t/GD.t 2 512 10 10 100.00% 1-10 > Failed 1/1 test scripts, 0.00% okay. 10/10 subtests failed, 0.00% > okay. > *** Error code 2 > make: Fatal error: Command failed for target `test_dynamic' > > But the "make install" was OK. > > So, I tried to install newer version of my components and so my new > list > of software is > > * ActivePerl-5.6.1.638-sun4-solaris > * libpng-1.2.7-config > * ljpegsrc.v6b > * freetype-1.3.1 > * gd-2.0.32 > * GD-2.16 > > > The problem remain and now I don't know what can I do. Here the new > error log > > # make test > PERL_DL_NONLAZY=1 /usr/local/ActivePerl-5.6/bin/perl -Iblib/arch > -Iblib/lib > -I/usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread-multi > -I/usr/local/ActivePerl-5.6/lib/5.6.1 -e 'use Test::Harness > qw(&runtests > $verbose); $verbose=0; runtests @ARGV;' t/*.t > t/GD..........Can't load './blib/arch/auto/GD/GD.so' for module GD: > ld.so.1: /usr/local/ActivePerl-5.6/bin/perl: fatal: relocation error: > file ./blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpeg: > referenced > symbol not found at > /usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread- > multi/DynaLoader > .pm line 206. > Compilation failed in require at t/GD.t line 13. > BEGIN failed--compilation aborted at t/GD.t line 13. > t/GD..........dubious > > Test returned status 255 (wstat 65280, 0xff00) > DIED. FAILED tests 1-10 > Failed 10/10 tests, 0.00% okay > t/Polyline....Can't load 'blib/arch/auto/GD/GD.so' for module GD: > ld.so.1: /usr/local/ActivePerl-5.6/bin/perl: fatal: relocation error: > file blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpeg:
referenced Show quoted text
> symbol not found at > /usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread- > multi/DynaLoader > .pm line 206. > Compilation failed in require at blib/lib/GD/Polyline.pm line 49. > BEGIN failed--compilation aborted at blib/lib/GD/Polyline.pm line 49. > Compilation failed in require at t/Polyline.t line 10. > BEGIN failed--compilation aborted at t/Polyline.t line 10. > t/Polyline....dubious > > Test returned status 255 (wstat 65280, 0xff00) > DIED. FAILED test 1 > Failed 1/1 tests, 0.00% okay > Failed Test Stat Wstat Total Fail Failed List of Failed >
------------------------------------------------------------------------ Show quoted text
> ------- > t/GD.t 255 65280 10 20 200.00% 1-10 > t/Polyline.t 255 65280 1 2 200.00% 1 > Failed 2/2 test scripts, 0.00% okay. 11/11 subtests failed, 0.00% > okay. > *** Error code 2 > make: Fatal error: Command failed for target `test_dynamic' > > Can you help me?? > How can I resolve this situation?? > > > Thanks so much > > Alessandro > -------------------------------------------------------------------- > > CONFIDENTIALITY NOTICE > > This message and its attachments are addressed solely to the persons > above and may contain confidential information. If you have > received the message in error, be informed that any use of the > content hereof is prohibited. Please return it immediately to the > sender and delete the message. Should you have any questions, > please contact us by replying to webmaster@telecomitalia.it. > > Thank you > > www.telecomitalia.it > > --------------------------------------------------------------------
Hi Lincoln, Sorry, but pherhaps I forgot something. I tired to install first the gd 1.8.4 and then the new version gd- 2.0.32. Is this new version newer than the "2.0.28"? Or is libgd (C library, as you say) different from gd.2.0.32??? Thanks [LDS - Mon Mar 7 13:17:58 2005]: Show quoted text
> Current versions of the GD Perl module require you to install libgd > (the C library) version 2.0.28 or higher. I am surprised that when
you Show quoted text
> compiled the GD module, it didn't warn you about this requirement.
Did Show quoted text
> you see a message like this one? > > NOTICE: This module requires libgd 2.0.25 or higher. > it will NOT work with earlier versions. If you are getting > compile or link errors, then please get and install a new > version of libgd from www.boutell.com. Do NOT ask Lincoln > for help until you try this. > > Lincoln > [alessandro.avino@telecomitalia.it - Mon Feb 14 02:49:56 2005]: >
> > Hi, > > my name is Alessandro > > I installed Perl 5.003_05 on my Sun Solaris (SUNW,Ultra-5_10,
sun4u), Show quoted text
> > with Solaris 5.7 Operating System. > > I used a gcc compiler (version 2.95) to compile all my components. > > Then, I successfully installed some perl Modules: > > > > - DBI-1.14 > > - DBD-Oracle-1.06 > > - GDTextUtil-0.80 > > - GDGraph-1.33 > > - CGI-FastTemplate-1.09 > > - Parse-RecDescent-1.80 > > - Spreadsheet-WriteExcel-0.36 > > > > The next module I would install was GD_1.30. but, first, > > zlib-1.1.4 > > libpng-1.2.5 > > gd-1.8.4 > > > > I had problem with the "make test" command. Here the log > > > > # make test > > /usr/bin/perl -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris > > -I/usr/local/bin/nsPerl5.005_03/lib > > /usr/local/bin/nsPerl5.005_03/lib/ExtUtils/xsubpp -object_capi > > -typemap > > /usr/local/bin/nsPerl5.005_03/lib/ExtUtils/typemap -typemap typemap > > GD.xs >xstmp.c && mv xstmp.c GD.c > > cc -c -I/usr/local/include -I/usr/local/include/gd > > -I/usr/local/include > > -O -DVERSION=\"1.30\" -DXS_VERSION=\"1.30\" -KPIC > > -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris/CORE -DHAVE_JPEG > > -DHAVE_TTF GD.c > > cc: unrecognized option `-KPIC' > > GD.xs: In function `XS_GD__Image_newFromXpm': > > GD.xs:539: warning: assignment makes pointer from integer without a > > cast > > LD_RUN_PATH="/usr/local/lib:/lib" cc -o blib/arch/auto/GD/GD.so > > -R/usr/local/lib -R/lib -G -L/usr/local/lib GD.o -L/usr/lib/X11 > > -L/usr/local/lib -lgd -lpng -lz -lm > > chmod 755 blib/arch/auto/GD/GD.so > > PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib > > -I/usr/local/bin/nsPerl5.005_03/lib/sun4-solaris > > -I/usr/local/bin/nsPerl5.005_03/lib -e 'use Test::Harness
> qw(&runtests
> > $verbose); $verbose=0; runtests @ARGV;' t/*.t > > t/GD................Can't load './blib/arch/auto/GD/GD.so' for
module Show quoted text
> > GD: ld.so. > > 1: /usr/bin/perl: fatal: relocation error: file > > ./blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpegCtx:
> referenced
> > symbol not found at > > /usr/local/bin/nsPerl5.005_03/lib/sun4-solaris/DynaLoader.pm line
> 169.
> > at t/GD.t line 11 > > BEGIN failed--compilation aborted at t/GD.t line 11. > > dubious > > Test returned status 2 (wstat 512, 0x200) > > DIED. FAILED tests 1-10 > > Failed 10/10 tests, 0.00% okay > > Failed Test Status Wstat Total Fail Failed List of failed > >
> ----------------------------------------------------------------------
-- Show quoted text
> > ------- > > t/GD.t 2 512 10 10 100.00% 1-10 > > Failed 1/1 test scripts, 0.00% okay. 10/10 subtests failed, 0.00% > > okay. > > *** Error code 2 > > make: Fatal error: Command failed for target `test_dynamic' > > > > But the "make install" was OK. > > > > So, I tried to install newer version of my components and so my new > > list > > of software is > > > > * ActivePerl-5.6.1.638-sun4-solaris > > * libpng-1.2.7-config > > * ljpegsrc.v6b > > * freetype-1.3.1 > > * gd-2.0.32 > > * GD-2.16 > > > > > > The problem remain and now I don't know what can I do. Here the new > > error log > > > > # make test > > PERL_DL_NONLAZY=1 /usr/local/ActivePerl-5.6/bin/perl -Iblib/arch > > -Iblib/lib > > -I/usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread-multi > > -I/usr/local/ActivePerl-5.6/lib/5.6.1 -e 'use Test::Harness > > qw(&runtests > > $verbose); $verbose=0; runtests @ARGV;' t/*.t > > t/GD..........Can't load './blib/arch/auto/GD/GD.so' for module GD: > > ld.so.1: /usr/local/ActivePerl-5.6/bin/perl: fatal: relocation
error: Show quoted text
> > file ./blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpeg: > > referenced > > symbol not found at > > /usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread- > > multi/DynaLoader > > .pm line 206. > > Compilation failed in require at t/GD.t line 13. > > BEGIN failed--compilation aborted at t/GD.t line 13. > > t/GD..........dubious > > > > Test returned status 255 (wstat 65280, 0xff00) > > DIED. FAILED tests 1-10 > > Failed 10/10 tests, 0.00% okay > > t/Polyline....Can't load 'blib/arch/auto/GD/GD.so' for module GD: > > ld.so.1: /usr/local/ActivePerl-5.6/bin/perl: fatal: relocation
error: Show quoted text
> > file blib/arch/auto/GD/GD.so: symbol gdImageCreateFromJpeg:
> referenced
> > symbol not found at > > /usr/local/ActivePerl-5.6/lib/5.6.1/sun4-solaris-thread- > > multi/DynaLoader > > .pm line 206. > > Compilation failed in require at blib/lib/GD/Polyline.pm line 49. > > BEGIN failed--compilation aborted at blib/lib/GD/Polyline.pm line
49. Show quoted text
> > Compilation failed in require at t/Polyline.t line 10. > > BEGIN failed--compilation aborted at t/Polyline.t line 10. > > t/Polyline....dubious > > > > Test returned status 255 (wstat 65280, 0xff00) > > DIED. FAILED test 1 > > Failed 1/1 tests, 0.00% okay > > Failed Test Stat Wstat Total Fail Failed List of Failed > >
> ----------------------------------------------------------------------
-- Show quoted text
> > ------- > > t/GD.t 255 65280 10 20 200.00% 1-10 > > t/Polyline.t 255 65280 1 2 200.00% 1 > > Failed 2/2 test scripts, 0.00% okay. 11/11 subtests failed, 0.00% > > okay. > > *** Error code 2 > > make: Fatal error: Command failed for target `test_dynamic' > > > > Can you help me?? > > How can I resolve this situation?? > > > > > > Thanks so much > > > > Alessandro > > --------------------------------------------------------------------
Show quoted text
> > > > CONFIDENTIALITY NOTICE > > > > This message and its attachments are addressed solely to the
persons Show quoted text
> > above and may contain confidential information. If you have > > received the message in error, be informed that any use of the > > content hereof is prohibited. Please return it immediately to
the Show quoted text
> > sender and delete the message. Should you have any questions, > > please contact us by replying to webmaster@telecomitalia.it. > > > > Thank you > > > > www.telecomitalia.it > > > > --------------------------------------------------------------------
Show quoted text
> > >
Download (untitled) / with headers
text/plain 345b
[guest - Wed Mar 9 04:24:14 2005]: Show quoted text
> Hi Lincoln, > Sorry, but pherhaps I forgot something. > > I tired to install first the gd 1.8.4 and then the new version gd- > 2.0.32. > > Is this new version newer than the "2.0.28"? > Or is libgd (C library, as you say) different from gd.2.0.32??? > > Thanks > > alessandro.avino@telecomitalia.it
Download (untitled) / with headers
text/plain 345b
[guest - Wed Mar 9 04:24:14 2005]: Show quoted text
> Hi Lincoln, > Sorry, but pherhaps I forgot something. > > I tired to install first the gd 1.8.4 and then the new version gd- > 2.0.32. > > Is this new version newer than the "2.0.28"? > Or is libgd (C library, as you say) different from gd.2.0.32??? > > Thanks > > alessandro.avino@telecomitalia.it


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.