Skip Menu |
 

This queue is for tickets about the ExtUtils-F77 CPAN distribution.

Report information
The Basics
Id: 114780
Status: patched
Priority: 0/
Queue: ExtUtils-F77

People
Owner: chm [...] cpan.org
Requestors: sisyphus [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in:
  • 1.19
  • 1.19_1
Fixed in: (no value)



Subject: [Win32] F77.pm does not accommodate gcc-5.x.x
Download (untitled) / with headers
text/plain 728b
Hi, Now that gcc-5.x.x is up and about, we need the following small patch to F77.pm: ######################################### --- F77.pm_orig 2016-05-28 15:58:54 +1000 +++ F77.pm 2016-05-28 16:12:45 +1000 @@ -65,10 +65,10 @@ $fallback_compiler = 'GFortran'; } elsif($Config{gccversion}) { - # Could be either gcc-4.x.x or gcc-3.x.x + # Different fortran compiler for gcc-4.x.x (and later) versus gcc-3.x.x $gcc = 'gcc'; @version = split /\./, $Config{gccversion}; - $fallback_compiler = $version[0] == 4 ? 'GFortran' : 'G77'; + $fallback_compiler = $version[0] >= 4 ? 'GFortran' : 'G77'; $gfortran = 'gfortran'; } else { ######################################### Cheers, Rob
Fixed in git and in the just pushed CPAN developers release CHM/ExtUtils-F77-1.19_2.tar.gz which should appear at a mirror shortly. 


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.