Skip Menu |
 

This queue is for tickets about the once CPAN distribution.

Report information
The Basics
Id: 114313
Status: open
Priority: 0/
Queue: once

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.101420
Fixed in: (no value)



Subject: Fails tests when MakeMaker < 6.56 and Test::Differences not installed
Download (untitled) / with headers
text/plain 275b
As per subject. Reason is that Test::Differences is not in PREREQ_PM and BUILD_REQUIRES gets deleted with older MakeMaker on the user's end. Sample fail report: http://www.cpantesters.org/cpan/report/7328987 Ha, 5 years old and nobody complained? High time! :) Greetings,
Download (untitled) / with headers
text/plain 482b
On 2016-05-10 18:25:08, ANDK wrote: Show quoted text
> As per subject. Reason is that Test::Differences is not in PREREQ_PM > and BUILD_REQUIRES gets deleted with older MakeMaker on the user's > end. > > Sample fail report: > > http://www.cpantesters.org/cpan/report/7328987 > > Ha, 5 years old and nobody complained? High time! :) > > Greetings,
That prereq really ought to be in TEST_REQUIRES (which allows installation to be skipped with cpanm --notest), and "use ExtUtils::MakeMaker 6.64".


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.