Skip Menu |
 

This queue is for tickets about the PAR-Packer CPAN distribution.

Report information
The Basics
Id: 114229
Status: resolved
Priority: 0/
Queue: PAR-Packer

People
Owner: Nobody in particular
Requestors: CHUCKROB [...] cpan.org
ZDM [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: v1.32 still won't install on strawberry perl v5.22.2
Download (untitled) / with headers
text/plain 6.3k
Entering C:/Users/zdm/AppData/Local/Temp/PAR-Packer-1.032 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 6.59 ... Yes (7.14) Checking if you have ExtUtils::Embed 0 ... Yes (1.32) Running Makefile.PL Configuring PAR-Packer-1.032 ... *** You have extra Perl library paths set in your environment. Please note that these paths (set with PERL5LIB or PERLLIB) are not honored by perl when running under taint mode, which may lead to problems. This is a limitation (by design) of Perl, not of PAR::Packer; but some of the problems may manifest here during installation. Checking if your kit is complete... Looks good Prototype mismatch: sub main::prompt: none vs ($;$) at d:/devel/perl32/perl/lib/ExtUtils/MakeMaker.pm line 240. Writing MYMETA.yml and MYMETA.json Generating a dmake-style Makefile Writing Makefile for PAR::Packer Writing MYMETA.yml and MYMETA.json OK Checking dependencies from MYMETA.json ... Checking if you have Win32::Exe 0.17 ... Yes (0.17) Checking if you have ExtUtils::MakeMaker 0 ... Yes (7.14) Checking if you have IO::Compress::Gzip 0 ... Yes (2.069) Checking if you have Getopt::ArgvFile 1.07 ... Yes (1.11) Checking if you have Module::ScanDeps 1.21 ... Yes (1.21) Checking if you have Archive::Zip 1.02 ... Yes (1.57) Checking if you have ExtUtils::Embed 0 ... Yes (1.32) Checking if you have Compress::Zlib 1.16 ... Yes (2.069) Checking if you have Parse::Binary 0.04 ... Yes (0.11) Checking if you have PAR::Dist 0.22 ... Yes (0.49) Checking if you have Text::ParseWords 0 ... Yes (3.30) Checking if you have Win32::Process 0 ... Yes (0.16) Checking if you have PAR 1.010 ... Yes (1.010) Checking if you have File::Temp 0.05 ... Yes (0.2304) Building and testing PAR-Packer-1.032 ... cp lib/PAR/Filter/PodStrip.pm blib\lib\PAR\Filter\PodStrip.pm cp lib/PAR/Filter/Bytecode.pm blib\lib\PAR\Filter\Bytecode.pm cp lib/App/Packer/PAR.pm blib\lib\App\Packer\PAR.pm cp lib/pp.pm blib\lib\pp.pm cp lib/PAR/Filter/PatchContent.pm blib\lib\PAR\Filter\PatchContent.pm cp lib/PAR/Filter/Obfuscate.pm blib\lib\PAR\Filter\Obfuscate.pm cp lib/PAR/Filter/Bleach.pm blib\lib\PAR\Filter\Bleach.pm cp lib/PAR/StrippedPARL/Base.pm blib\lib\PAR\StrippedPARL\Base.pm cp lib/PAR/Packer.pm blib\lib\PAR\Packer.pm cp lib/PAR/Filter.pm blib\lib\PAR\Filter.pm "D:\devel\perl32\perl\bin\perl.exe" par_pl2c.pl my_par_pl < ..\script\par.pl > my_par_pl.c "D:\devel\perl32\perl\bin\perl.exe" sha1.c.PL gcc -c -s -O2 -DWIN32 -DPERL_TEXTMODE_SCRIPTS -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -fwrapv -fno-strict-aliasing -mms-bitfields -I"D:\devel\perl32\perl\lib\CORE" -DPARL_EXE=\"parl.exe\" -s -O2 main.c windres -i winres/pp.rc -o ppresource.coff --input-format=rc --output-format=coff --target=pe-i386 g++.exe main.o ppresource.coff -s -s -L"D:\devel\perl32\perl\lib\CORE" -L"D:\devel\perl32\c\lib" "D:\devel\perl32\perl\lib\CORE\libperl522.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libmoldname.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libkernel32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libuser32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libgdi32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libwinspool.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libcomdlg32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libadvapi32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libshell32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libole32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\liboleaut32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libnetapi32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libuuid.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libws2_32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libmpr.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libwinmm.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libversion.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libodbc32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libodbccp32.a" "D:\devel\perl32\c\i686-w64-mingw32\lib\libcomctl32.a" -o par.exe rem "D:\devel\perl32\perl\bin\perl.exe" encode_append.pl Dynamic.in par.exe Dynamic.pm "D:\devel\perl32\perl\bin\perl.exe" embed_files.pl -c 32768 par.exe "D:\devel\perl32\perl\bin\perl522.dll" "D:\devel\perl32\perl\bin\libgcc_s_sjlj-1.dll" "D:\devel\perl32\perl\bin\libwinpthread-1.dll" "D:\devel\perl32\perl\bin\libstdc++-6.dll" > boot_embedded_files.c # using "objdump" recusrively to find DLLs needed by par.exe # embedding "par.exe" as "par.exe" # embedding "D:/devel/perl32/perl/bin/libwinpthread-1.dll" as "libwinpthread-1.dll" # embedding "D:/devel/perl32/perl/bin/libgcc_s_sjlj-1.dll" as "libgcc_s_sjlj-1.dll" # embedding "D:/devel/perl32/perl/bin/perl522.dll" as "perl522.dll" # embedding "D:/devel/perl32/perl/bin/libstdc++-6.dll" as "libstdc++-6.dll" gcc -c -s -O2 -DWIN32 -DPERL_TEXTMODE_SCRIPTS -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -fwrapv -fno-strict-aliasing -mms-bitfields -I"D:\devel\perl32\perl\lib\CORE" -DPARL_EXE=\"parl.exe\" -s -O2 boot.c In file included from mktmpdir.h:85:0, from mktmpdir.c:1, from boot.c:10: sha1.c: In function 'sha_transform': sha1.c:146:2: warning: right shift count >= width of type T >>= 32; ^ g++.exe boot.o -static-libgcc ppresource.coff -o boot.exe rem "D:\devel\perl32\perl\bin\perl.exe" encode_append.pl Static.in boot.exe Static.pm cp Dynamic.pm ..\blib\lib\PAR\StrippedPARL\Dynamic.pm cp Static.pm ..\blib\lib\PAR\StrippedPARL\Static.pm "D:\devel\perl32\perl\bin\perl.exe" -Mblib=.. run_with_inc.pl boot.exe -q -B -Oparl.exe "D:\devel\perl32\perl\bin\perl.exe" -MExtUtils::Command -e cp -- parl.exe ..\blib\script\parl.exe rem ..\blib\script\parl.exe "D:\devel\perl32\perl\bin\perl.exe" -Mblib=.. run_with_inc.pl par.exe -q -B -Oparldyn.exe "D:\devel\perl32\perl\bin\perl.exe" -MExtUtils::Command -e cp -- parldyn.exe ..\blib\script\parldyn.exe rem ..\blib\script\parldyn.exe "D:\devel\perl32\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/par.pl blib\script\par.pl pl2bat.bat blib\script\par.pl "D:\devel\perl32\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/pp blib\script\pp pl2bat.bat blib\script\pp "D:\devel\perl32\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/tkpp blib\script\tkpp pl2bat.bat blib\script\tkpp dmake: Error: -- Don't know how to make `test_dynamic' dmake.exe: Error code 255, while making 'subdirs-test_dynamic' FAIL ! Installing . failed. See C:\Users\zdm\AppData\Local\Temp\.cpanm\work\1462620115.4548\build.log for details. Retry with --force to force install it.
Download (untitled) / with headers
text/plain 906b
On 2016-05-07 07:26:00, ZDM wrote: Show quoted text
> dmake: Error: -- Don't know how to make `test_dynamic' > dmake.exe: Error code 255, while making 'subdirs-test_dynamic' > FAIL
ExtUtils::MakeMaker changed its behaviour (and Strawberry is crazy to include this version and not the one released with perl 5.22.2) :( Apply the patch below, will be in the next release of PAR::Packer. Cheers, Roderich Index: myldr/Makefile.PL =================================================================== --- myldr/Makefile.PL (revision 1679) +++ myldr/Makefile.PL (working copy) @@ -290,7 +290,7 @@ WriteMakefile( NAME => "myldr", - SKIP => [qw(static static_lib dynamic dynamic_lib test)], + SKIP => [qw(static static_lib dynamic dynamic_lib)], NO_META => 1, PL_FILES => {}, PM => { map { $_ => catfile('$(INST_LIBDIR)', qw( PAR StrippedPARL ), $_) } :;
Subject: Installing pp (or PAR) doesn't work
Download (untitled) / with headers
text/plain 3.1k
Win 7 64-bit and Strawberry perl 5.24.0 64-bit. Installing pp doesn't work. I installed a fresh copy of Strawberry Perl 5.24.0 just now. Then I did: cpanm pp This is the whole screen output of what I got: C:\chuck\strawperl524>cpanm pp --> Working on pp Fetching http://www.cpan.org/authors/id/R/RS/RSCHUPP/PAR-Packer-1.032.tar.gz ... OK Configuring PAR-Packer-1.032 ... OK ==> Found dependencies: Module::ScanDeps, Getopt::ArgvFile --> Working on Module::ScanDeps Fetching http://www.cpan.org/authors/id/R/RS/RSCHUPP/Module-ScanDeps-1.21.tar.gz ... OK Configuring Module-ScanDeps-1.21 ... OK Building and testing Module-ScanDeps-1.21 ... OK Successfully installed Module-ScanDeps-1.21 --> Working on Getopt::ArgvFile Fetching http://www.cpan.org/authors/id/J/JS/JSTENZEL/Getopt-ArgvFile-1.11.tar.g z ... OK Configuring Getopt-ArgvFile-1.11 ... OK Building and testing Getopt-ArgvFile-1.11 ... OK Successfully installed Getopt-ArgvFile-1.11 Building and testing PAR-Packer-1.032 ... FAIL ! Installing pp failed. See C:\Users\chuck\.cpanm\work\1463574810.57248\build.log for details. Retry with --force to force install it. 2 distributions installed C:\chuck\strawperl524> These are the last lines of build.log: # embedding "C:/chuck/strawperl524/perl/bin/libstdc++-6.dll" as "libstdc++-6.dll" gcc -c -s -O2 -DWIN32 -DWIN64 -DCONSERVATIVE -DPERL_TEXTMODE_SCRIPTS -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -fwrapv -fno-strict-aliasing -mms-bitfields -I"C:\chuck\strawperl524\perl\lib\CORE" -DPARL_EXE=\"parl.exe\" -s -O2 boot.c In file included from mktmpdir.h:85:0, from mktmpdir.c:1, from boot.c:10: sha1.c: In function 'sha_transform': sha1.c:146:2: warning: right shift count >= width of type T >>= 32; ^ g++ boot.o -static-libgcc ppresource.coff -o boot.exe rem "C:\chuck\strawperl524\perl\bin\perl.exe" encode_append.pl Static.in boot.exe Static.pm cp Dynamic.pm ..\blib\lib\PAR\StrippedPARL\Dynamic.pm cp Static.pm ..\blib\lib\PAR\StrippedPARL\Static.pm "C:\chuck\strawperl524\perl\bin\perl.exe" -Mblib=.. run_with_inc.pl boot.exe -q -B -Oparl.exe "C:\chuck\strawperl524\perl\bin\perl.exe" -MExtUtils::Command -e cp -- parl.exe ..\blib\script\parl.exe rem ..\blib\script\parl.exe "C:\chuck\strawperl524\perl\bin\perl.exe" -Mblib=.. run_with_inc.pl par.exe -q -B -Oparldyn.exe "C:\chuck\strawperl524\perl\bin\perl.exe" -MExtUtils::Command -e cp -- parldyn.exe ..\blib\script\parldyn.exe rem ..\blib\script\parldyn.exe "C:\chuck\strawperl524\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/par.pl blib\script\par.pl pl2bat.bat blib\script\par.pl "C:\chuck\strawperl524\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/pp blib\script\pp pl2bat.bat blib\script\pp "C:\chuck\strawperl524\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/tkpp blib\script\tkpp pl2bat.bat blib\script\tkpp dmake: Error: -- Don't know how to make `test_dynamic' dmake.exe: Error code 255, while making 'subdirs-test_dynamic' -> FAIL Installing pp failed. See C:\Users\chuck\.cpanm\work\1463574810.57248\build.log for details. Retry with --force to force install it. 2 distributions installed Anyone know a solution for this? Thanks.
Download (untitled) / with headers
text/plain 1.4k
It was trying to install PAR::Packer 1.032. Doing: > cpanm PAR::Packer gives me the same error from build.log: g++ boot.o -static-libgcc ppresource.coff -o boot.exe rem "C:\chuck\strawperl524\perl\bin\perl.exe" encode_append.pl Static.in boot.exe Static.pm cp Static.pm ..\blib\lib\PAR\StrippedPARL\Static.pm cp Dynamic.pm ..\blib\lib\PAR\StrippedPARL\Dynamic.pm "C:\chuck\strawperl524\perl\bin\perl.exe" -Mblib=.. run_with_inc.pl boot.exe -q -B -Oparl.exe "C:\chuck\strawperl524\perl\bin\perl.exe" -MExtUtils::Command -e cp -- parl.exe ..\blib\script\parl.exe rem ..\blib\script\parl.exe "C:\chuck\strawperl524\perl\bin\perl.exe" -Mblib=.. run_with_inc.pl par.exe -q -B -Oparldyn.exe "C:\chuck\strawperl524\perl\bin\perl.exe" -MExtUtils::Command -e cp -- parldyn.exe ..\blib\script\parldyn.exe rem ..\blib\script\parldyn.exe "C:\chuck\strawperl524\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/par.pl blib\script\par.pl pl2bat.bat blib\script\par.pl "C:\chuck\strawperl524\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/pp blib\script\pp pl2bat.bat blib\script\pp "C:\chuck\strawperl524\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e cp -- script/tkpp blib\script\tkpp pl2bat.bat blib\script\tkpp dmake: Error: -- Don't know how to make `test_dynamic' dmake.exe: Error code 255, while making 'subdirs-test_dynamic' -> FAIL Installing PAR::Packer failed. See C:\Users\chuck\.cpanm\work\1463576740.58744\build.log for details. Retry with --force to force install it.
Download (untitled) / with headers
text/plain 298b
Top of 2nd build.log file above says: cpanm (App::cpanminus) 1.7041 on perl 5.024000 built for MSWin32-x64-multi-thread Work directory is C:\Users\chuck/.cpanm/work/1463576740.58744 You have make C:\chuck\strawperl524\c\bin\dmake.exe You have LWP 6.15 So I ran dmake -V and dmake is v 4.12.
Download (untitled) / with headers
text/plain 118b
Should my newly merged bug go in the PAR-Packer bug area? See https://rt.cpan.org/Dist/Display.html?Name=PAR-Packer.
Download (untitled) / with headers
text/plain 219b
Is there a version of Strawberry Perl where PAR::Packer actually installs and works? I got pp to install on 5.14.4 for Windows 7 64-bit but when the exe was run I got an error in PAR.pm. I don't remember the error.
Download (untitled) / with headers
text/plain 111b
Duplicate of #114229. See above for a trivial patch (until the next release of PAR::Packer). Cheers, Roderich
Subject: Re: [rt.cpan.org #114229] v1.32 still won't install on strawberry perl v5.22.2
Date: Wed, 18 May 2016 16:21:17 +0300
To: bug-PAR-Packer [...] rt.cpan.org
From: "dzagashev [...] gmail.com" <dzagashev [...] gmail.com>
Download (untitled) / with headers
text/plain 364b
It works on 5.22.0, 5.22.1. On 18.05.2016 16:20, Chuck R. via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=114229 > > > Is there a version of Strawberry Perl where PAR::Packer actually installs and works? > > I got pp to install on 5.14.4 for Windows 7 64-bit but when the exe was run I got an error in PAR.pm. I don't remember the error. > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.