Skip Menu |
 

This queue is for tickets about the Net-SSH-Perl CPAN distribution.

Report information
The Basics
Id: 114225
Status: open
Priority: 0/
Queue: Net-SSH-Perl

People
Owner: schwigon [...] cpan.org
Requestors: blinder.ip [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Required version CryptX in Net-SSH-Perl-2.01
Date: Sat, 7 May 2016 10:46:19 +0300
To: bug-Net-SSH-Perl [...] rt.cpan.org
From: Игорь Блиндер <blinder.ip [...] gmail.com>
Download (untitled) / with headers
text/plain 401b
Noticed, that in last version Net-SSH-Perl-2.01, requires version CryptX => 0.26. Latest available version CryptX 0.032: http://search.cpan.org/dist/CryptX/ Because of this, when try to add a package that uses the Net-SSH-Perl in pinto, there is an error, because it can not find package CryptX-0.26 or newer. Perhaps in depending, it is necessary to specify version CryptX 0.026? -- Thanks, Igor
Download (untitled) / with headers
text/plain 994b
On 2016-05-07 03:46:29, blinder.ip@gmail.com wrote: Show quoted text
> Noticed, that in last version Net-SSH-Perl-2.01, requires version CryptX => > 0.26. > Latest available version CryptX 0.032: http://search.cpan.org/dist/CryptX/ > > Because of this, when try to add a package that uses the Net-SSH-Perl in > pinto, there is an error, because it can not find package CryptX-0.26 or > newer. > > Perhaps in depending, it is necessary to specify version CryptX 0.026?
While the CryptX version specified in Net-SSH-Perl's META.yml is certainly wrong, I also think that pinto is doing something wrong here. This META.yml sets dynamic_config=1, which means that the dependency information must be determined by running Makefile.PL or Build.PL (in this case the META.yml information may only be used for rough statistical purposes). In Makefile.PL the minimum CryptX version does not look wrong (it's just 0). So maybe open an issue at pinto's bugtracker, or maybe this is already a known limitation of pinto?
Download (untitled) / with headers
text/plain 744b
Hi Игорь Блиндер, can you retry your work with the just uploaded v2.12 of Net::SSH::Perl? Maybe it helps to fix or avoid this issue. Kind regards, Steffen On Sat May 07 03:46:29 2016, blinder.ip@gmail.com wrote: Show quoted text
> Noticed, that in last version Net-SSH-Perl-2.01, requires version CryptX => > 0.26. > Latest available version CryptX 0.032: http://search.cpan.org/dist/CryptX/ > > Because of this, when try to add a package that uses the Net-SSH-Perl in > pinto, there is an error, because it can not find package CryptX-0.26 or > newer. > > Perhaps in depending, it is necessary to specify version CryptX 0.026? > > -- > Thanks, > Igor
-- Steffen Schwigon <ss5@renormalist.net> Dresden Perl Mongers <http://dresden-pm.org/>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.