Skip Menu |
 

This queue is for tickets about the MooseX-Types-Structured CPAN distribution.

Report information
The Basics
Id: 114060
Status: resolved
Priority: 0/
Queue: MooseX-Types-Structured

People
Owner: ether [...] cpan.org
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.36



Subject: Build.PL fails and Makefile.PL passes in certain constellations
Download (untitled) / with headers
text/plain 908b
I got this from one of my smokers with 5.12.5: Configuring E/ET/ETHER/MooseX-Types-Structured-0.35.tar.gz with Build.PL CPAN: CPAN::Reporter loaded ok (v1.2017) Wide character in subroutine entry at /home/sand/src/perl/repoperls/installed-perls/perl/v5.12.5/79cc/lib/site_perl/5.12.5/Parse/CPAN/Meta.pm line 53. at /home/sand/src/perl/repoperls/installed-perls/perl/v5.12.5/79cc/lib/site_perl/5.12.5/CPAN/Meta.pm line 301. at /home/sand/src/perl/repoperls/installed-perls/perl/v5.12.5/79cc/lib/site_perl/5.12.5/Module/Build/Tiny.pm line 33. (/home/sand/src/perl/repoperls/installed-perls/perl/v5.12.5/79cc/bin/perl Build.PL exited with 65280) After I configured my cpan shell to prefer_installer=EUMM, I could pass the tests. Moose was 2.1705, Module::Build was 0.4218, Parse::CPAN::Meta was 1.4418 Also downgrading Parse::CPAN::Meta to 1.4417 seemed to help. Let me know if you need more information.
On 2016-04-28 20:25:48, ANDK wrote: Show quoted text
> I got this from one of my smokers with 5.12.5: > > Configuring E/ET/ETHER/MooseX-Types-Structured-0.35.tar.gz with > Build.PL > CPAN: CPAN::Reporter loaded ok (v1.2017) > Wide character in subroutine entry at > /home/sand/src/perl/repoperls/installed- > perls/perl/v5.12.5/79cc/lib/site_perl/5.12.5/Parse/CPAN/Meta.pm line > 53. > at /home/sand/src/perl/repoperls/installed- > perls/perl/v5.12.5/79cc/lib/site_perl/5.12.5/CPAN/Meta.pm line 301. > at /home/sand/src/perl/repoperls/installed- > perls/perl/v5.12.5/79cc/lib/site_perl/5.12.5/Module/Build/Tiny.pm line > 33. > (/home/sand/src/perl/repoperls/installed- > perls/perl/v5.12.5/79cc/bin/perl Build.PL exited with 65280) > > After I configured my cpan shell to prefer_installer=EUMM, I could > pass the tests. Moose was 2.1705, Module::Build was 0.4218, > Parse::CPAN::Meta was 1.4418 > > Also downgrading Parse::CPAN::Meta to 1.4417 seemed to help. > > Let me know if you need more information.
Yup, that's https://github.com/Perl-Toolchain-Gang/Parse-CPAN-Meta/issues/12.
Download (untitled) / with headers
text/plain 131b
I've just released 0.36 -- with newer Parse::CPAN::Meta etc, and unicode chars removed from META.json, this should go a lot better.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.