Skip Menu |
 

This queue is for tickets about the TryCatch CPAN distribution.

Report information
The Basics
Id: 114033
Status: resolved
Priority: 0/
Queue: TryCatch

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.003002
Fixed in: (no value)



Subject: Does not work anymore with perl 5.24.0
Download (untitled) / with headers
text/plain 480b
perl 5.24.0 will be released soon, and TryCatch will not work with this perl version. Problem is the dependency on Scope::Upper, which is broken with perl 5.23.8 and newer. See https://rt.cpan.org/Ticket/Display.html?id=112246 for more details. Consequently there are also no TryCatch reports on CPAN Testers for perls > 5.23.8: http://matrix.cpantesters.org/?dist=TryCatch+1.003002 I don't know if it's possible to not rely on Scope::Upper here, or if there's another solution.
Download (untitled) / with headers
text/plain 717b
On 2016-04-28 07:02:13, SREZIC wrote: Show quoted text
> perl 5.24.0 will be released soon, and TryCatch will not work with > this perl version. Problem is the dependency on Scope::Upper, which is > broken with perl 5.23.8 and newer. See > https://rt.cpan.org/Ticket/Display.html?id=112246 for more details. > > Consequently there are also no TryCatch reports on CPAN Testers for > perls > 5.23.8: > http://matrix.cpantesters.org/?dist=TryCatch+1.003002 > > I don't know if it's possible to not rely on Scope::Upper here, or if > there's another solution.
Scope::Upper was fixed (in version 0.29), so this is not anymore an issue. Pass reports exist for perl 5.24.x and 5.25.x: http://matrix.cpantesters.org/?dist=TryCatch+1.003002


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.