Skip Menu |
 

This queue is for tickets about the List-MoreUtils CPAN distribution.

Report information
The Basics
Id: 113818
Status: rejected
Priority: 0/
Queue: List-MoreUtils

People
Owner: Nobody in particular
Requestors: jason.vas.dias [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: tests fail when run against default RHEL-7 (OEL7) packages
Download (untitled) / with headers
text/plain 1.7k
When building List::MoreUtils with CPAN, on an as-installed Oracle Enterprise Linux (OEL) 7 server, these tests fail: <quote><pre> PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/pureperl/*.t xt/*.t t/pureperl/ab.t ......... ok t/pureperl/Functions.t .. 1/? # Failed test 'is_dying()' # at t/lib/LMU/Test/Functions.pm line 322. # Failed test 'is_dying()' # at t/lib/LMU/Test/Functions.pm line 327. # Failed test 'is_dying()' # at t/lib/LMU/Test/Functions.pm line 349. # Failed test 'is_dying()' # at t/lib/LMU/Test/Functions.pm line 983. # Failed test 'is_dying()' # at t/lib/LMU/Test/Functions.pm line 1026. # Looks like you failed 5 tests of 3465. t/pureperl/Functions.t .. Dubious, test returned 5 (wstat 1280, 0x500) Failed 5/3465 subtests (less 54 skipped subtests: 3406 okay) t/pureperl/Import.t ..... ok t/pureperl/XS.t ......... ok Test Summary Report ------------------- t/pureperl/Functions.t (Wstat: 1280 Tests: 3465 Failed: 5) Failed tests: 126-127, 132, 309, 317 Non-zero exit status: 5 Files=4, Tests=3468, 0 wallclock secs ( 0.15 usr 0.01 sys + 0.38 cusr 0.02 csys = 0.56 CPU) Result: FAIL Failed 1/4 test programs. 5/3468 subtests failed. make: *** [test_dynamic] Error 255 REHSACK/List-MoreUtils-0.413.tar.gz /usr/bin/make test -- NOT OK </pre></quote> Could it be a problem with the installed perl / List::Utils versions ? : $ rpm -q perl perl-Scalar-List-Utils perl-5.16.3-286.el7.x86_64 perl-Scalar-List-Utils-1.27-248.el7.x86_64 If so, this should be detected during configuration / specified in package requirements. I'm trying to use Net::IMAP::Client, which depends on it. Is this package actively maintained ?
Download (untitled) / with headers
text/plain 185b
Would you please be so kind and execute $ perl -Mblib -MList::MoreUtils=insert_after -lE 'say List::MoreUtils->VERSION;&insert_after( sub { }, 4711, "13" )' and paste the result here?
From: jason.vas.dias [...] gmail.com
Download (untitled) / with headers
text/plain 297b
The tests do succeed when run in a freshly built perl-5.22.1 installation with $ cpan ... cpan[1]> install Net::IMAP::Client ... $ echo $? 0 But I think List::MoreUtils should detect the case when it is going to fail and complain, or specify the version dependency on an up to date PERL.
From: jason.vas.dias [...] gmail.com
Download (untitled) / with headers
text/plain 691b
On Fri Apr 15 14:54:13 2016, REHSACK wrote: Show quoted text
> Would you please be so kind and execute > > $ perl -Mblib -MList::MoreUtils=insert_after -lE 'say List::MoreUtils-
> >VERSION;&insert_after( sub { }, 4711, "13" )'
> > and paste the result here?
Unfortunately, that's not going to work, because REHSACK/List-MoreUtils-0.413.tar.gz failed to be installed by CPAN . I don't install packages that fail their tests. However, I have access to a freshly installed Linux-4.5.0 LFS system where it does install OK - see last mail. But I think LMU should detect the case where it has a too old PERL version to pass its tests and complain about it / specify correct version dependency requirements.
Download (untitled) / with headers
text/plain 208b
Please go into the directory where your List-MoreUtils is built and execute the above specified line. List::MoreUtils detects the wrong setup and fails the test. That is good and behaves exactly as expected.
It is not a L::MU problem but a weird setup. Reported does not know how to do sanity checks.
Download (untitled) / with headers
text/plain 498b
On 2016-04-15 15:09:48, jvdias wrote: [...] Show quoted text
> But I think LMU should detect the case where > it has a too old PERL version to pass its tests > and complain about it / specify correct version > dependency requirements.
LMU is supposed to work with much older perls, and CPAN Testers report passes down to perl 5.8.1: http://matrix.cpantesters.org/?dist=List-MoreUtils+0.413 On the other hand, there's no known failure with perl 5.16.3. So maybe it's worth to a little bit of investigation here...
Download (untitled) / with headers
text/plain 648b
CentOS 7 comes with much more recent perl than 5.8.1. I'm happy to investigate - but I can't reproduce the issue so I presume the reporter has something weird in his setup. As long as he doesn't take his environment and executes the commands I (or in case you want to guide him: you) specify, I'm out. I'm happy to fix issues I can reproduce, I'm happy to discuss when I can't to guide me to do. But I don't see it as my job to follow every test failure, cause most not obvious are setup errors. I do all of this in my spare time. I don't earn money with maintaining Perl modules. If you are hired to support cpan modules out there, be my guest.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.