Skip Menu |
 

This queue is for tickets about the Geo-Hash-XS CPAN distribution.

Report information
The Basics
Id: 113598
Status: stalled
Priority: 0/
Queue: Geo-Hash-XS

People
Owner: dmaki [...] cpan.org
Requestors: MRDVT [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.00015
Fixed in: (no value)



Subject: Geo-Hash-XS - Test::More => 0.94 too high for no apparent reason
Download (untitled) / with headers
text/plain 361b
Show quoted text
> test_requires 'Test::More' => '0.94';
All tests passed under EL6 packaged RPM. perl-Test-Simple-0.92-141.el6.x86_64 Please think about lowering this requirement unless you have a valid reason to be higher than apparently needed so than cpanspec -b Geo-Hash-XS-0.00015.tar.gz can automatically build the RPM. Normally the minimum required version is 0.44.
Download (untitled) / with headers
text/plain 485b
On 2016-04-07 09:21:00, MRDVT wrote: Show quoted text
> > test_requires 'Test::More' => '0.94';
> > All tests passed under EL6 packaged RPM. > > perl-Test-Simple-0.92-141.el6.x86_64 > > Please think about lowering this requirement unless you have a valid > reason to be higher than apparently needed so than cpanspec -b Geo- > Hash-XS-0.00015.tar.gz can automatically build the RPM. > > Normally the minimum required version is 0.44.
done_testing() requies 0.88. (working) subtest requires 0.94.
Download (untitled) / with headers
text/plain 198b
As Karen says, "subtest" is being used in xt/*.t If you can send a Pull Request to https://github.com/lestrrat/Geo-Hash-XS which does away with the use of subtest, I can certainly upload a new one.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.