Skip Menu |
 

This queue is for tickets about the RPerl CPAN distribution.

Report information
The Basics
Id: 113430
Status: open
Priority: 0/
Queue: RPerl

People
Owner: WBRASWELL [...] cpan.org
Requestors:
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.600000
Fixed in: (no value)



Subject: RPerl no longer compiles on v5.24.8
Download (untitled) / with headers
text/plain 801b
It seems that RPerl no longer compiles on recent bleadperls. Looks like RPerl was leaning a bit on the guts of the context system, which has been overhauled. It is now documented (but still unstable) here: https://metacpan.org/pod/release/XSAWYERX/perl-5.23.8/pod/perlguts.pod#Dynamic-Scope-and-the-Context-Stack This was originally reported to perl5-porters in https://rt.perl.org/Ticket/Display.html?id=127727 but initial attempts to sort out what's going on in your code were not quickly successful. Most likely, you need to update your code, under 5.23.8+, to use the new context system. I'm going to close the rt.perl.org ticket and let you take over, but please ask on p5p if you need any information, or hit problems, or think that there is something more going on here. Thanks! -- rjbs
Download (untitled) / with headers
text/plain 655b
UPDATE: I just noticed that Travis-CI is running Perl v5.24.0 and this bug references v5.24.8, perhaps that is why I'm not seeing the errors yet? ------------- I sent this reply today to the following people: Ricardo Signes, Andreas J. Koenig, David Mitchell, Karl Williamson, Sawyer X ...We have released RPerl v2.4 which seems to pass all tests just fine on Travis-CI using Perl v5.10 through v5.24: https://travis-ci.org/wbraswell/rperl/builds/188169191 Does this mean that somehow this issue has been solved, without me actually trying to fix it? If not, how can I find out more info on the actual bug itself? Thanks! Perling, ~ Will the Chill
Subject: RPerl no longer compiles on v5.25.8
On 2017-01-02 22:37:26, WBRASWELL wrote: Show quoted text
> UPDATE: I just noticed that Travis-CI is running Perl v5.24.0 and this > bug references v5.24.8, perhaps that is why I'm not seeing the errors > yet?
Probably the bug report should say v5.25.8, there's no v5.24.8. http://analysis.cpantesters.org/beforemaintrelease?pair=5.24.0:5.25.10 shows that there are zero pass reports for RPerl-2.450000 on perl 5.25.10. And I remember fail reports which said "Unescaped left brace in regex is deprecated", so probably this is the reason... Show quoted text
> > ------------- > > I sent this reply today to the following people: > Ricardo Signes, Andreas J. Koenig, David Mitchell, Karl Williamson, > Sawyer X > > ...We have released RPerl v2.4 which seems to pass all tests just fine > on Travis-CI using Perl v5.10 through v5.24: > > https://travis-ci.org/wbraswell/rperl/builds/188169191 > > Does this mean that somehow this issue has been solved, without me > actually trying to fix it? > > If not, how can I find out more info on the actual bug itself? > > Thanks! > > Perling, > ~ Will the Chill
Download (untitled) / with headers
text/plain 229b
On 2017-03-03 02:08:33, SREZIC wrote: Show quoted text
> Probably the bug report should say v5.25.8, there's no v5.24.8.
The bug report meant v5.23.8. I am no longer managing Perl 5 releases, so I have removed myself from this ticket. -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.