Skip Menu |
 

This queue is for tickets about the Perl-Critic-Deprecated CPAN distribution.

Report information
The Basics
Id: 113165
Status: new
Priority: 0/
Queue: Perl-Critic-Deprecated

People
Owner: Nobody in particular
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.119
Fixed in: (no value)



Subject: Should depend on Perl::Critic 1.118

Due to the migration of packages from the core Perl::Critic dist into Perl::Critic::Deprecated, it would be best if ::Deprecated stipulated a minimum version.

Otherwise it risks entering the secenario where Perl::Critic:Deprecated is over-writes files that is still listed in Perl::Critic's .packlist

And that same mechanic can lead to file-system collisions on vendors that have a highly regulated package<->file ownership system similar to .packlists



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.