Skip Menu |
 

This queue is for tickets about the Scalar-List-Utils CPAN distribution.

Report information
The Basics
Id: 112312
Status: resolved
Priority: 0/
Queue: Scalar-List-Utils

People
Owner: Nobody in particular
Requestors: davem [...] iabyn.com
Cc: KENTNL [...] cpan.org
ribasushi [...] leporine.io
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 1.44



Subject: Scalar-List-Utils: failure to build under perl 5.23.8
Date: Tue, 23 Feb 2016 16:04:27 +0000
To: bug-Scalar-List-Utils [...] rt.cpan.org
From: Dave Mitchell <davem [...] iabyn.com>
Download (untitled) / with headers
text/plain 440b
My patch from Dec 2014 to fix compiler warnings (it basically added lots of PERL_UNUSED_VAR(newsp)), now causes it fail to compile under bleadperl (5.23.8) due a change of mine in blead that removes the newsp variable from dMULTICALL (Sorry!) So the PERL_UNUSED_VAR(newsp)'s should only appear for perl < 5.23.8. Dave. -- I don't want to achieve immortality through my work... I want to achieve it through not dying. -- Woody Allen
Paul, any word on this?
Download (untitled) / with headers
text/plain 211b
On Tue Mar 08 14:47:10 2016, RIBASUSHI wrote: Show quoted text
> Paul, any word on this?
I imagine it wants some version-guarding. I can probably look into it but if someone sent me a patch it might be faster. -- Paul Evans
Download (untitled) / with headers
text/plain 311b
On 2016-03-08 20:46:50, PEVANS wrote: Show quoted text
> On Tue Mar 08 14:47:10 2016, RIBASUSHI wrote:
> > Paul, any word on this?
> > I imagine it wants some version-guarding. > > I can probably look into it but if someone sent me a patch it might be > faster.
https://github.com/Scalar-List-Utils/Scalar-List-Utils/pull/39
This was applied in 1.44. (Though I forgot to add it to the Changes log. Oops.) -- Paul Evans


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.