Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 111556
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: GAAS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: t/startssl-failed.t hangs with openssl-1.0.2f
The t/startssl-failed.t test just hangs when using a Net-SSLeay that links with openssl-1.0.2f.  With the 1.0.2e release this wasn't an issue.  I see this on multiple platforms; linux, osx, windows.

When I run the test directly I see this output and I get accumulate a hanging background process:

gisle@myrull:~/IO-Socket-SSL-2.022$ perl -Mblib t/startssl-failed.t
1..9
ok #Server Initialization
ok #client tcp connect
ok #tcp accept
ok #send non-ssl data
Alarm clock: 14
gisle@myrull:~/IO-Socket-SSL-2.022$ ps -u gisle | grep startssl
  501 30350 ttys007    0:13.56 perl -Mblib t/startssl-failed.t
  501 30359 ttys007    0:00.00 grep startssl
Download (untitled) / with headers
text/plain 409b
Am Fr 29. Jan 2016, 18:32:21, GAAS schrieb: Show quoted text
> The t/startssl-failed.t test just hangs when using a Net-SSLeay that > links with
Thanks for reporting the issue. It looks like that 1.0.2f changed the behavior of SSL_shutdown for the case that the SSL connection is not yet fully open. This resulted in an endless loop when trying to close down the connection properly. Fixed in the just released version 2.023.
Download (untitled) / with headers
text/plain 838b
On 2016-01-29 18:32:21, GAAS wrote: Show quoted text
> The t/startssl-failed.t test just hangs when using a Net-SSLeay that > links with > openssl-1.0.2f. With the 1.0.2e release this wasn't an issue. I see > this on > multiple platforms; linux, osx, windows. > > When I run the test directly I see this output and I get accumulate a > hanging > background process: > > gisle@myrull:~/IO-Socket-SSL-2.022$ perl -Mblib t/startssl-failed.t > 1..9 ok > #Server Initialization ok #client tcp connect ok #tcp accept ok #send > non-ssl > data Alarm clock: 14 gisle@myrull:~/IO-Socket-SSL-2.022$ ps -u gisle | > grep > startssl 501 30350 ttys007 0:13.56 perl -Mblib t/startssl-failed.t 501 > 30359 > ttys007 0:00.00 grep startssl
I cannot reproduce the problem on a Debian/sid system (openssl 1.0.2f-2, with self-compiled perl 5.20.3 and system perl 5.22.1).


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.