Skip Menu |
 

This queue is for tickets about the Bot-Cobalt-Plugin-Weather CPAN distribution.

Report information
The Basics
Id: 110754
Status: resolved
Priority: 0/
Queue: Bot-Cobalt-Plugin-Weather

People
Owner: AVENJ [...] cpan.org
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Undeclared dependency Object::RateLimiter (0.003001)
Download (untitled) / with headers
text/plain 1.4k
The basic.t test fails if Object::RateLimiter is not installed: # Failed test 'use Bot::Cobalt::Plugin::Weather;' # at t/basic.t line 5. # Tried to use 'Bot::Cobalt::Plugin::Weather'. # Error: Can't locate Object/RateLimiter.pm in @INC (you may need to install the Object::RateLimiter module) (@INC contains: /home/cpansand/.cpan/build/2015122918/Bot-Cobalt-Plugin-Weather-0.003001-C2BNyv/blib/lib /home/cpansand/.cpan/build/2015122918/Bot-Cobalt-Plugin-Weather-0.003001-C2BNyv/blib/arch /opt/perl-5.20.2/lib/site_perl/5.20.2/x86_64-linux /opt/perl-5.20.2/lib/site_perl/5.20.2 /opt/perl-5.20.2/lib/5.20.2/x86_64-linux /opt/perl-5.20.2/lib/5.20.2 .) at /home/cpansand/.cpan/build/2015122918/Bot-Cobalt-Plugin-Weather-0.003001-C2BNyv/blib/lib/Bot/Cobalt/Plugin/Weather.pm line 11. # BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2015122918/Bot-Cobalt-Plugin-Weather-0.003001-C2BNyv/blib/lib/Bot/Cobalt/Plugin/Weather.pm line 11. # Compilation failed in require at t/basic.t line 5. # BEGIN failed--compilation aborted at t/basic.t line 5. # Failed test 'Bot::Cobalt::Plugin::Weather->new() died' # at t/basic.t line 8. # Error was: Can't locate object method "new" via package "Bot::Cobalt::Plugin::Weather" at /opt/perl-5.20.2/lib/site_perl/5.20.2/Test/More.pm line 690. # Looks like you failed 2 tests of 2. t/basic.t .................. Dubious, test returned 2 (wstat 512, 0x200) Failed 2/2 subtests
Download (untitled) / with headers
text/plain 135b
On Tue Dec 29 14:33:54 2015, SREZIC wrote: Show quoted text
> The basic.t test fails if Object::RateLimiter is not installed: >
Fixed in 0.3.2, thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.