Skip Menu |
 

This queue is for tickets about the Alien-wxWidgets CPAN distribution.

Report information
The Basics
Id: 110550
Status: new
Priority: 0/
Queue: Alien-wxWidgets

People
Owner: Nobody in particular
Requestors: joern.henneberg [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Installing Alien::wxWidgets-0.67 fails on Mac OS X 10.10.5
Date: Tue, 22 Dec 2015 17:18:34 -0800
To: bug-Alien-wxWidgets [...] rt.cpan.org
From: Joern Henneberg <joern.henneberg [...] gmail.com>
Download (untitled) / with headers
text/plain 2.5k
Hi, I tried installing Alien::wxWidges-0.67 both through CPAN as well as manually by downloading the tar from http://search.cpan.org/~mdootson/Alien-wxWidgets-0.67/lib/Alien/wxWidgets.pm . --------------------------- Manually installing, I do: Mac-mini:Alien-wxWidgets-0.67 joern$ sudo perl Build.PL Do you want to fetch and build wxWidgets from sources? [yes ] yes Which wxWidgets version? (2.8.10, 2.8.11, 2.8.12, 2.9.0, 2.9.1, 2.9.2, 2.9.3, 2.9.4, 3.0.0, 3.0.1, 3.0.2) [3.0.2 ]3.0.2 Which archive type? [tar.bz2 ] tar.bz2 Do you want to include OpenGL support [yes ] yes Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Alien-wxWidgets' version '0.67' --------------------------- I then do: Mac-mini:Alien-wxWidgets-0.67 joern$ sudo perl Build The configuration of wxWidgets then fails with: checking if C compiler (clang -mmacosx-version-min=10.5) works with SDK/version options... configure: error: in `/Users/joern/Documents/eng-db/Alien-wxWidgets-0.67/wxWidgets-3.0.2/bld': configure: error: no. Try a different SDK See `config.log' for more details system: echo exit | sh ../configure --prefix=/Library/Perl/5.18/darwin-thread-multi-2level/Alien/wxWidgets/osx_cocoa_3_0_2_uni --with-osx_cocoa --with-opengl --disable-compat24 --enable-unicode --disable-monolithic --disable-universal_binary --enable-graphics_ctx CC=clang CXX=clang++ CXXFLAGS="-stdlib=libc++ -std=c++11" OBJCXXFLAGS="-stdlib=libc++ -std=c++11" LDFLAGS=-stdlib=libc++: 256 at Build line 60. --------------------------- There seems to be a work-around discussed here: http://stackoverflow.com/questions/32689670/alienwxwidgets-install-fails-on-osx10-10 However, I have no idea how to apply that to the install process of Alien::wxWidgets... --------------------------- Some information about my system: Mac-mini:~ joern$ perl -v This is perl 5, version 18, subversion 2 (v5.18.2) built for darwin-thread-multi-2level (with 2 registered patches, see perl -V for more detail) Copyright 1987-2013, Larry Wall Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit. Complete documentation for Perl, including FAQ lists, should be found on this system using "man perl" or "perldoc perl". If you have access to the Internet, point your browser at http://www.perl.org/, the Perl Home Page. Mac-mini:~ joern$ uname -a Darwin Mac-mini.local 14.5.0 Darwin Kernel Version 14.5.0: Tue Sep 1 21:23:09 PDT 2015; root:xnu-2782.50.1~1/RELEASE_X86_64 x86_64 OS X Yosemite, 10.10.5 Thanks, Best Regards, Joern
Download config.log
application/octet-stream 63.2k

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.