Skip Menu |
 

This queue is for tickets about the Net-Frame CPAN distribution.

Report information
The Basics
Id: 110498
Status: rejected
Priority: 0/
Queue: Net-Frame

People
Owner: Nobody in particular
Requestors: relia104 [...] t-online.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: unable to get dnet
Date: Tue, 22 Dec 2015 00:11:15 +0100
To: <bug-Net-Frame [...] rt.cpan.org>
From: "relia104" <relia104 [...] t-online.de>
Download (untitled) / with headers
text/plain 1004b
Hello, I successfully used Net::Packet under Windows XP (32-bit) earlier. Because Net::Packet is not supported any more, I have to migrate to Net::Frame under Windows 7 (64-bit). After installation of the Bundle::Net::Frame 1.02 via PPM, I always get following critical error messages from Net::Frame::Device : Net::Frame::Device: updateFromDefault: unable to get dnet - or - Net::Frame::Device: updateFromDev: unable to get dnet - or - Net::Frame::Device: updateFromTarget: unable to get dnet It could be an issue with Net::Libdnet module which function is called from _getDevWin32() in Net::Frame::Device (the error messages are shown above). Possibly, intf_get() does not work as expected for ethernet interfaces under Windows 7. If these are "linux-only" modules, OS dependency and restriction notes should be given in Net::Frame distribution for MSWin32 users. If Net::Frame framework should run also under MSWin32, this problem (bug) should be solved. Best regards, J. Bytschkow
Subject: AW: [rt.cpan.org #110498] AutoReply: unable to get dnet
Date: Fri, 8 Jan 2016 22:24:39 +0100
To: <bug-Net-Frame [...] rt.cpan.org>
From: "relia104" <relia104 [...] t-online.de>
Download (untitled) / with headers
text/plain 2.3k
Hello, I wish you a good start into the new year! The ID of my ticket is [rt.cpan.org #110498]: https://rt.cpan.org/Ticket/Display.html?id=110498 Can you please inform me via e-mail about estimated date when the fix for the perl module Net::Libdnet could be provided for Windows 7 platform? Can you please also inform me when the fix is already available for download? Thank you! Best regards, Jewgenij Bytschkow Show quoted text
-----Urspr√ľngliche Nachricht----- Von: Bugs in Net-Frame via RT [mailto:bug-Net-Frame@rt.cpan.org] Gesendet: Dienstag, 22. Dezember 2015 00:12 An: relia104@t-online.de Betreff: [rt.cpan.org #110498] AutoReply: unable to get dnet Greetings, This message has been automatically generated in response to the creation of a trouble ticket regarding: "unable to get dnet", a summary of which appears below. There is no need to reply to this message right now. Your ticket has been assigned an ID of [rt.cpan.org #110498]. Your ticket is accessible on the web at: https://rt.cpan.org/Ticket/Display.html?id=110498 Please include the string: [rt.cpan.org #110498] in the subject line of all future correspondence about this issue. To do so, you may reply to this message. Thank you, bug-Net-Frame@rt.cpan.org ------------------------------------------------------------------------- Hello, I successfully used Net::Packet under Windows XP (32-bit) earlier. Because Net::Packet is not supported any more, I have to migrate to Net::Frame under Windows 7 (64-bit). After installation of the Bundle::Net::Frame 1.02 via PPM, I always get following critical error messages from Net::Frame::Device : Net::Frame::Device: updateFromDefault: unable to get dnet - or - Net::Frame::Device: updateFromDev: unable to get dnet - or - Net::Frame::Device: updateFromTarget: unable to get dnet It could be an issue with Net::Libdnet module which function is called from _getDevWin32() in Net::Frame::Device (the error messages are shown above). Possibly, intf_get() does not work as expected for ethernet interfaces under Windows 7. If these are "linux-only" modules, OS dependency and restriction notes should be given in Net::Frame distribution for MSWin32 users. If Net::Frame framework should run also under MSWin32, this problem (bug) should be solved. Best regards, J. Bytschkow
Download (untitled) / with headers
text/plain 182b
Hi, This module is not supported under Win32 (nor Win64). Since Windows 10, you should be using the Linux subsystem under Windows if you wish to use network Perl modules. Regards,


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.