Skip Menu |
 

This queue is for tickets about the Gtk2 CPAN distribution.

Report information
The Basics
Id: 109991
Status: open
Priority: 0/
Queue: Gtk2

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.2497
Fixed in: (no value)



Subject: Invalid version format (non-numeric data) (perl 5.20.0, German locale)
Download (untitled) / with headers
text/plain 600b
00.Gtk2.t fails, probably only with a German locale (not-dot decimal point) and perl 5.20.0. Probably a variation of https://rt.perl.org/Ticket/Display.html?id=122105 Invalid version format (non-numeric data) at /opt/perl-5.20.0t/lib/site_perl/5.20.0/x86_64-linux-thread-multi/Scalar/Util.pm line 23. Compilation failed in require at /opt/perl-5.20.0t/lib/site_perl/5.20.0/Test/More.pm line 592. # Looks like you planned 30 tests but ran 15. # Looks like your test exited with 2 just after 15. t/00.Gtk2.t ........................ Dubious, test returned 2 (wstat 512, 0x200) Failed 15/30 subtests
Subject: Re: [rt.cpan.org #109991] Invalid version format (non-numeric data) (perl 5.20.0, German locale)
Date: Sun, 6 Dec 2015 13:40:28 +0100
To: bug-Gtk2 [...] rt.cpan.org
From: Torsten Schoenfeld <kaffeetisch [...] gmx.de>
Download (untitled) / with headers
text/plain 1.1k
On 01.12.2015 07:10, Slaven_Rezic via RT wrote: Show quoted text
> 00.Gtk2.t fails, probably only with a German locale (not-dot decimal point) and perl 5.20.0. Probably a variation of https://rt.perl.org/Ticket/Display.html?id=122105 > > Invalid version format (non-numeric data) at /opt/perl-5.20.0t/lib/site_perl/5.20.0/x86_64-linux-thread-multi/Scalar/Util.pm line 23. > Compilation failed in require at /opt/perl-5.20.0t/lib/site_perl/5.20.0/Test/More.pm line 592. > # Looks like you planned 30 tests but ran 15. > # Looks like your test exited with 2 just after 15. > t/00.Gtk2.t ........................ > Dubious, test returned 2 (wstat 512, 0x200) > Failed 15/30 subtests
I thought we fixed this with <https://git.gnome.org/browse/perl-Gtk2/commit/?id=02a70526>. I can't reproduce the failure with the following locale: # locale LANG=en_US.UTF-8 LANGUAGE=en_US:en LC_CTYPE="en_US.UTF-8" LC_NUMERIC=de_DE.utf8 LC_TIME=de_DE.utf8 LC_COLLATE="en_US.UTF-8" LC_MONETARY=de_DE.utf8 LC_MESSAGES="en_US.UTF-8" LC_PAPER=de_DE.utf8 LC_NAME=de_DE.UTF-8 LC_ADDRESS=de_DE.UTF-8 LC_TELEPHONE=de_DE.UTF-8 LC_MEASUREMENT=de_DE.utf8 LC_IDENTIFICATION=de_DE.UTF-8 LC_ALL= What's your locale exactly?
Download (untitled) / with headers
text/plain 2.6k
On 2015-12-06 07:40:48, TSCH wrote: Show quoted text
> On 01.12.2015 07:10, Slaven_Rezic via RT wrote:
> > 00.Gtk2.t fails, probably only with a German locale (not-dot decimal > > point) and perl 5.20.0. Probably a variation of > > https://rt.perl.org/Ticket/Display.html?id=122105 > > > > Invalid version format (non-numeric data) at /opt/perl- > > 5.20.0t/lib/site_perl/5.20.0/x86_64-linux-thread-multi/Scalar/Util.pm > > line 23. > > Compilation failed in require at /opt/perl- > > 5.20.0t/lib/site_perl/5.20.0/Test/More.pm line 592. > > # Looks like you planned 30 tests but ran 15. > > # Looks like your test exited with 2 just after 15. > > t/00.Gtk2.t ........................ > > Dubious, test returned 2 (wstat 512, 0x200) > > Failed 15/30 subtests
> > I thought we fixed this with > <https://git.gnome.org/browse/perl-Gtk2/commit/?id=02a70526>. I can't > reproduce the failure with the following locale: > > # locale > LANG=en_US.UTF-8 > LANGUAGE=en_US:en > LC_CTYPE="en_US.UTF-8" > LC_NUMERIC=de_DE.utf8 > LC_TIME=de_DE.utf8 > LC_COLLATE="en_US.UTF-8" > LC_MONETARY=de_DE.utf8 > LC_MESSAGES="en_US.UTF-8" > LC_PAPER=de_DE.utf8 > LC_NAME=de_DE.UTF-8 > LC_ADDRESS=de_DE.UTF-8 > LC_TELEPHONE=de_DE.UTF-8 > LC_MEASUREMENT=de_DE.utf8 > LC_IDENTIFICATION=de_DE.UTF-8 > LC_ALL= > > What's your locale exactly?
Well, yours is a mixture of English and German settings, but with exactly the same values I get an error (Debian/wheezy): $ env DISPLAY=:34 LANG=en_US.UTF-8 LANGUAGE=en_US:en LC_CTYPE="en_US.UTF-8" LC_NUMERIC=de_DE.utf8 LC_TIME=de_DE.utf8 LC_COLLATE="en_US.UTF-8" LC_MONETARY=de_DE.utf8 LC_MESSAGES="en_US.UTF-8" LC_PAPER=de_DE.utf8 LC_NAME=de_DE.UTF-8 LC_ADDRESS=de_DE.UTF-8 LC_TELEPHONE=de_DE.UTF-8 LC_MEASUREMENT=de_DE.utf8 LC_IDENTIFICATION=de_DE.UTF-8 LC_ALL= perl5.20.0 -Mblib t/00.Gtk2.t 1..30 ok 1 - use Gtk2; # Testing Gtk2 1.2497 # Running against gtk+ 2.24.10 # Compiled against gtk+ 2.24.10 ok 2 - version info is three items long ok 3 - check_version pass ok 4 - check_version fail ok 5 - major_version ok 6 - minor_version ok 7 - micro_version ok 8 - version info is three items long ok 9 - CHECK_VERSION pass ok 10 - CHECK_VERSION fail ok 11 - MAJOR_VERSION ok 12 - MINOR_VERSION ok 13 - MICRO_VERSION Xlib: extension "RANDR" missing on display ":34". ok 14 ok 15 Invalid version format (non-numeric data) at /opt/perl-5.20.0/lib/site_perl/5.20.0/x86_64-linux/Scalar/Util.pm line 23. Compilation failed in require at /opt/perl-5.20.0/lib/site_perl/5.20.0/Test/More.pm line 592. # Looks like you planned 30 tests but ran 15. # Looks like your test exited with 2 just after 15. Note that it passes if there's no DISPLAY and tests 14..30 were skipped because of this.
Download (untitled) / with headers
text/plain 3.2k
On 2015-12-06 11:41:19, SREZIC wrote: Show quoted text
> On 2015-12-06 07:40:48, TSCH wrote:
> > On 01.12.2015 07:10, Slaven_Rezic via RT wrote:
> > > 00.Gtk2.t fails, probably only with a German locale (not-dot > > > decimal > > > point) and perl 5.20.0. Probably a variation of > > > https://rt.perl.org/Ticket/Display.html?id=122105 > > > > > > Invalid version format (non-numeric data) at /opt/perl- > > > 5.20.0t/lib/site_perl/5.20.0/x86_64-linux-thread- > > > multi/Scalar/Util.pm > > > line 23. > > > Compilation failed in require at /opt/perl- > > > 5.20.0t/lib/site_perl/5.20.0/Test/More.pm line 592. > > > # Looks like you planned 30 tests but ran 15. > > > # Looks like your test exited with 2 just after 15. > > > t/00.Gtk2.t ........................ > > > Dubious, test returned 2 (wstat 512, 0x200) > > > Failed 15/30 subtests
> > > > I thought we fixed this with > > <https://git.gnome.org/browse/perl-Gtk2/commit/?id=02a70526>. I > > can't > > reproduce the failure with the following locale: > > > > # locale > > LANG=en_US.UTF-8 > > LANGUAGE=en_US:en > > LC_CTYPE="en_US.UTF-8" > > LC_NUMERIC=de_DE.utf8 > > LC_TIME=de_DE.utf8 > > LC_COLLATE="en_US.UTF-8" > > LC_MONETARY=de_DE.utf8 > > LC_MESSAGES="en_US.UTF-8" > > LC_PAPER=de_DE.utf8 > > LC_NAME=de_DE.UTF-8 > > LC_ADDRESS=de_DE.UTF-8 > > LC_TELEPHONE=de_DE.UTF-8 > > LC_MEASUREMENT=de_DE.utf8 > > LC_IDENTIFICATION=de_DE.UTF-8 > > LC_ALL= > > > > What's your locale exactly?
> > Well, yours is a mixture of English and German settings, but with > exactly the same values I get an error (Debian/wheezy): > > $ env DISPLAY=:34 LANG=en_US.UTF-8 LANGUAGE=en_US:en > LC_CTYPE="en_US.UTF-8" LC_NUMERIC=de_DE.utf8 LC_TIME=de_DE.utf8 > LC_COLLATE="en_US.UTF-8" LC_MONETARY=de_DE.utf8 > LC_MESSAGES="en_US.UTF-8" LC_PAPER=de_DE.utf8 LC_NAME=de_DE.UTF-8 > LC_ADDRESS=de_DE.UTF-8 LC_TELEPHONE=de_DE.UTF-8 > LC_MEASUREMENT=de_DE.utf8 LC_IDENTIFICATION=de_DE.UTF-8 LC_ALL= > perl5.20.0 -Mblib t/00.Gtk2.t > 1..30 > ok 1 - use Gtk2; > # Testing Gtk2 1.2497 > # Running against gtk+ 2.24.10 > # Compiled against gtk+ 2.24.10 > ok 2 - version info is three items long > ok 3 - check_version pass > ok 4 - check_version fail > ok 5 - major_version > ok 6 - minor_version > ok 7 - micro_version > ok 8 - version info is three items long > ok 9 - CHECK_VERSION pass > ok 10 - CHECK_VERSION fail > ok 11 - MAJOR_VERSION > ok 12 - MINOR_VERSION > ok 13 - MICRO_VERSION > Xlib: extension "RANDR" missing on display ":34". > ok 14 > ok 15 > Invalid version format (non-numeric data) at /opt/perl- > 5.20.0/lib/site_perl/5.20.0/x86_64-linux/Scalar/Util.pm line 23. > Compilation failed in require at /opt/perl- > 5.20.0/lib/site_perl/5.20.0/Test/More.pm line 592. > # Looks like you planned 30 tests but ran 15. > # Looks like your test exited with 2 just after 15. > > > Note that it passes if there's no DISPLAY and tests 14..30 were > skipped because of this.
On a freebsd system running 5.20.0 I could not reproduce the problem. But is the following really supposed to happen (linux+freebsd, various perl versions)? $ env LC_ALL=de_DE.UTF-8 perl5.23.5 -MTest::More=no_plan -e 'use Gtk2; Gtk2->disable_setlocale; Gtk2->set_locale; is 1.2, "1.2"' not ok 1 # Failed test at -e line 1. # got: '1,2' # expected: '1.2' 1..1 # Looks like you failed 1 test of 1.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.