Skip Menu |
 

This queue is for tickets about the Waft CPAN distribution.

Report information
The Basics
Id: 109033
Status: new
Priority: 0/
Queue: Waft

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.9910
Fixed in: (no value)



Subject: CGI.pm not declared as a dependency
CGI.pm is not anymore part of core perl in newer versions (e.g. perl 5.22.0) and thus needs to be declared as a prerequisite. Otherwise the test suite fails if it is missing: Can't locate CGI.pm in @INC (you may need to install the CGI module) (@INC contains: /tmpfs/.cpan-build/2015111618/Waft-0.9910-1uuE07/blib/lib /tmpfs/.cpan-build/2015111618/Waft-0.9910-1uuE07/blib/arch /opt/perl-5.22.0t/lib/site_perl/5.22.0/x86_64-linux-thread-multi /opt/perl-5.22.0t/lib/site_perl/5.22.0 /opt/perl-5.22.0t/lib/5.22.0/x86_64-linux-thread-multi /opt/perl-5.22.0t/lib/5.22.0 .) at /tmpfs/.cpan-build/2015111618/Waft-0.9910-1uuE07/blib/lib/Waft.pm line 8. BEGIN failed--compilation aborted at /tmpfs/.cpan-build/2015111618/Waft-0.9910-1uuE07/blib/lib/Waft.pm line 8. Compilation failed in require at /opt/perl-5.22.0t/lib/5.22.0/base.pm line 99. ...propagated at /opt/perl-5.22.0t/lib/5.22.0/base.pm line 108. BEGIN failed--compilation aborted at t/compile_template.t line 8. t/compile_template.t .......... Dubious, test returned 2 (wstat 512, 0x200) Failed 1/1 subtests (etc.)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.