Skip Menu |
 

This queue is for tickets about the Quantum-Superpositions CPAN distribution.

Report information
The Basics
Id: 108
Status: resolved
Priority: 0/
Queue: Quantum-Superpositions

People
Owner: Nobody in particular
Requestors: mark [...] twoshortplanks.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.03
Fixed in: (no value)



Subject: Makefile.PL doesn't have a prereq for Class::Multimethods
Download (untitled) / with headers
text/plain 1.2k
Hi. I get this when trying to install Quantum::Superpositions: Running make test PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0 test.pl Can't locate Class/Multimethods.pm in @INC (@INC contains: blib/arch blib/lib /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at blib/lib/Quantum/Superpositions.pm line 92. BEGIN failed--compilation aborted at blib/lib/Quantum/Superpositions.pm line 92. Compilation failed in require at test.pl line 6. BEGIN failed--compilation aborted at test.pl line 6. I suspect it's because I haven't got Class::Multimethods installed and it's not specified as a prerequist in the Makefile.PL so CPAN.pm can't install it. Ah yes, it passes fine once I install Class::Multimethods. Too Much Information (what rt.cpan.org tells me to tell you): Distribution name: Redhat 7.2. Perl: This is perl, v5.6.0 built for i386-linux OS vendor: Linux ns0 2.4.7-10 #1 Thu Sep 6 17:21:28 EDT 2001 i586 unknown Not that I'd be about to include this in any perl advent calendar, no not at all. Mark.
Fixed long ago; not sure which release.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.