Skip Menu |
 

This queue is for tickets about the XML-Compile-SOAP CPAN distribution.

Report information
The Basics
Id: 107586
Status: resolved
Priority: 0/
Queue: XML-Compile-SOAP

People
Owner: Nobody in particular
Requestors: hausauer [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Tue, 6 Oct 2015 13:52:29 -0700
To: bug-XML-Compile-SOAP [...] rt.cpan.org, xml-compile [...] lists.scsys.co.uk
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 4.9k
I’m using XML-Compile-SOAP-3.12 to send a payload with attachments to a SOAP server running on Apache CXF 3.0.4.redhat-620133. It looks like CXF doesn’t like the escaped quotes that appear in the type="…; charset=\"utf-8\"" header. According to the comments at lines 113-114 of http://grepcode.com/file/repo1.maven.org/maven2/org.apache.cxf/cxf-core/3.0.4/org/apache/cxf/helpers/HttpHeaderHelper.java, CXF does not expect content types to have escaped quotes. I recommend that XML::Compile::XOP stop quoting the charsets by updating SOAPHTTP.pm:94 - $content_type = qq{$mime; charset="$charset”}; + $content_type = qq{$mime; charset=$charset}; And line :98 - $content_type = qq{$mime; charset="$charset"$sa}; + $content_type = qq{$mime; charset=$charset$sa}; Here is an example of the SOAP message generated by ->call(): POST http://192.168.56.22:8182/cxf/xcad-ws/XCadService HTTP/1.1 User-Agent: libwww-perl/6.13 Content-Type: multipart/related; boundary=MIME-boundary-8745; type="application/xop+xml"; start="<xml@localhost>"; start-info="text/xml; charset=\"utf-8\"" SOAPAction: "" X-LWP-Version: 6.13 X-XML-Compile-Cache-Version: 1.04 X-XML-Compile-SOAP-Version: 3.12 X-XML-Compile-Version: 1.50 X-XML-LibXML-Version: 2.0110 --MIME-boundary-8745 Content-Type: application/xop+xml; charset="utf-8"; type="text/xml; charset=\"utf-8\"" Content-ID: <xml@localhost> Content-Transfer-Encoding: 8bit <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body> ... snipped … Apache CXF throws the following exception; note that CXF does not properly un-escape double quotes in the charset: Server Error Caused by: java.io.IOException: Invalid character set \"utf-8\" in request. at org.apache.cxf.transport.http.AbstractHTTPDestination.setEncoding(AbstractHTTPDestination.java:436) at org.apache.cxf.transport.http.AbstractHTTPDestination.setupMessage(AbstractHTTPDestination.java:358) at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke(AbstractHTTPDestination.java:236) at org.apache.cxf.transport.servlet.ServletController.invokeDestination(ServletController.java:234) at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:208) at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:160) at org.apache.cxf.transport.servlet.CXFNonSpringServlet.invoke(CXFNonSpringServlet.java:171) at org.apache.cxf.transport.servlet.AbstractHTTPServlet.handleRequest(AbstractHTTPServlet.java:293) at org.apache.cxf.transport.servlet.AbstractHTTPServlet.doPost(AbstractHTTPServlet.java:212) at javax.servlet.http.HttpServlet.service(HttpServlet.java:595) at org.apache.cxf.transport.servlet.AbstractHTTPServlet.service(AbstractHTTPServlet.java:268) at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684) at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:503) at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(HttpServiceServletHandler.java:69) at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137) at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557) at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231) at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086) at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(HttpServiceContext.java:240) at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429) at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193) at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020) at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135) at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:75) at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116) at org.eclipse.jetty.server.Server.handle(Server.java:370) at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494) at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:982) at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1043) at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:865) at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240) at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82) at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696) at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53) at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608) at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543) at java.lang.Thread.run(Thread.java:745) — Derek
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Wed, 7 Oct 2015 09:55:46 +0200
To: Derek Hausauer via RT <bug-XML-Compile-SOAP [...] rt.cpan.org>
From: Mark Overmeer <mark [...] overmeer.net>
Download (untitled) / with headers
text/plain 1.8k
* Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151006 20:52]: Show quoted text
> Tue Oct 06 16:52:42 2015: Request 107586 was acted upon. > Queue: XML-Compile-SOAP > Subject: Issue with XOP escaped quotes with Apache CXF (JAX-WS) > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > I’m using XML-Compile-SOAP-3.12 to send a payload with attachments > to a SOAP server running on Apache CXF 3.0.4.redhat-620133. It looks > like CXF doesn’t like the escaped quotes that appear in the type="…; > charset=\"utf-8\"" header.
The bug is slightly different, but certainly there. With XOP multiparts, the "start-info" field contains the full Content-Type of the reconstructed XML. I resently added the charset there. Show quoted text
> Content-Type: multipart/related; boundary=MIME-boundary-8745; type="application/xop+xml"; start="<xml@localhost>"; start-info="text/xml; charset=\"utf-8\"" > SOAPAction: ""
In the attachements, however, the "type" attribute should only contain the mime-type, not the attibutes. Show quoted text
> --MIME-boundary-8745 > Content-Type: application/xop+xml; charset="utf-8"; type="text/xml; charset=\"utf-8\""
I think the fix is this: start="<$start_cid>"; start-info="$si" __CT my $base = HTTP::Message->new - ( [ Content_Type => qq{$mime_xop; charset="$charset"; type="$si"} + ( [ Content_Type => qq{$mime_xop; charset="$charset"; type="$content_type"} , Content_Transfer_Encoding => '8bit' , Content_ID => "<$start_cid>" ] ); -- Regards, MarkOv ------------------------------------------------------------------------ drs Mark A.C.J. Overmeer MARKOV Solutions Mark@Overmeer.net solutions@overmeer.net http://Mark.Overmeer.net http://solutions.overmeer.net
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Wed, 28 Oct 2015 12:13:16 -0700
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 2.2k
Stepping through with the debugger, it looks like $content_type already includes the charset, $si is the same thing just with the double quotes escaped. To get the charset information out of $content_type, I think you would need to go with my original fix. Show quoted text
> On Oct 7, 2015, at 12:56 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151006 20:52]:
>> Tue Oct 06 16:52:42 2015: Request 107586 was acted upon. >> Queue: XML-Compile-SOAP >> Subject: Issue with XOP escaped quotes with Apache CXF (JAX-WS) >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > >> >> I’m using XML-Compile-SOAP-3.12 to send a payload with attachments >> to a SOAP server running on Apache CXF 3.0.4.redhat-620133. It looks >> like CXF doesn’t like the escaped quotes that appear in the type="…; >> charset=\"utf-8\"" header.
> > The bug is slightly different, but certainly there. > > With XOP multiparts, the "start-info" field contains the full Content-Type > of the reconstructed XML. I resently added the charset there. >
>> Content-Type: multipart/related; boundary=MIME-boundary-8745; type="application/xop+xml"; start="<xml@localhost>"; start-info="text/xml; charset=\"utf-8\"" >> SOAPAction: ""
> > In the attachements, however, the "type" attribute should only contain > the mime-type, not the attibutes. >
>> --MIME-boundary-8745 >> Content-Type: application/xop+xml; charset="utf-8"; type="text/xml; charset=\"utf-8\""
> > I think the fix is this: > > start="<$start_cid>"; > start-info="$si" > __CT > > my $base = HTTP::Message->new > - ( [ Content_Type => qq{$mime_xop; charset="$charset"; type="$si"} > + ( [ Content_Type => qq{$mime_xop; charset="$charset"; type="$content_type"} > , Content_Transfer_Encoding => '8bit' > , Content_ID => "<$start_cid>" > ] ); > > -- > Regards, > MarkOv > > ------------------------------------------------------------------------ > drs Mark A.C.J. Overmeer MARKOV Solutions > Mark@Overmeer.net solutions@overmeer.net > http://Mark.Overmeer.net http://solutions.overmeer.net > >
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Wed, 28 Oct 2015 12:30:06 -0700
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
A suggested fix to remove charset from the mime attachment header entirely would be: my $content_type; if($version eq 'SOAP11') { $mime ||= ref $soap ? $soap->mimeType : 'text/xml'; - $content_type = qq{$mime; charset="$charset"}; + $content_type = qq{$mime}; } elsif($version eq 'SOAP12') { $mime ||= ref $soap ? $soap->mimeType : 'application/soap+xml'; my $sa = defined $action ? qq{; action="$action"} : ''; - $content_type = qq{$mime; charset="$charset"$sa}; + $content_type = qq{$mime$sa}; $header->header(Accept => $mime); # not the HTML answer } else Show quoted text
> On Oct 28, 2015, at 12:13 PM, Derek Hausauer <hausauer@gmail.com> wrote: > > Stepping through with the debugger, it looks like $content_type already includes the charset, $si is the same thing just with the double quotes escaped. To get the charset information out of $content_type, I think you would need to go with my original fix. >
>> On Oct 7, 2015, at 12:56 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: >> >> <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > >> >> * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151006 20:52]:
>>> Tue Oct 06 16:52:42 2015: Request 107586 was acted upon. >>> Queue: XML-Compile-SOAP >>> Subject: Issue with XOP escaped quotes with Apache CXF (JAX-WS) >>> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > >>> >>> I’m using XML-Compile-SOAP-3.12 to send a payload with attachments >>> to a SOAP server running on Apache CXF 3.0.4.redhat-620133. It looks >>> like CXF doesn’t like the escaped quotes that appear in the type="…; >>> charset=\"utf-8\"" header.
>> >> The bug is slightly different, but certainly there. >> >> With XOP multiparts, the "start-info" field contains the full Content-Type >> of the reconstructed XML. I resently added the charset there. >>
>>> Content-Type: multipart/related; boundary=MIME-boundary-8745; type="application/xop+xml"; start="<xml@localhost>"; start-info="text/xml; charset=\"utf-8\"" >>> SOAPAction: ""
>> >> In the attachements, however, the "type" attribute should only contain >> the mime-type, not the attibutes. >>
>>> --MIME-boundary-8745 >>> Content-Type: application/xop+xml; charset="utf-8"; type="text/xml; charset=\"utf-8\""
>> >> I think the fix is this: >> >> start="<$start_cid>"; >> start-info="$si" >> __CT >> >> my $base = HTTP::Message->new >> - ( [ Content_Type => qq{$mime_xop; charset="$charset"; type="$si"} >> + ( [ Content_Type => qq{$mime_xop; charset="$charset"; type="$content_type"} >> , Content_Transfer_Encoding => '8bit' >> , Content_ID => "<$start_cid>" >> ] ); >> >> -- >> Regards, >> MarkOv >> >> ------------------------------------------------------------------------ >> drs Mark A.C.J. Overmeer MARKOV Solutions >> Mark@Overmeer.net solutions@overmeer.net >> http://Mark.Overmeer.net http://solutions.overmeer.net >> >>
>
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Wed, 28 Oct 2015 20:38:17 +0100
To: Derek Hausauer via RT <bug-XML-Compile-SOAP [...] rt.cpan.org>
From: Mark Overmeer <markov [...] overmeer.net>
Download (untitled) / with headers
text/plain 376b
* Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151028 19:30]: Show quoted text
> Queue: XML-Compile-SOAP > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > A suggested fix to remove charset from the mime attachment header entirely would be:
That's not the correct fix. I have a fix already waiting for release since your report. Shall I upload it?
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Mon, 2 Nov 2015 08:20:44 -0800
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 358b
I'm not in any hurry; I've overridden the prepare call on my end the just drop the escaped quotes. I have an extremely limited use case. That said, I do look forward to a permanent fix! Show quoted text
> On Oct 28, 2015, at 12:53 PM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > That's not the correct fix. I have a fix already waiting for release
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Fri, 6 Nov 2015 09:43:10 +0100
To: Derek Hausauer via RT <bug-XML-Compile-SOAP [...] rt.cpan.org>
From: Mark Overmeer <mark [...] nluug.nl>
Download (untitled) / with headers
text/plain 796b
* Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151102 16:21]: Show quoted text
> Queue: XML-Compile-SOAP > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > I'm not in any hurry; I've overridden the prepare call on my end the > just drop the escaped quotes. I have an extremely limited use case. That > said, I do look forward to a permanent fix!
I have just released version 3.13 to CPAN. Give it an hour to settle. Thanks for your report. -- Regards, MarkOv ------------------------------------------------------------------------ Mark Overmeer MSc MARKOV Solutions Mark@Overmeer.net solutions@overmeer.net http://Mark.Overmeer.net http://solutions.overmeer.net
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Fri, 4 Dec 2015 12:04:57 -0800
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 2.2k
I've upgraded to 3.013 but it appears that the issue is still present. Here is the request that is generated by XML::Compile::XOP POST http://[[redacted]] HTTP/1.1 User-Agent: libwww-perl/6.13 Content-Type: multipart/related; boundary=MIME-boundary-1877; type="application/xop+xml"; start="<xml@localhost>"; start-info="text/xml; charset=\"utf-8\"" SOAPAction: "" X-LWP-Version: 6.13 X-XML-Compile-Cache-Version: 1.04 X-XML-Compile-SOAP-Version: 3.13 X-XML-Compile-Version: 1.51 X-XML-LibXML-Version: 2.0122 --MIME-boundary-1877 Content-Type: application/xop+xml; charset="utf-8"; type="text/xml; charset="utf-8"" Content-ID: <xml@localhost> Content-Transfer-Encoding: 8bit <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body>[[redacted]]</SOAP-ENV:Body></SOAP-ENV:Envelope> --MIME-boundary-1877 Content-Type: application/octet-stream Content-ID: <1449258948@localhost> Content-Transfer-Encoding: binary [[redacted]] --MIME-boundary-1877-- As you can see, the Content-Type header still includes a double charset definition. Here are the module versions I am using: use XML::Compile 1.051; use XML::Compile::SOAP11 3.013; use XML::Compile::Transport::SOAPHTTP 3.013; use XML::Compile::WSDL11 3.04; use XML::Compile::XOP 3.013; Show quoted text
> On Nov 6, 2015, at 12:43 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151102 16:21]:
>> Queue: XML-Compile-SOAP >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > >> >> I'm not in any hurry; I've overridden the prepare call on my end the >> just drop the escaped quotes. I have an extremely limited use case. That >> said, I do look forward to a permanent fix!
> > I have just released version 3.13 to CPAN. Give it an hour to settle. > Thanks for your report. > -- > Regards, > MarkOv > > ------------------------------------------------------------------------ > Mark Overmeer MSc MARKOV Solutions > Mark@Overmeer.net solutions@overmeer.net > http://Mark.Overmeer.net http://solutions.overmeer.net > >
Content-Type fixed with XML::Compile::SOAP12 version 3.04, which I have just released to CPAN.
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Wed, 9 Dec 2015 14:58:01 -0800
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 344b
Our web service is running SOAP 1.1. Are you planning a fix for XML::Compile::SOAP11? Show quoted text
> On Dec 9, 2015, at 3:15 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > Content-Type fixed with XML::Compile::SOAP12 version 3.04, which I have just released to CPAN.
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Thu, 10 Dec 2015 09:08:32 +0100
To: Derek Hausauer via RT <bug-XML-Compile-SOAP [...] rt.cpan.org>
From: Mark Overmeer <solutions [...] overmeer.net>
Download (untitled) / with headers
text/plain 771b
* Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151209 22:58]: Show quoted text
> Queue: XML-Compile-SOAP > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > Our web service is running SOAP 1.1. Are you planning a fix for > XML::Compile::SOAP11?
The problem what you describe here should have been fixed with release 3.13 (nov 6) The change is different than you suggested, but with the same effect. Didn't it work? -- Regards, MarkOv ------------------------------------------------------------------------ Mark Overmeer MSc MARKOV Solutions Mark@Overmeer.net solutions@overmeer.net http://Mark.Overmeer.net http://solutions.overmeer.net
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Fri, 11 Dec 2015 11:42:22 -0800
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 4.1k
I'm still seeing the issue - when I use XML::Compile::XOP to send a SOAP message to my server, Apache CXF emits the following error: 2015-10-07 06:09:40,099 | WARN | p1886374391-2922 | AbstractHTTPDestination | ? ? | 115 - org.apache.cxf.cxf-rt-transports-http - 3.0.4.redhat-620133 | Invalid character set \"utf-8\" in request. Here is the SOAP message that causes the above failure (obtained from XOP's trace): POST http://[[redacted]] HTTP/1.1 User-Agent: libwww-perl/6.13 Content-Type: multipart/related; boundary=MIME-boundary-9856; type="application/xop+xml"; start="<xml@localhost>"; start-info="text/xml; charset=\"utf-8\"" SOAPAction: "" X-LWP-Version: 6.13 X-XML-Compile-Cache-Version: 1.04 X-XML-Compile-SOAP-Version: 3.13 X-XML-Compile-Version: 1.51 X-XML-LibXML-Version: 2.0122 --MIME-boundary-9856 Content-Type: application/xop+xml; charset="utf-8"; type="text/xml; charset="utf-8"" Content-ID: <xml@localhost> Content-Transfer-Encoding: 8bit <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body>[[redacted]]</SOAP-ENV:Body></SOAP-ENV:Envelope> --MIME-boundary-9856 Content-Type: application/octet-stream Content-ID: <1449861750@localhost> Content-Transfer-Encoding: binary [[redacted]] --MIME-boundary-9856-- Here are the module versions I am using: $ cpan -D XML::Compile XML::Compile::XOP XML::Compile::SOAP11 XML::Compile::Transport::SOAPHTTP XML::Compile::WSDL11 Reading '[[redacted]]/.cpan/Metadata' Database was generated on Fri, 11 Dec 2015 08:17:02 GMT XML::Compile ------------------------------------------------------------------------- (no description) M/MA/MARKOV/XML-Compile-1.51.tar.gz [[redacted]]/perl5/perlbrew/perls/perl-5.16.0/lib/site_perl/5.16.0/XML/Compile.pm Installed: 1.51 CPAN: 1.51 up to date Mark Overmeer (MARKOV) mark@overmeer.net XML::Compile::XOP ------------------------------------------------------------------------- (no description) M/MA/MARKOV/XML-Compile-SOAP-3.13.tar.gz [[redacted]]/perl5/perlbrew/perls/perl-5.16.0/lib/site_perl/5.16.0/XML/Compile/XOP.pm Installed: 3.13 CPAN: 3.13 up to date Mark Overmeer (MARKOV) mark@overmeer.net XML::Compile::SOAP11 ------------------------------------------------------------------------- (no description) M/MA/MARKOV/XML-Compile-SOAP-3.13.tar.gz [[redacted]]/perl5/perlbrew/perls/perl-5.16.0/lib/site_perl/5.16.0/XML/Compile/SOAP11.pm Installed: 3.13 CPAN: 3.13 up to date Mark Overmeer (MARKOV) mark@overmeer.net XML::Compile::Transport::SOAPHTTP ------------------------------------------------------------------------- (no description) M/MA/MARKOV/XML-Compile-SOAP-3.13.tar.gz [[redacted]]/perl5/perlbrew/perls/perl-5.16.0/lib/site_perl/5.16.0/XML/Compile/Transport/SOAPHTTP.pm Installed: 3.13 CPAN: 3.13 up to date Mark Overmeer (MARKOV) mark@overmeer.net XML::Compile::WSDL11 ------------------------------------------------------------------------- (no description) M/MA/MARKOV/XML-Compile-WSDL11-3.04.tar.gz [[redacted]]/perls/perl-5.16.0/lib/site_perl/5.16.0/XML/Compile/WSDL11.pm Installed: 3.04 CPAN: 3.04 up to date Mark Overmeer (MARKOV) mark@overmeer.net Show quoted text
> On Dec 10, 2015, at 12:09 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151209 22:58]:
>> Queue: XML-Compile-SOAP >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > >> >> Our web service is running SOAP 1.1. Are you planning a fix for >> XML::Compile::SOAP11?
> > The problem what you describe here should have been fixed with > release 3.13 (nov 6) The change is different than you suggested, > but with the same effect. Didn't it work? > -- > Regards, > MarkOv > > ------------------------------------------------------------------------ > Mark Overmeer MSc MARKOV Solutions > Mark@Overmeer.net solutions@overmeer.net > http://Mark.Overmeer.net http://solutions.overmeer.net > >
Download (untitled) / with headers
text/html 12.1k

Message body is not shown because it is too large.

Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Tue, 5 Jan 2016 10:06:57 +0100
To: Derek Hausauer via RT <bug-XML-Compile-SOAP [...] rt.cpan.org>
From: Mark Overmeer <solutions [...] overmeer.net>
Download (untitled) / with headers
text/plain 699b
Sorry for the late reply, Derek, December is a horrible month for work. * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151211 19:42]: Show quoted text
> I'm still seeing the issue - when I use XML::Compile::XOP to send a SOAP message to my server, Apache CXF emits the following error: > > 2015-10-07 06:09:40,099 > | WARN > | p1886374391-2922 > | AbstractHTTPDestination > | > | 115 - org.apache.cxf.cxf-rt-transports-http - 3.0.4.redhat-620133 > | Invalid character set \"utf-8\" in request.
It seems that apache cxf forgets to strip backslashes. In the attached version of XML/Compile/Transport/SOAPHTTP.pm, I have removed the quotes. Does it work now? -- MarkOv
Download SOAPHTTP.pm
text/x-perl 13.6k

Message body is not shown because sender requested not to inline it.

Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Tue, 5 Jan 2016 11:48:32 -0800
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 1011b
Thank you, Mark. The .pm you provided works. Are you planning to incorporate this change in the next release? Show quoted text
> On Jan 5, 2016, at 1:07 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > > Sorry for the late reply, Derek, December is a horrible month for work. > > * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [151211 19:42]:
>> I'm still seeing the issue - when I use XML::Compile::XOP to send a SOAP message to my server, Apache CXF emits the following error: >> >> 2015-10-07 06:09:40,099 >> | WARN >> | p1886374391-2922 >> | AbstractHTTPDestination >> | >> | 115 - org.apache.cxf.cxf-rt-transports-http - 3.0.4.redhat-620133 >> | Invalid character set \"utf-8\" in request.
> > It seems that apache cxf forgets to strip backslashes. In the attached > version of XML/Compile/Transport/SOAPHTTP.pm, I have removed the quotes. > Does it work now? > -- > MarkOv > > <SOAPHTTP.pm>
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Wed, 6 Jan 2016 16:16:15 +0100
To: Derek Hausauer via RT <bug-XML-Compile-SOAP [...] rt.cpan.org>
From: Mark Overmeer <solutions [...] overmeer.net>
Download (untitled) / with headers
text/plain 655b
* Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [160105 19:49]: Show quoted text
> Queue: XML-Compile-SOAP > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > Thank you, Mark. The .pm you provided works. Are you planning to > incorporate this change in the next release?
Released as 3.14 -- Thanks for the report, MarkOv ------------------------------------------------------------------------ Mark Overmeer MSc MARKOV Solutions Mark@Overmeer.net solutions@overmeer.net http://Mark.Overmeer.net http://solutions.overmeer.net
Subject: Re: [rt.cpan.org #107586] Issue with XOP escaped quotes with Apache CXF (JAX-WS)
Date: Thu, 7 Jan 2016 09:17:59 -0800
To: bug-XML-Compile-SOAP [...] rt.cpan.org
From: Derek Hausauer <hausauer [...] gmail.com>
Download (untitled) / with headers
text/plain 875b
Works now! Thank you so much. Show quoted text
> On Jan 6, 2016, at 7:16 AM, Mark Overmeer via RT <bug-XML-Compile-SOAP@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > > > * Derek Hausauer via RT (bug-XML-Compile-SOAP@rt.cpan.org) [160105 19:49]:
>> Queue: XML-Compile-SOAP >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=107586 > >> >> Thank you, Mark. The .pm you provided works. Are you planning to >> incorporate this change in the next release?
> > Released as 3.14 > -- > Thanks for the report, > > MarkOv > > ------------------------------------------------------------------------ > Mark Overmeer MSc MARKOV Solutions > Mark@Overmeer.net solutions@overmeer.net > http://Mark.Overmeer.net http://solutions.overmeer.net > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.