Skip Menu |
 

This queue is for tickets about the CGI-Simple CPAN distribution.

Report information
The Basics
Id: 107003
Status: new
Priority: 0/
Queue: CGI-Simple

People
Owner: Nobody in particular
Requestors: mschout [...] gkg.net
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Incorrect detection of mod_perl2 version.
Date: Thu, 10 Sep 2015 08:31:23 -0500
To: bug-cgi-simple [...] rt.cpan.org
From: Michael Schout <mschout [...] gkg.net>
Download (untitled) / with headers
text/plain 897b
Hi. in _initialize_mod_perl(), CGI::Simple is checking if $mod_perl::VERSION is >= 2.00. However, the *ACTUAL* version that the great rename into the Apache2 namespace happened was in the 2.0.0-RC5 release of mod_perl, which has $mod_perl::VERSION set to 1.999022. Because of this, CGI::Simple fails to work if run under mod_perl2 2.0.0-RC5. Yes I know this is an ancient release, but there was a version of RHEL that shipped with this (RHEL5 IIRC). The fix is simple: diff --git a/lib/CGI/Simple.pm b/lib/CGI/Simple.pm index 52d5198..ef71760 100644 --- a/lib/CGI/Simple.pm +++ b/lib/CGI/Simple.pm @@ -229,7 +229,7 @@ sub _initialize_mod_perl { if ( defined $mod_perl::VERSION ) { - if ( $mod_perl::VERSION >= 2.00 ) { + if ( $mod_perl::VERSION >= 1.999022 ) { $self->{'.mod_perl'} = 2; require Apache2::RequestRec; Thanks in advance. Regards, Michael Schout


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.