This queue is for tickets about the Pod-Coverage-Moose CPAN distribution.

Report information
The Basics
Id:
106898
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
ether [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
0.07



Subject: tests fail for new Moose with no MXRWO
Copied from a comment on https://github.com/moose/Pod-Coverage-Moose/commit/dce14a74954fe771e26bb418a1db4d12400c9e14#commitcomment-12918096: Hey, We have a semi-automatic system for building perl modules, and it fails to build Pod::Coverage::Moose now. We end up with Moose 2.1600, but no MooseX::Role::WithOverloading (it isn't listed in test_requires in the meta?). if I move the eval like this: my $res = eval { require Moose; Moose->VERSION('2.1300') }; use if !$res 'Test::Requires' => 'MooseX::Role::WithOverloading'; the test skips properly, and installing MooseX::Role::WithOverloading manually then makes the test run and pass as well, but I do not think that is the intention of the code. (It took me a while to understand). If I understand the commit message correctly, the idea is that MooseX::Role::WithOverloading isn't needed on Moose 2.1300 and higher? But t/lib/TestOverload.pm still has a use MooseX::Role::WithOverloading that blows up on newer Moose it seems? (Note, I am not sure if commenting here is ok or not, please let me know if you prefer a RT issue instead) -omega
Fixed in 0.07.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.