Skip Menu |
 

This queue is for tickets about the IO-Util CPAN distribution.

Report information
The Basics
Id: 106584
Status: open
Priority: 0/
Queue: IO-Util

People
Owner: Nobody in particular
Requestors: JHI [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: test failures with 5.22.0
Download (untitled) / with headers
text/plain 1.5k
... Running make for D/DO/DOMIZIO/IO-Util-1.5.tar.gz CPAN: Module::CoreList loaded ok (v5.20150520) cp lib/IO/Util.pm blib/lib/IO/Util.pm Manifying 1 pod document DOMIZIO/IO-Util-1.5.tar.gz /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 "/usr/local/perl-forge/v/5.22.0/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01_capture.t ................. ok t/02_capture_memory_leaking.t .. ok t/03_slurp.t ................... ok t/04_uniqid.t .................. ok t/05_uniqid_no_import.t ........ ok t/06_load_mml.t ................ ok t/07_load_mml.t ................ ok Can't stat ../lib: No such file or directory at /usr/local/perl-forge/v/5.22.0/site/lib/Test/Pod.pm line 225. # Failed test 'POD test for blib/lib/IO/Util.pm' # at /usr/local/perl-forge/v/5.22.0/site/lib/Test/Pod.pm line 187. # blib/lib/IO/Util.pm (829): Non-ASCII character seen before =encoding in '<A9>'. Assuming CP1252 # Looks like you failed 1 test of 1. t/test_pod.t ................... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests t/test_pod_coverage.t .......... ok Test Summary Report ------------------- t/test_pod.t (Wstat: 256 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 1 Files=9, Tests=101, 1 wallclock secs ( 0.07 usr 0.03 sys + 0.44 cusr 0.05 csys = 0.59 CPU) Result: FAIL Failed 1/9 test programs. 1/101 subtests failed. make: *** [test_dynamic] Error 255 DOMIZIO/IO-Util-1.5.tar.gz /usr/bin/make test -- NOT OK
Download (untitled) / with headers
text/plain 1.4k
On 2015-08-21 07:43:20, JHI wrote: Show quoted text
> ... > Running make for D/DO/DOMIZIO/IO-Util-1.5.tar.gz > CPAN: Module::CoreList loaded ok (v5.20150520) > cp lib/IO/Util.pm blib/lib/IO/Util.pm > Manifying 1 pod document > DOMIZIO/IO-Util-1.5.tar.gz > /usr/bin/make -- OK > Running make test > PERL_DL_NONLAZY=1 "/usr/local/perl-forge/v/5.22.0/bin/perl" "- > MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef > *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" > t/*.t > t/01_capture.t ................. ok > t/02_capture_memory_leaking.t .. ok > t/03_slurp.t ................... ok > t/04_uniqid.t .................. ok > t/05_uniqid_no_import.t ........ ok > t/06_load_mml.t ................ ok > t/07_load_mml.t ................ ok > Can't stat ../lib: No such file or directory > at /usr/local/perl-forge/v/5.22.0/site/lib/Test/Pod.pm line 225. > > # Failed test 'POD test for blib/lib/IO/Util.pm' > # at /usr/local/perl-forge/v/5.22.0/site/lib/Test/Pod.pm line 187. > # blib/lib/IO/Util.pm (829): Non-ASCII character seen before =encoding > in '<A9>'. Assuming CP1252 > # Looks like you failed 1 test of 1. > t/test_pod.t ................... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests
Please don't allow pod tests to run for normal user installs. Either move them to xt/, or guard them with: plan skip_all => 'these tests are for authors only!' unless $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING}; (regarding this specific error, you need an '=encoding' directive in pod.)
Download (untitled) / with headers
text/plain 1.7k
On 2015-08-21 10:43:20, JHI wrote: Show quoted text
> ... > Running make for D/DO/DOMIZIO/IO-Util-1.5.tar.gz > CPAN: Module::CoreList loaded ok (v5.20150520) > cp lib/IO/Util.pm blib/lib/IO/Util.pm > Manifying 1 pod document > DOMIZIO/IO-Util-1.5.tar.gz > /usr/bin/make -- OK > Running make test > PERL_DL_NONLAZY=1 "/usr/local/perl-forge/v/5.22.0/bin/perl" "- > MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef > *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" > t/*.t > t/01_capture.t ................. ok > t/02_capture_memory_leaking.t .. ok > t/03_slurp.t ................... ok > t/04_uniqid.t .................. ok > t/05_uniqid_no_import.t ........ ok > t/06_load_mml.t ................ ok > t/07_load_mml.t ................ ok > Can't stat ../lib: No such file or directory > at /usr/local/perl-forge/v/5.22.0/site/lib/Test/Pod.pm line 225. > > # Failed test 'POD test for blib/lib/IO/Util.pm' > # at /usr/local/perl-forge/v/5.22.0/site/lib/Test/Pod.pm line 187. > # blib/lib/IO/Util.pm (829): Non-ASCII character seen before =encoding > in '<A9>'. Assuming CP1252 > # Looks like you failed 1 test of 1. > t/test_pod.t ................... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > t/test_pod_coverage.t .......... ok > > Test Summary Report > ------------------- > t/test_pod.t (Wstat: 256 Tests: 1 Failed: 1) > Failed test: 1 > Non-zero exit status: 1 > Files=9, Tests=101, 1 wallclock secs ( 0.07 usr 0.03 sys + 0.44 > cusr 0.05 csys = 0.59 CPU) > Result: FAIL > Failed 1/9 test programs. 1/101 subtests failed. > make: *** [test_dynamic] Error 255 > DOMIZIO/IO-Util-1.5.tar.gz > /usr/bin/make test -- NOT OK
Already reported: https://rt.cpan.org/Ticket/Display.html?id=79063


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.