Skip Menu |
 

This queue is for tickets about the LWP-Protocol-https CPAN distribution.

Report information
The Basics
Id: 105889
Status: resolved
Priority: 0/
Queue: LWP-Protocol-https

People
Owner: Nobody in particular
Requestors: csae2608 [...] uibk.ac.at
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: debian squeeze - perl update - error cpan LWP::Protocol::https
Date: Thu, 16 Jul 2015 08:01:55 +0200
To: bug-LWP-Protocol-https [...] rt.cpan.org
From: richard kuenz <csae2608 [...] uibk.ac.at>
Download (untitled) / with headers
text/plain 2.5k
hello , i would like to use youtube-viewer on debian squeeze. it comes only with perl -v 5.10 so i updated systemwide via perlbrew the program gives after compiling error [501 Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)] LWP::Protocol::https is not available on squeeze so i do cpan LWP::Protocol::https but this does not work out with the perlbrew version # Failed test at t/apache.t line 25. # Looks like you failed 3 tests of 5. t/apache.t ....... Dubious, test returned 3 (wstat 768, 0x300) Failed 3/5 subtests t/https_proxy.t .. Can't locate IO/Socket/SSL.pm in @INC (you may need to install the IO::Socket::SSL module)) at /home/ricci/perl5/perlbrew/perls/perl-5.20.1/lib/site_perl/5.20.1/Net/HTTPS.pm line 27. Can't locate Net/SSL.pm in @INC (you may need to install the Net::SSL module) (@INC contains: /home/ricci/.cpan/build/LWP-Protocol-https-6.06-nAuSue/blib/lib /home/ricci/.cpan/build/LWP-Protocol-https-6.06-nAuSue/blib/arch /home/ricci/perl5/perlbrew/perls/perl-5.20.1/lib/site_perl/5.20.1/x86_64-linux /home/ricci/perl5/perlbrew/perls/perl-5.20.1/lib/site_perl/5.20.1 /home/ricci/perl5/perlbrew/perls/perl-5.20.1/lib/5.20.1/x86_64-linux /home/ricci/perl5/perlbrew/perls/perl-5.20.1/lib/5.20.1 .) at /home/ricci/perl5/perlbrew/perls/perl-5.20.1/lib/site_perl/5.20.1/Net/HTTPS.pm line 31. Compilation failed in require at /home/ricci/.cpan/build/LWP-Protocol-https-6.06-nAuSue/blib/lib/LWP/Protocol/https.pm line 8. Compilation failed in require at t/https_proxy.t line 14. BEGIN failed--compilation aborted at t/https_proxy.t line 14. t/https_proxy.t .. Dubious, test returned 2 (wstat 512, 0x200) No subtests run Test Summary Report ------------------- t/apache.t (Wstat: 768 Tests: 5 Failed: 3) Failed tests: 1, 3-4 Non-zero exit status: 3 t/https_proxy.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: No plan found in TAP output Files=2, Tests=5, 0 wallclock secs ( 0.04 usr 0.00 sys + 0.16 cusr 0.00 csys = 0.20 CPU) Result: FAIL Failed 2/2 test programs. 3/5 subtests failed. make: *** [test_dynamic] Fehler 2 MSCHILLI/LWP-Protocol-https-6.06.tar.gz one dependency not OK (IO::Socket::SSL); additionally test harness failed /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports MSCHILLI/LWP-Protocol-https-6.06.tar.gz what i can do ? reinstall and use another method for updating perl? how can i overcome and install LWP-Protocol-https on Debian Squeeze? Thanks - Danke - Grazie - Multumesq
Download (untitled) / with headers
text/plain 241b
You have problem installing IO::Socket::SSL. Check that you have libssl-dev package installed and try installing IO::Socket::SSL. If you still have problems, report it to IO::Socket::SSL bug tracker. -- Alexandr Ciornii, http://chorny.net


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.