Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 105742
Status: rejected
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: coolo [...] suse.de
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.016
Fixed in: (no value)



Subject: IO::Socket::IP support does not work without network
Download (untitled) / with headers
text/plain 805b
As we updated perl to 5.22.0 in the openSUSE distribution, we noticed that IO-Socket-SSL fails to run its test suite. After some debugging, it turned out that with new perl, IO-Socket-SSL switches from ::INET to ::IP and that module uses getaddrinfo, which fails to resolve the port numbers given by the ::SSL test suite if there is no proper network in the build environment. We disable network for reproduciblity and security. The good news: you can disable that feature of ::IP, but you have to add it in every constructor call in the test suite. Attached is the patch that makes it build in the Open Build Service again. Hope you can integrate that in one way or another in a future upstream release. (I used spaces where you used tabs, I noticed too late - so don't get fooled by applying as is)
Subject: perl-IO-Socket-SSL_fix_offline.patch

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 1.2k
Am Mi 08. Jul 2015, 03:48:51, https://www.opensuse.org/openid/user/coolo schrieb: Show quoted text
> As we updated perl to 5.22.0 in the openSUSE distribution, we noticed > that IO-Socket-SSL fails to run its test suite. > > After some debugging, it turned out that with new perl, IO-Socket-SSL > switches from ::INET to ::IP and that module uses getaddrinfo, which > fails to resolve the port numbers given by the ::SSL test suite if > there is no proper network in the build environment. We disable > network for reproduciblity and security. > > The good news: you can disable that feature of ::IP, but you have to > add it in every constructor call in the test suite.
I would assume that this would not only affect IO::Socket::SSL but any module and test using IO::Socket::IP. I also don't think that a default of using AI_ADDRCONFIG is a bad idea, since it requires anybody to explicitly disable this default when using software on an unconnected system with only localhost, which is not uncommon setup. It also behaves differently to existing modules like IO::Socket::INET. Thus I would recommend that this should be fixed in IO::Socket::IP and not in every module using IO::Socket::IP. Please consider to file this bug against IO::Socket::IP instead.
Download (untitled) / with headers
text/plain 365b
Show quoted text
> Thus I would recommend that this should be fixed in IO::Socket::IP > and not in every module using IO::Socket::IP. Please consider to > file this bug against IO::Socket::IP instead.
Actually it looks like there is already a similar bug report against IO::Socket::IP, which is unrelated to IO::Socket::SSL. https://rt.cpan.org/Public/Bug/Display.html?id=104793
From: coolo [...] suse.de
Download (untitled) / with headers
text/plain 598b
Am Mi 08. Jul 2015, 04:45:22, SULLR schrieb: Show quoted text
>
> > Thus I would recommend that this should be fixed in IO::Socket::IP > > and not in every module using IO::Socket::IP. Please consider to > > file this bug against IO::Socket::IP instead.
> > Actually it looks like there is already a similar bug report against > IO::Socket::IP, which is unrelated to IO::Socket::SSL. > https://rt.cpan.org/Public/Bug/Display.html?id=104793
Actually Socket::IP's test suite uses the same flag all over the place. So the author is aware of the problem - but the bug shows little activity ;( Greetings, Stephan
On Wed Jul 08 05:08:26 2015, https://www.opensuse.org/openid/user/coolo wrote: Show quoted text
> Am Mi 08. Jul 2015, 04:45:22, SULLR schrieb:
> >
> > > Thus I would recommend that this should be fixed in IO::Socket::IP > > > and not in every module using IO::Socket::IP. Please consider to > > > file this bug against IO::Socket::IP instead.
> > > > Actually it looks like there is already a similar bug report against > > IO::Socket::IP, which is unrelated to IO::Socket::SSL. > > https://rt.cpan.org/Public/Bug/Display.html?id=104793
> > Actually Socket::IP's test suite uses the same flag all over the > place. So the author is aware of the problem - but the bug shows > little activity ;(
I currently don't think that I should work around bugs in other modules if the author is already aware of the problem. It would probably be different if the module author actively declared that this is not a bug but a feature and one need to use the module the correct way. But thanks for pointing out the issue and if it gets too bad I either try to convince the module author to fix the problem or need to work around it myself.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.