Skip Menu |
 

This queue is for tickets about the Class-Monadic CPAN distribution.

Report information
The Basics
Id: 104980
Status: open
Priority: 0/
Queue: Class-Monadic

People
Owner: Nobody in particular
Requestors: stevenlabs [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.04
Fixed in: (no value)



Subject: Class-Monadic-0.04 fails install by Carton since perl 5.22.0
It will fail to version confirmation of Extutils::MakeMaker in the confirmation of MYMETA.json. Also, then we'll go to look for it in cpanmetadb but v7.04_01 is not upload to CPAN. perl 5.22.0 uses ExtUtils::MakeMaker v7.04_01. Stable version of it of CPAN has become to v7.04. Previously it occurred, here and I think closer to the content. http://weblog.bulknews.net/post/33905644998/makemaker-dev-releases-perl-5-16-and-carton http://weblog.bulknews.net/post/33907905561/do-not-ship-modules-with-module-install-1-04 It seems that it should do update the bundled Module::Install To resolve this. --- Checking dependencies from MYMETA.json ... Checking if you have Class::Method::Modifiers::Fast 0 ... Yes (0.041) Checking if you have Test::More 0.62 ... Yes (1.001014) Checking if you have ExtUtils::MakeMaker 7.0401 ... No (7.04_01 < 7.0401) Checking if you have Data::Util 0.44 ... Yes (0.63) Checking if you have Exporter 5.57 ... Yes (5.72) Checking if you have Hash::FieldHash 0 ... Yes (0.14) Checking if you have Test::LeakTrace 0.08 ... Yes (0.14) ==> Found dependencies: ExtUtils::MakeMaker Searching ExtUtils::MakeMaker (7.0401) on cpanmetadb ... --2015-06-05 17:12:53-- http://cpanmetadb.plackperl.org/v1.0/package/ExtUtils::MakeMaker cpanmetadb.plackperl.org (cpanmetadb.plackperl.org) をDNSに問いあわせています... 23.235.47.129, 23.235.47.192 cpanmetadb.plackperl.org (cpanmetadb.plackperl.org)|23.235.47.129|:80 に接続しています... 接続しました。 HTTP による接続要求を送信しました、応答を待っています... 200 OK 長さ: 71 [text/yaml] `STDOUT' に保存中 100% [===================================================================================================================================>] 71 --.-K/s 時間 0s 2015-06-05 17:12:53 (1.15 MB/s) - stdout へ出力完了 [71/71] Found ExtUtils::MakeMaker 7.04 which doesn't satisfy 7.0401. ! Installing the dependencies failed: Installed version (7.04_01) of ExtUtils::MakeMaker is not in range '7.0401' ! Bailing out the installation for Class-Monadic-0.04. --- Regards,
Download (untitled) / with headers
text/plain 2.4k
On 2015-06-05 02:46:52, SHIBUYA wrote: Show quoted text
> It will fail to version confirmation of Extutils::MakeMaker in the > confirmation of MYMETA.json. > Also, then we'll go to look for it in cpanmetadb but v7.04_01 is not > upload to CPAN. > perl 5.22.0 uses ExtUtils::MakeMaker v7.04_01. > Stable version of it of CPAN has become to v7.04. > > Previously it occurred, here and I think closer to the content. > http://weblog.bulknews.net/post/33905644998/makemaker-dev-releases- > perl-5-16-and-carton > http://weblog.bulknews.net/post/33907905561/do-not-ship-modules-with- > module-install-1-04 > > It seems that it should do update the bundled Module::Install To > resolve this. > > > --- > Checking dependencies from MYMETA.json ... > Checking if you have Class::Method::Modifiers::Fast 0 ... Yes (0.041) > Checking if you have Test::More 0.62 ... Yes (1.001014) > Checking if you have ExtUtils::MakeMaker 7.0401 ... No (7.04_01 < > 7.0401) > Checking if you have Data::Util 0.44 ... Yes (0.63) > Checking if you have Exporter 5.57 ... Yes (5.72) > Checking if you have Hash::FieldHash 0 ... Yes (0.14) > Checking if you have Test::LeakTrace 0.08 ... Yes (0.14) > ==> Found dependencies: ExtUtils::MakeMaker > Searching ExtUtils::MakeMaker (7.0401) on cpanmetadb ... > --2015-06-05 17:12:53-- > http://cpanmetadb.plackperl.org/v1.0/package/ExtUtils::MakeMaker > cpanmetadb.plackperl.org (cpanmetadb.plackperl.org) をDNSに問いあわせています... > 23.235.47.129, 23.235.47.192 > cpanmetadb.plackperl.org (cpanmetadb.plackperl.org)|23.235.47.129|:80 > に接続しています... 接続しました。 > HTTP による接続要求を送信しました、応答を待っています... 200 OK > 長さ: 71 [text/yaml] > `STDOUT' に保存中 > > 100% > [===================================================================================================================================>] > 71 --.-K/s 時間 0s > > 2015-06-05 17:12:53 (1.15 MB/s) - stdout へ出力完了 [71/71] > > Found ExtUtils::MakeMaker 7.04 which doesn't satisfy 7.0401. > ! Installing the dependencies failed: Installed version (7.04_01) of > ExtUtils::MakeMaker is not in range '7.0401' > ! Bailing out the installation for Class-Monadic-0.04. > --- > > Regards,
This is a problem with older Module::Install. If you re-release the distribution using a new Module::Install, it should go away. See here for another example: https://github.com/miyagawa/cpanminus/issues/463
Download (untitled) / with headers
text/plain 2.5k
On 2015-6月-05 金 12:57:09, ETHER wrote: Show quoted text
> On 2015-06-05 02:46:52, SHIBUYA wrote:
> > It will fail to version confirmation of Extutils::MakeMaker in the > > confirmation of MYMETA.json. > > Also, then we'll go to look for it in cpanmetadb but v7.04_01 is not > > upload to CPAN. > > perl 5.22.0 uses ExtUtils::MakeMaker v7.04_01. > > Stable version of it of CPAN has become to v7.04. > > > > Previously it occurred, here and I think closer to the content. > > http://weblog.bulknews.net/post/33905644998/makemaker-dev-releases- > > perl-5-16-and-carton > > http://weblog.bulknews.net/post/33907905561/do-not-ship-modules-with- > > module-install-1-04 > > > > It seems that it should do update the bundled Module::Install To > > resolve this. > > > > > > --- > > Checking dependencies from MYMETA.json ... > > Checking if you have Class::Method::Modifiers::Fast 0 ... Yes (0.041) > > Checking if you have Test::More 0.62 ... Yes (1.001014) > > Checking if you have ExtUtils::MakeMaker 7.0401 ... No (7.04_01 < > > 7.0401) > > Checking if you have Data::Util 0.44 ... Yes (0.63) > > Checking if you have Exporter 5.57 ... Yes (5.72) > > Checking if you have Hash::FieldHash 0 ... Yes (0.14) > > Checking if you have Test::LeakTrace 0.08 ... Yes (0.14) > > ==> Found dependencies: ExtUtils::MakeMaker > > Searching ExtUtils::MakeMaker (7.0401) on cpanmetadb ... > > --2015-06-05 17:12:53-- > > http://cpanmetadb.plackperl.org/v1.0/package/ExtUtils::MakeMaker > > cpanmetadb.plackperl.org (cpanmetadb.plackperl.org) をDNSに問いあわせています... > > 23.235.47.129, 23.235.47.192 > > cpanmetadb.plackperl.org (cpanmetadb.plackperl.org)|23.235.47.129|:80 > > に接続しています... 接続しました。 > > HTTP による接続要求を送信しました、応答を待っています... 200 OK > > 長さ: 71 [text/yaml] > > `STDOUT' に保存中 > > > > 100% > > [===================================================================================================================================>] > > 71 --.-K/s 時間 0s > > > > 2015-06-05 17:12:53 (1.15 MB/s) - stdout へ出力完了 [71/71] > > > > Found ExtUtils::MakeMaker 7.04 which doesn't satisfy 7.0401. > > ! Installing the dependencies failed: Installed version (7.04_01) of > > ExtUtils::MakeMaker is not in range '7.0401' > > ! Bailing out the installation for Class-Monadic-0.04. > > --- > > > > Regards,
> > This is a problem with older Module::Install. If you re-release the > distribution using a new Module::Install, it should go away. See here > for another example: https://github.com/miyagawa/cpanminus/issues/463
I see. Thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.