Skip Menu |
 

This queue is for tickets about the IUP CPAN distribution.

Report information
The Basics
Id: 104746
Status: open
Priority: 0/
Queue: IUP

People
Owner: Nobody in particular
Requestors: futuramedium [...] yandex.ru
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.303
Fixed in: (no value)



Subject: Can't install in 14.04 LTS Ubuntu
Download (untitled) / with headers
text/plain 902b
To exclude possibility that my system is somehow broken or messed up, I'm reproducing the problem in 'fresh clean installation' of 14.04.2 LTS (64-bit) i.e. I'm booting live-CD image. Then I: 1) run cpan once to configure (tried both local::lib and sudo options), 2) install synaptic and all packages mentioned here: http://webserver2.tecgraf.puc-rio.br/iup/en/building.html 3) install, through cpan, Alien::IUP -- successfully, 4) (sudo) cpan IUP -- it fails (log attached). I see that LibraryIup.so was built OK, but DynaLoader fails to load it -- troubleshooting this is beyond my knowledge, maybe I'm missing something obvious. Same failure as with installing onto my working machine, though there I tried perlbrew with different Perl versions. Same scenario (boot from live-CD image) I tried with latest 15.04 Ubuntu. There Alien::IUP fails to install, I can provide a log file, if necessary.
Subject: build.log
Download build.log
application/octet-stream 3.8k

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Thu, 28 May 2015 18:07:21 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
Download (untitled) / with headers
text/plain 175b
1/ what's the version of gtk on your system? 2/ could you send me the output of perl -MAlien::IUP -E 'say Alien::IUP->config("LIBS"); say Alien::IUP->config("INC")' -- kmx
From: futuramedium [...] yandex.ru
Download (untitled) / with headers
text/plain 1.7k
On Thu May 28 12:07:41 2015, KMX wrote: Show quoted text
> 1/ what's the version of gtk on your system? >
ubuntu@ubuntu:~$ dpkg -l libgtk2.0-0 libgtk-3-0 Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Architecture Description +++-==============-============-============-================================= ii libgtk-3-0:amd 3.10.8-0ubun amd64 GTK+ graphical user interface lib ii libgtk2.0-0:am 2.24.23-0ubu amd64 GTK+ graphical user interface lib ubuntu@ubuntu:~$ Show quoted text
> 2/ could you send me the output of > perl -MAlien::IUP -E 'say Alien::IUP->config("LIBS"); say > Alien::IUP->config("INC")' >
ubuntu@ubuntu:~$ perl -MAlien::IUP -E 'say Alien::IUP->config("LIBS"); say Alien::IUP->config("INC")' -L'/usr/local/share/perl/5.18.2/auto/share/dist/Alien-IUP/0.703/lib' -liupcontrols -liup_pplot -liupcd -liupgl -liupglcontrols -liup_mglplot -liupim -liupimglib -liup -lcd -lftgl -lim -liupmatrixex -liup_plot -liup_scintilla -lz -lGL -lGLU -lstdc++ -lgtk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lfontconfig -lfreetype -lgdk-x11-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lcairo -L/usr/local/lib -L/usr/lib/x86_64-linux-gnu -I/usr/lib/x86_64-linux-gnu -I'/usr/local/share/perl/5.18.2/auto/share/dist/Alien-IUP/0.703/include' -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/harfbuzz -I/usr/local/include
Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Thu, 28 May 2015 22:50:42 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
In fact it seems to be a bug in Alien::IUP.
Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Fri, 29 May 2015 21:39:18 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
Download (untitled) / with headers
text/plain 190b
Could you please try to install dev version Alien-IUP-0.703_1 and test IUP install again? Before Allien::IUp installation make sure you have installed: sudo apt-get install libgtk-3-dev
Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Fri, 29 May 2015 21:39:40 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
Download (untitled) / with headers
text/plain 190b
Could you please try to install dev version Alien-IUP-0.703_1 and test IUP install again? Before Allien::IUP installation make sure you have installed: sudo apt-get install libgtk-3-dev
From: futuramedium [...] yandex.ru
Download (untitled) / with headers
text/plain 2.3k
Thanks, I've been able now to install Alien-IUP-0.703_1 and then IUP in 14.04. There are still some issues. 1) Can't install Alien-IUP-0.703_1 in Ubuntu 15.04. Not a problem for me for now, don't know if this is low priority or not, i.e. just for your information. Log file attached, gtk versions below. +++-=================-================-============-===================================== ii libgtk-3-0:amd64 3.14.12-0ubuntu2 amd64 GTK+ graphical user interface library ii libgtk2.0-0:amd64 2.24.27-0ubuntu1 amd64 GTK+ graphical user interface library 2) In Strawberry, I've upgraded Alien-IUP and IUP -- my app runs OK as earlier no problem. 3) In 14.04, my app runs mostly OK, but there are some annoying issues. Can't tell if this is due to new library versions or these issues were always there with IUP and gtk. 4) When I start my app, there's a message: (perl:2459): Gtk-WARNING **: Toplevel size doesn't seem to directly depend on the size of the geometry widget from gtk_window_set_geometry_hints(). The geometry widget might not be in the window, or it might not be packed into the window appropriately Don't know if it affects anything, maybe it's my bad programming style so we can skip this. But, next issues I've been able to isolate to particular controls (Canvas and Expander) and I get them with examples bundled with IUP, too. 5) Running perl IUP-0.303/examples/0-basic/canvas2.pl and then mousing over or scrolling or clicking -- i.e. any redraw (?) -- I see constant messages like Argument "0,00000000..." isn't numeric in multiplication (*) at IUP-0.303/examples/0-basic/canvas2.pl line 48. I.e. it looks like an eternal issue with decimal point/comma separator. Maybe it doesn't affect anything -- just annoying. 6) Starting perl IUP-0.303/examples/0-basic/expander.pl I'm getting very weird behaviour, kind of hard to explain, maybe you'll reject it. I'll try :). What clicking on Expander control does, looks like depends on mouse cursor position over screen (i.e. relative to future position of Expander when program starts). It's either a) normal behaviour; b) program window gets maximized (??); c) program window becomes hidden (???). Maybe I should record my screen or something like that, to show, if necessary. + Some other (minor?) issues, I'll see if I can debug them or make them presentable as a bug report :-).
Subject: build_alien-iup-0703_1-ubuntu-1504.log

Message body is not shown because it is too large.

Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Sat, 30 May 2015 19:47:33 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
Download (untitled) / with headers
text/plain 155b
Show quoted text
> 1) Can't install Alien-IUP-0.703_1 in Ubuntu 15.04.
I have just uploaded Alien-IUP-0.703_2.tar.gz to CPAN. Could you please test it on Ubuntu 15.04?
Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Sat, 30 May 2015 20:24:36 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
try Alien-IUP-0.703_3.tar.gz (0.703_2 is broken)
From: futuramedium [...] yandex.ru
Download (untitled) / with headers
text/plain 413b
On Sat May 30 14:24:50 2015, KMX wrote: Show quoted text
> try Alien-IUP-0.703_3.tar.gz (0.703_2 is broken)
Alien-IUP-0.703_3 installs in both 14.04 and 15.04. Issues (4),(6) from my previous message still there, in both. (5) is gone in 15.04 but still present in 14.04. In 15.04 I'm also getting "Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged." and black background of MatrixList and Matrix.
Subject: Re: [rt.cpan.org #104746] Can't install in 14.04 LTS Ubuntu
Date: Fri, 05 Jun 2015 17:25:10 +0200
To: bug-IUP [...] rt.cpan.org
From: kmx <kmx [...] cpan.org>
Meanwhile I have released Alien-IUP-0.704 The remaining issues seems to be bugs in libiup.
From: futuramedium [...] yandex.ru
Nothing's perfect, hopefully they are minor issues for most users :). Many thanks for your work.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.