Skip Menu |
 

This queue is for tickets about the Net-Google-Spreadsheets CPAN distribution.

Report information
The Basics
Id: 104729
Status: new
Priority: 0/
Queue: Net-Google-Spreadsheets

People
Owner: Nobody in particular
Requestors: dolmen [...] cpan.org
ejensen1 [...] swarthmore.edu
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.1501
Fixed in: (no value)



Subject: Google no longer supporting AuthSub, breaks Net::Google::Spreadsheets
Date: Wed, 27 May 2015 09:12:24 -0400
To: bug-Net-Google-Spreadsheets [...] rt.cpan.org
From: Eric Jensen <ejensen1 [...] swarthmore.edu>
Download (untitled) / with headers
text/plain 465b
It appears that Google has stopped accepting any AuthSub authentication requests for access to Google spreadsheets. Since that is the authentication method that Net::Google::Spreadsheets->new calls, then any call to this breaks. It just reports “login failed” at line 42 of Net::Google::AuthSub as reported in bug #104190. If you’re able to update this to use OAuth2 by default, that would be great. (Note that OAuth1 is deprecated as well.) Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.