Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 104660
Status: rejected
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors:
Cc: ether [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.015
Fixed in: (no value)



Subject: io-socket-inet6 test fails when IO::Socket::IP is installed
Download (untitled) / with headers
text/plain 130b
The io-socket-inet6 test fails when IO::Socket::IP is installed. This can be fixed by blacklisting the module just for this test.
Subject: perl-IO-Socket-SSL.src2.patch
--- origsrc/IO-Socket-SSL-2.015/t/io-socket-inet6.t 2015-05-13 22:27:06.000000000 +0200 +++ src/IO-Socket-SSL-2.015/t/io-socket-inet6.t 2015-05-23 22:02:45.936309200 +0200 @@ -9,6 +9,7 @@ BEGIN { $INC{'IO/Socket/IP.pm'} = undef } +use Test::Without::Module qw( IO::Socket::IP ); use strict; use warnings; use Net::SSLeay;
Download (untitled) / with headers
text/plain 515b
Am So 24. Mai 2015, 07:03:28, https://me.yahoo.com/howdidwegetherereally#f714d schrieb: Show quoted text
> The io-socket-inet6 test fails when IO::Socket::IP is installed. This > can be fixed by blacklisting the module just for this test.
The test does not fail for me with both modules installed and there is already code in the test which causes IO::Socket::IP not too load. Can you be please more specific in which setup this test makes problems (OS, perl version, version of the modules) and how the error exactly looks like?
Download (untitled) / with headers
text/plain 1.1k
On 2015-05-24 10:12:01, SULLR wrote: Show quoted text
> Am So 24. Mai 2015, 07:03:28, > https://me.yahoo.com/howdidwegetherereally#f714d schrieb:
> > The io-socket-inet6 test fails when IO::Socket::IP is installed. > > This > > can be fixed by blacklisting the module just for this test.
> > > The test does not fail for me with both modules installed and there is > already code in the test which causes IO::Socket::IP not too load. Can > you be please more specific in which setup this test makes problems > (OS, perl version, version of the modules) and how the error exactly > looks like?
I agree, this sounds like a bug that needs to be solved, rather than avoided. It is not a good thing that certain module combinations fail, so these problems need to be found and fixed. In particular, it is really important to have diagnostic information to find these, as there *have* been a few interoperability problems lately, but it's been very hard to diagnose them. I've been seeing some test failures in the libwww-perl and Net-* distributions that I haven't been able to pinpoint yet, so any reproduction case at all will be *very* helpful.
Download (untitled) / with headers
text/plain 1.2k
Show quoted text
> I agree, this sounds like a bug that needs to be solved, rather than > avoided. It is not a good thing that certain module combinations fail, > so these problems need to be found and fixed.
This bug is not about IO::Socket::SSL failing with both modules installed, but this test failing. The test explictly makes sure that IO::Socket::IP gets not loaded to enforce testing with IO::Socket::INET6. By default IO::Socket::IP gets used (if recent enough) instead of IO::Socket::INET6 but this test checks if it would work with IO::Socket::INET6 too. So the question here is only why the test is failing. I doubt that it is due to IO::Socket::IP loaded instead, but I don't really know until I have more information about the issue instead of just "it fails". Show quoted text
> In particular, it is really important to have diagnostic information > to find these, as there *have* been a few interoperability problems > lately, but it's been very hard to diagnose them. I've been seeing > some test failures in the libwww-perl and Net-* distributions that I > haven't been able to pinpoint yet, so any reproduction case at all > will be *very* helpful.
I'm willing to help with these issues, but I don't really think that this bug here is related to them. But again, it is hard to know without having more details.
Download (untitled) / with headers
text/plain 994b
On Sun May 24 13:12:01 2015, SULLR wrote: Show quoted text
> Am So 24. Mai 2015, 07:03:28, > https://me.yahoo.com/howdidwegetherereally#f714d schrieb:
> > The io-socket-inet6 test fails when IO::Socket::IP is installed. > > This > > can be fixed by blacklisting the module just for this test.
> > > The test does not fail for me with both modules installed and there is > already code in the test which causes IO::Socket::IP not too load. Can > you be please more specific in which setup this test makes problems > (OS, perl version, version of the modules) and how the error exactly > looks like?
I've carried that patch for at least two years, so that would have been Win7/Cygwin-1.7.x, perl-5.14.2 and some 1.8x or 1.9x version of the module. I don't have the logfiles anymore, sorry. I've just tested with the patch removed and it doesn't fail for me now with Cygwin-2.0.2, perl-5.22.0-RC2 and the latest version of the module, so it appears that that bug had been fixed earlier. Sorry for the noise.
Download (untitled) / with headers
text/plain 205b
Show quoted text
> ... it doesn't fail for me now > with Cygwin-2.0.2, perl-5.22.0-RC2 and the latest version of the > module, so it appears that that bug had been fixed earlier. Sorry for > the noise.
Then is all well.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.