Skip Menu |
 

This queue is for tickets about the Net-Telnet CPAN distribution.

Report information
The Basics
Id: 104582
Status: rejected
Priority: 0/
Queue: Net-Telnet

People
Owner: Nobody in particular
Requestors: ramesh.b.vasudevan [...] verizon.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Bad named parameter personality given to Net::Telnet::new()
Date: Wed, 20 May 2015 16:30:46 -0400
To: "bug-Net-Telnet [...] rt.cpan.org" <bug-Net-Telnet [...] rt.cpan.org>
From: "Vasudevan, Ramesh Balaji" <ramesh.b.vasudevan [...] verizon.com>
Download (untitled) / with headers
text/plain 651b
Sir: I was trying to run perl by including following modules: use Net::Appliance::Session; use Net::Appliance::Session::Exceptions; use UNIVERSAL::require; use IO::File; use Switch; Received following error message: Enter your file name: test.txt Processing: bad named parameter "personality" given to Net::Telnet::new() at /opt/perl5/perls/perl-5.10.1/lib/site_perl/5.10.1/Net/Appliance/Session/Transport.pm line 21 I am not sure when this pm file gets called. Please let me know if I need to download latest Net::Telnet. I am currently using Perl 5.10.1 version. If you have any questions, please let me know. Thank You Ramesh Vasudevan
Download (untitled) / with headers
text/plain 885b
This is a user error. As the error message says, "personality" is not a valid Net::Telnet::new parameter. On Wed May 20 16:30:23 2015, ramesh.b.vasudevan@verizon.com wrote: Show quoted text
> Sir: > > I was trying to run perl by including following modules: > > use Net::Appliance::Session; > use Net::Appliance::Session::Exceptions; > use UNIVERSAL::require; > use IO::File; > use Switch; > > Received following error message: > Enter your file name: test.txt > Processing: > bad named parameter "personality" given to Net::Telnet::new() at > /opt/perl5/perls/perl- > 5.10.1/lib/site_perl/5.10.1/Net/Appliance/Session/Transport.pm line 21 > > I am not sure when this pm file gets called. Please let me know if I > need to download latest Net::Telnet. I am currently using Perl 5.10.1 > version. > > If you have any questions, please let me know. > > > > Thank You > > Ramesh Vasudevan


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.