This queue is for tickets about the Devel-Assert CPAN distribution.

Report information
The Basics
Id:
104425
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
felix.li [...] bankofamerica.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: Devel::Assert - Assert.xs:19:5: error: 'for' loop initial declarations are only allowed in C99 mode
Date: Thu, 14 May 2015 11:46:11 +0000
To: "bug-Devel-Assert@rt.cpan.org" <bug-Devel-Assert@rt.cpan.org>
From: "Li, Felix" <felix.li@bankofamerica.com>

HI,

 

Having a problem building Devel::Assert 1.04 on a Windows 7! (same thing on a Window 8.1 with 32 bit Strawberry Perl )

 

Perl details:

 

                c:\Users\zkx56st\Downloads>perl -v

 

                This is perl 5, version 20, subversion 1 (v5.20.1) built for MSWin32-x86-multi-thread-64int

 

                Copyright 1987-2014, Larry Wall

 

               …

 

The cpanm build:

 

                c:\Users\zkx56st\Downloads>cpanm .\Devel-Assert-1.04.tar.gz

                --> Working on .\Devel-Assert-1.04.tar.gz

                Fetching file://C:/Users/zkx56st/Downloads/Devel-Assert-1.04.tar.gz ... OK

                Configuring Devel-Assert-1.04 ... OK

                Building and testing Devel-Assert-1.04 ... FAIL

                ! Installing .\Devel-Assert-1.04.tar.gz failed. See P:\data\.cpanm\work\1431542639.9968\build.log for details. Retry with --force to force install it.

 

The log from cpanm build:

 

                c:\Users\zkx56st\Downloads>type P:\data\.cpanm\work\1431542639.9968\build.log

                cpanm (App::cpanminus) 1.7009 on perl 5.020001 built for MSWin32-x86-multi-thread-64int

                Work directory is P:\data/.cpanm/work/1431542639.9968

                You have make P:\c\bin\dmake.exe

                You have LWP 6.08

                Falling back to Archive::Tar 2.02

                --> Working on .\Devel-Assert-1.04.tar.gz

                Fetching file://C:/Users/zkx56st/Downloads/Devel-Assert-1.04.tar.gz

                -> OK

                Unpacking Devel-Assert-1.04.tar.gz

                Entering Devel-Assert-1.04

                Checking configure dependencies from META.json

                Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98)

                Configuring Devel-Assert-1.04

                Running Makefile.PL

                Checking if your kit is complete...

                Looks good

                Generating a dmake-style Makefile

                Writing Makefile for Devel::Assert

                Writing MYMETA.yml and MYMETA.json

                -> OK

                Checking dependencies from MYMETA.json ...

                Checking if you have Test::Exception 0 ... Yes (0.32)

                Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98)

                Checking if you have Test::More 0 ... Yes (1.001006)

                Building and testing Devel-Assert-1.04

                cp lib/Devel/Assert/Global.pm blib\lib\Devel\Assert\Global.pm

                cp lib/Devel/Assert.pm blib\lib\Devel\Assert.pm

                cp lib/Devel/Assert.pod blib\lib\Devel\Assert.pod

                Running Mkbootstrap for Devel::Assert ()

                P:\perl\bin\perl.exe -MExtUtils::Command -e chmod -- 644 Assert.bs

                P:\perl\bin\perl.exe P:\perl\lib\ExtUtils\xsubpp  -typemap P:\perl\lib\ExtUtils\typemap  Assert.xs > Assert.xsc && P:\perl\bin\perl.

                exe -MExtUtils::Command -e mv -- Assert.xsc Assert.c

                gcc -c          -s -O2 -DWIN32 -DPERL_TEXTMODE_SCRIPTS -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -DUSE_PERLIO -fwrapv -fno-strict-

                aliasing -mms-bitfields -s -O2    -DVERSION=\"1.04\"    -DXS_VERSION=\"1.04\"  "-IP:\perl\lib\CORE"   Assert.c

                Assert.xs: In function 'find_context_cv':

                Assert.xs:19:5: error: 'for' loop initial declarations are only allowed in C99 mode

                                for (PERL_CONTEXT* cx = cxstack + cxstack_ix; cx >= cxstack; --cx) {

                                ^

                Assert.xs:19:5: note: use option -std=c99 or -std=gnu99 to compile your code

                dmake.exe:  Error code 129, while making 'Assert.o'

                -> FAIL Installing .\Devel-Assert-1.04.tar.gz failed. See P:\data\.cpanm\work\1431542639.9968\build.log for details. Retry with --fo

    rce to force install it.

 

"--force" doen't, however, work.

 

Thanks,

 


This message, and any attachments, is for the intended recipient(s) only, may contain information that is privileged, confidential and/or proprietary and subject to important terms and conditions available at http://www.bankofamerica.com/emaildisclaimer. If you are not the intended recipient, please delete this message.
On Thu May 14 07:46:31 2015, felix.li@bankofamerica.com wrote:
Show quoted text
> Having a problem building Devel::Assert 1.04 on a Windows 7! (same > thing on a Window 8.1 with 32 bit Strawberry Perl )
Show quoted text
> Assert.xs:19:5: error: 'for' loop initial declarations are only > allowed in C99 mode > for (PERL_CONTEXT* cx = cxstack + cxstack_ix; cx >= > cxstack; --cx) { > ^ > Assert.xs:19:5: note: use option -std=c99 or -std=gnu99 to compile > your code
Thanks for the report, I've fixed this particular error, but I don't have around Win box or gcc toolchain old enough, so I couldn't check for any other possible build incompatibilities. Please try 1.06 version.
Subject: RE: [rt.cpan.org #104425] Devel::Assert - Assert.xs:19:5: error: 'for' loop initial declarations are only allowed in C99 mode
Date: Thu, 14 May 2015 13:44:21 +0000
To: "bug-Devel-Assert@rt.cpan.org" <bug-Devel-Assert@rt.cpan.org>
From: "Li, Felix" <felix.li@bankofamerica.com>
INSTALLED! Yea! Thanks!
Show quoted text
-----Original Message----- From: Sergey Aleynikov via RT [mailto:bug-Devel-Assert@rt.cpan.org] Sent: Thursday, May 14, 2015 7:47 AM To: Li, Felix Subject: [rt.cpan.org #104425] Devel::Assert - Assert.xs:19:5: error: 'for' loop initial declarations are only allowed in C99 mode <URL: https://rt.cpan.org/Ticket/Display.html?id=104425 > On Thu May 14 07:46:31 2015, felix.li@bankofamerica.com wrote:
> Having a problem building Devel::Assert 1.04 on a Windows 7! (same > thing on a Window 8.1 with 32 bit Strawberry Perl )
> Assert.xs:19:5: error: 'for' loop initial declarations are only > allowed in C99 mode > for (PERL_CONTEXT* cx = cxstack + cxstack_ix; cx >= > cxstack; --cx) { > ^ > Assert.xs:19:5: note: use option -std=c99 or -std=gnu99 to compile > your code
Thanks for the report, I've fixed this particular error, but I don't have around Win box or gcc toolchain old enough, so I couldn't check for any other possible build incompatibilities. Please try 1.06 version. ---------------------------------------------------------------------- This message, and any attachments, is for the intended recipient(s) only, may contain information that is privileged, confidential and/or proprietary and subject to important terms and conditions available at http://www.bankofamerica.com/emaildisclaimer. If you are not the intended recipient, please delete this message.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.