Skip Menu |
 

This queue is for tickets about the Dist-Zilla-PluginBundle-Apocalyptic CPAN distribution.

Report information
The Basics
Id: 104091
Status: open
Priority: 0/
Queue: Dist-Zilla-PluginBundle-Apocalyptic

People
Owner: Nobody in particular
Requestors: dolmen [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.005
Fixed in: (no value)



Subject: PAUSE credentials should not be required
I would like to contribute a patch for Pod::Weaver::Section::Support, but I can't build your distribution:

$ dzil test --author
...
[@Apocalyptic/Authority] PAUSE credentials not found in "config.ini" or "dist.ini" or "~/.pause"! Please set it or specify an authority for this plugin.
[@Apocalyptic/Authority] PAUSE credentials not found in "config.ini" or "dist.ini" or "~/.pause"! Please set it or specify an authority for this plugin. at .../Moose/Meta/Method/Delegation.pm line 109.

The issues:
- a PAUSE account should not be required to contribute to your modules
- even if I have a PAUSE account, that should not be required to run author tests

-- 
Olivier Mengué - http://perlresume.org/DOLMEN - https://gratipay.com/dolmen/
Download (untitled) / with headers
text/plain 1.1k
On 2015-04-29 02:45:47, DOLMEN wrote: Show quoted text
> I would like to contribute a patch for Pod::Weaver::Section::Support, but I > can't build your distribution: > > $ dzil test --author > ... > [@Apocalyptic/Authority] PAUSE credentials not found in "config.ini" or > "dist.ini" or "~/.pause"! Please set it or specify an authority for this > plugin. > [@Apocalyptic/Authority] PAUSE credentials not found in "config.ini" or > "dist.ini" or "~/.pause"! Please set it or specify an authority for this > plugin. at .../Moose/Meta/Method/Delegation.pm line 109. > > The issues: > - a PAUSE account should not be required to contribute to your modules > - even if I have a PAUSE account, that should not be required to run author > tests > > -- > Olivier Mengué - http://perlresume.org/DOLMEN - https://gratipay.com/dolmen/
At the heart, the problem is in the [Authority] plugin. Arguably it should disable itself (with a noisy warning) if no PAUSE ID is configured for the plugin and there are no .pause credentials found, rather than refusing to build. But a plugin bundle should definitely provide a default for this value in all cases, or the individual distribution should pass a PAUSE ID to the plugin.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.