Skip Menu |
 

This queue is for tickets about the Lingua-EN-Fathom CPAN distribution.

Report information
The Basics
Id: 102898
Status: resolved
Priority: 0/
Queue: Lingua-EN-Fathom

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.17
Fixed in: (no value)



Subject: Prereq version for warnings too high
Download (untitled) / with headers
text/plain 164b
Build.PL and META.yml specify warnings => 1.12, which is not available for perl 5.12 and older. The other minimum version specifications are also probably too high.
Download (untitled) / with headers
text/plain 321b
I have had this issue come up before. If version numbers are too low, then some functionality may be missing. I use a standard set of prereq versions for most of my modules, and adopted this practice from another CPAN author. Perl 5.12 goes back to 2010, so that's quite a long time period in terms of software releases.
Download (untitled) / with headers
text/plain 711b
On 2015-03-27 22:02:55, KIMRYAN wrote: Show quoted text
> I have had this issue come up before. If version numbers are too low, > then some functionality may be missing. I use a standard set of prereq > versions for most of my modules, and adopted this practice from > another CPAN author.
Not a good practice. It's better to stick to known and verified minimum version requirements, then create dev releases and let cpantesters see if there are some problems. If there are known and verified version requirements, then these should be documented (e.g. in a comment in the PREREQ_PM section). Anyway, it seems that your problem passes the tests with older perls, see http://matrix.cpantesters.org/?dist=Lingua-EN-Fathom+1.17
Download (untitled) / with headers
text/plain 295b
Set the version number for warning to 0. As I can't see any changer history for this modulwe, don't know what other level to set it to. As the warnings pragma has beeb part of standard Perl for a long while, probably makes more sense not to specify in in the Makefile.PL and Build.PL in future


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.