Skip Menu |
 

This queue is for tickets about the Carp CPAN distribution.

Report information
The Basics
Id: 102835
Status: resolved
Priority: 0/
Queue: Carp

People
Owner: Nobody in particular
Requestors: shay [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.35
Fixed in: (no value)



Subject: Please sync with bleadperl
In the course of checking if bleadperl is currently in sync with CPAN modules I have found that Carp is out of sync: A single line is missing from lib/Carp/Heavy.pm in bleadperl, namely: $VERSION = eval $VERSION; (immediately underneath "our $VERSION = '1.35';"). I considered simply inserting the line into blead's copy to make them in sync but then 5.21.10's Heavy.pm would differ from 5.21.9's Heavy.pm, so I would need to bump the $VERSION... which would then make blead out of sync with CPAN again anyway. Therefore, could you please make a new CPAN release with no changes other than a $VERSION bump to 1.36? I can then bring that into bleadperl and we're back in sync again. (Alternatively, delete the extra line from the CPAN release (as well as bumping the $VERSION, obviously) if in fact the blead version is correct.) It would be great to have this before Friday 20th when 5.21.10 is released, but I dare say such a minor thing as a $VERSION bump would be allowed in afterwards if need be. (Note: You can also close off rt.cpan.org #97288 while you're at it.)
Download (untitled) / with headers
text/plain 241b
Whoops, my mistake. I need to look into antoher bug (#102784) and will try to sort these both out. It should be no problem to import Carp after the next release, or not at all until 5.23. At any rate, thanks for the information! -- rjbs
Sorted out now, I think! -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.