Skip Menu |
 

This queue is for tickets about the forks CPAN distribution.

Report information
The Basics
Id: 102730
Status: open
Priority: 0/
Queue: forks

People
Owner: RYBSKEJ [...] cpan.org
Requestors: dam [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



From: dam [...] cpan.org
Subject: Version check on Storable broken when version number is not numeric
Download (untitled) / with headers
text/plain 1.5k
We have the following bug reported to the Debian package of forks (https://bugs.debian.org/780351): It doesn't seem to be a bug in the packaging, so you may want to take a look. Thanks! ------8<-----------8<-----------8<-----------8<-----------8<----- Package: libforks-perl Version: 0.36-1+b1 Severity: normal Dear Maintainer, Line 1570 on forks.pm has this: local $Storable::Deparse = 1 if $Storable::VERSION >= 2.05; So I get the following problem on use: expo$~>perl -Mforks Argument "2.49_01" isn't numeric in numeric ge (>=) at /usr/lib/x86_64-linux-gnu/perl5/5.20/forks.pm line 1570. Since the version apparantly is 2.49_01 and not 2.49, which means that this version of forks is not usable right now. -- System Information: Debian Release: 8.0 APT prefers testing APT policy: (500, 'testing') Architecture: amd64 (x86_64) Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores) Locale: LANG=en, LC_CTYPE=sv_SE (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8) Shell: /bin/sh linked to /bin/dash Init: systemd (via /run/systemd/system) Versions of packages libforks-perl depends on: ii libacme-damn-perl 0.05-1+b3 ii libc6 2.19-15 ii liblist-moreutils-perl 0.33-2+b1 ii libsys-sigaction-perl 0.20-1 ii perl 5.20.2-2 ii perl-base [perlapi-5.20.0] 5.20.2-2 libforks-perl recommends no packages. libforks-perl suggests no packages. -- no debconf information ------8<-----------8<-----------8<-----------8<-----------8<----- Thanks for considering, Damyan Ivanov, Debian Perl Group
Download (untitled) / with headers
text/plain 633b
On 2015-03-12 10:39:54, DAM wrote: Show quoted text
> We have the following bug reported to the Debian package of forks > (https://bugs.debian.org/780351): > > It doesn't seem to be a bug in the packaging, so you may want to take > a look. Thanks! > > ------8<-----------8<-----------8<-----------8<-----------8<----- > > Package: libforks-perl > Version: 0.36-1+b1 > Severity: normal > > Dear Maintainer, > > Line 1570 on forks.pm has this: > > local $Storable::Deparse = 1 if $Storable::VERSION >= 2.05;
You can fix with: .... if eval { Storable->VERSION('2.05') }; which is a more preferable form of checking versions in general, anyway.
From: blue [...] thisisnotmyrealemail.com
Download (untitled) / with headers
text/plain 942b
On Thu Mar 12 14:36:17 2015, ETHER wrote: Show quoted text
> On 2015-03-12 10:39:54, DAM wrote:
> > We have the following bug reported to the Debian package of forks > > (https://bugs.debian.org/780351): > > > > It doesn't seem to be a bug in the packaging, so you may want to take > > a look. Thanks! > > > > ------8<-----------8<-----------8<-----------8<-----------8<----- > > > > Package: libforks-perl > > Version: 0.36-1+b1 > > Severity: normal > > > > Dear Maintainer, > > > > Line 1570 on forks.pm has this: > > > > local $Storable::Deparse = 1 if $Storable::VERSION >= 2.05;
> > You can fix with: > > .... if eval { Storable->VERSION('2.05') }; > > which is a more preferable form of checking versions in general, anyway.
This is more of an issue now that the latest stable perl version is using a version of Storable which triggers this warning. From 5.22.01 perldelta: o Storable has been upgraded from version 2.53 to 2.53_01.
Download (untitled) / with headers
text/plain 597b
Show quoted text
> This is more of an issue now that the latest stable perl version is > using a version of Storable which triggers this warning.
Versions of Perl modules are allowed to contain an underscore. The bug is in forks.pm. The correct way to fix it is: use version; my $storable_version = version->parse($Storable::VERSION); my $storable_preferred = version->parse('2.05'); local $Storable::Deparse = 1 if $storable_version >= local $Storable::Eval = 1 if $storable_version >= version->parse('2.05');
Download (untitled) / with headers
text/plain 725b
On 2016-05-03 11:06:50, POPEL wrote: Show quoted text
> > This is more of an issue now that the latest stable perl version is > > using a version of Storable which triggers this warning.
> > Versions of Perl modules are allowed to contain an underscore. > The bug is in forks.pm. > The correct way to fix it is: > > use version; > my $storable_version = version->parse($Storable::VERSION); > my > $storable_preferred = version->parse('2.05'); > local $Storable::Deparse = 1 if $storable_version >= > local $Storable::Eval = 1 if $storable_version >= version-
> >parse('2.05');
This looks incomplete. $storable_preferred is nowhere used.
Download (untitled) / with headers
text/plain 1.7k
Hi, I tried to create a patch with another approach. Thank you, -- twata On 2015-3月-12 木 13:39:54, DAM wrote: Show quoted text
> We have the following bug reported to the Debian package of forks > (https://bugs.debian.org/780351): > > It doesn't seem to be a bug in the packaging, so you may want to take > a look. Thanks! > > ------8<-----------8<-----------8<-----------8<-----------8<----- > > Package: libforks-perl > Version: 0.36-1+b1 > Severity: normal > > Dear Maintainer, > > Line 1570 on forks.pm has this: > > local $Storable::Deparse = 1 if $Storable::VERSION >= 2.05; > > So I get the following problem on use: > > expo$~>perl -Mforks > Argument "2.49_01" isn't numeric in numeric ge (>=) at > /usr/lib/x86_64-linux-gnu/perl5/5.20/forks.pm line 1570. > > Since the version apparantly is 2.49_01 and not 2.49, which means that > this version of forks is not usable right now. > > -- System Information: > Debian Release: 8.0 > APT prefers testing > APT policy: (500, 'testing') > Architecture: amd64 (x86_64) > > Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores) > Locale: LANG=en, LC_CTYPE=sv_SE (charmap=UTF-8) (ignored: LC_ALL set > to en_US.UTF-8) > Shell: /bin/sh linked to /bin/dash > Init: systemd (via /run/systemd/system) > > Versions of packages libforks-perl depends on: > ii libacme-damn-perl 0.05-1+b3 > ii libc6 2.19-15 > ii liblist-moreutils-perl 0.33-2+b1 > ii libsys-sigaction-perl 0.20-1 > ii perl 5.20.2-2 > ii perl-base [perlapi-5.20.0] 5.20.2-2 > > libforks-perl recommends no packages. > > libforks-perl suggests no packages. > > -- no debconf information > > > ------8<-----------8<-----------8<-----------8<-----------8<----- > > > Thanks for considering, > Damyan Ivanov, > Debian Perl Group
Subject: forks-0.36-rt102730.patch
--- forks-0.36/lib/forks.pm 2014-06-27 11:47:00.000000000 +0900 +++ forks-0.36-patched/lib/forks.pm 2019-04-14 17:04:03.670000002 +0900 @@ -1567,8 +1567,10 @@ # Localize Storable variables to allow CODE refs, if using Storable >= 2.05 - local $Storable::Deparse = 1 if $Storable::VERSION >= 2.05; - local $Storable::Eval = 1 if $Storable::VERSION >= 2.05; + my $storable_version = $Storable::VERSION; + $storable_version =~ s/_.*//; + local $Storable::Deparse = 1 if $storable_version >= 2.05; + local $Storable::Eval = 1 if $storable_version >= 2.05; # Initialize the number of polls # While we're running in the main dispatch loop


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.