Skip Menu |
 

This queue is for tickets about the RT-Extension-ExtractCustomFieldValues CPAN distribution.

Report information
The Basics
Id: 102398
Status: new
Priority: 0/
Queue: RT-Extension-ExtractCustomFieldValues

People
Owner: Nobody in particular
Requestors: guadagnino.cristiano [...] creval.it
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Error in "make upgrade-database" ?
Date: Fri, 27 Feb 2015 12:47:09 +0000
To: "bug-RT-Extension-ExtractCustomFieldValues [...] rt.cpan.org" <bug-RT-Extension-ExtractCustomFieldValues [...] rt.cpan.org>
From: Guadagnino Cristiano <guadagnino.cristiano [...] creval.it>
Download (untitled) / with headers
text/plain 1.7k
I'm trying to upgrade from v3.07 to v3.13. I am advised to use "make upgrade-database" for upgrades. When I run "make upgrade-database" I am asked the version I'm upgrading from, however, upon replying I get this: Enter RT::Extension::ExtractCustomFieldValues version you're upgrading from: 3.07 Doesn't match #.#.#: 3.0.7 [4592] [Fri Feb 27 11:07:03 2015] [critical]: ERROR: No upgrade data found in './etc/upgrade'! Perhaps you specified the wrong --datadir? (/opt/rt4/sbin/../lib/RT.pm:388) ERROR: No upgrade data found in './etc/upgrade'! Perhaps you specified the wrong --datadir? ...returned with error: 65280 make: *** [upgrade-database] Error 2 I looked in the /etc/upgrade directory. Here are the contents: drwxr-xr-x 2 1000 1000 4096 Dec 16 21:55 3.06 and in the "3.06" directory there is: -rw-r--r-- 1 1000 1000 273 Oct 3 2009 content I looked into the "content" script too, and saw that it tries to create a new ScripAction ExtractCustomFieldValuesWithCodeInTemplate. Seeing that I do not have that ScripAction on my system (maybe I forgot to run "make upgrade-database" when upgrading to v3.07) I decided to try again the command as if I was upgrading from v3.06. Again, I get this error: Enter RT::Extension::ExtractCustomFieldValues version you're upgrading from: 3.06 Doesn't match #.#.#: 3.0.6 [4759] [Fri Feb 27 11:21:17 2015] [critical]: ERROR: No upgrade data found in './etc/upgrade'! Perhaps you specified the wrong --datadir? (/opt/rt4/sbin/../lib/RT.pm:388) ERROR: No upgrade data found in './etc/upgrade'! Perhaps you specified the wrong --datadir? ...returned with error: 65280 make: *** [upgrade-database] Error 2 At which point I gave up. Regards Cris


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.